Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Missing /etc/adjtime resets clock to UTC after reboot

  1. #1

    Default Missing /etc/adjtime resets clock to UTC after reboot

    Hello

    I've installed openSuse 12.2 x64 on my laptop. During the setup process i unchecked the 'Set hardware clock to UTC' option. But now, after finishing the installation i've found this bug [Bug 779440] New: /etc/adjtime not created during installation; can't se . Due to unchecking of the option (and missing /etc/adjtime), I'm unable to set my hw clock to local time. 'Set hardware clock to UTC' gets selected after every restart. While sorting the bug is being worked out, can i manage with copying the /etc/adjtime file from another installation and set things right? If yes, could someone please post the file...

    Expecting an easy fix to the problem!

    thanks.

    Abhishek

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    On 09/27/2012 02:26 PM, abhitheaviator wrote:
    >
    > Hello
    >
    > I've installed openSuse 12.2 x64 on my laptop. During the setup
    > process i unchecked the 'Set hardware clock to UTC' option. But now,
    > after finishing the installation i've found this bug '[Bug 779440] New:
    > /etc/adjtime not created during installation; can't se'
    > (http://lists.opensuse.org/opensuse-b.../msg00918.html) . Due to
    > unchecking of the option (and missing /etc/adjtime), I'm unable to set
    > my hw clock to local time. 'Set hardware clock to UTC' gets selected
    > after every restart. While sorting the bug is being worked out, can i
    > manage with copying the /etc/adjtime file from another installation and
    > set things right? If yes, could someone please post the file...
    >
    > Expecting an easy fix to the problem!


    finger@larrylap:~> cat /etc/adjtime
    0.0 0 0.0
    0
    UTC



  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    Quote Originally Posted by abhitheaviator View Post
    Hello

    I've installed openSuse 12.2 x64 on my laptop. During the setup process i unchecked the 'Set hardware clock to UTC' option. But now, after finishing the installation i've found this bug [Bug 779440] New: /etc/adjtime not created during installation; can't se . Due to unchecking of the option (and missing /etc/adjtime), I'm unable to set my hw clock to local time. 'Set hardware clock to UTC' gets selected after every restart. While sorting the bug is being worked out, can i manage with copying the /etc/adjtime file from another installation and set things right? If yes, could someone please post the file...

    Expecting an easy fix to the problem!

    thanks.

    Abhishek
    Have a look here as well: What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its solution. - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    Quote Originally Posted by jdmcdaniel3 View Post
    I am having the same kind of problem as abhitheaviator. Using openSUSE 12.2, 64-bit, with KDE desktop environment. Fairly inexperienced user.

    When I enter the command:
    Code:
    sudo echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    I get "Permission denied".

    What am I doing wrong?

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    Am 30.09.2012 02:16, schrieb tb75252:
    > When I enter the command:
    > Code:
    > --------------------
    > sudo echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    > --------------------
    > I get "*Permission denied*".
    >
    > What am I doing wrong?
    >
    >

    At the moment when the redirect (the >) is performed you have no longer
    root rights (sudo ends before that point on your command line).
    Try
    Code:
    su -
    echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    instead.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
    eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Missing /etc/adjtime resets clock to UTC after reboot

    Quote Originally Posted by tb75252 View Post
    I am having the same kind of problem as abhitheaviator. Using openSUSE 12.2, 64-bit, with KDE desktop environment. Fairly inexperienced user.

    When I enter the command:
    Code:
    sudo echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    I get "Permission denied".

    What am I doing wrong?
    Give this a try instead:

    Code:
    su -
    password:
    echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    Quote Originally Posted by martin_helm View Post
    Am 30.09.2012 02:16, schrieb tb75252:
    > When I enter the command:
    > Code:
    > --------------------
    > sudo echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    > --------------------
    > I get "*Permission denied*".
    >
    > What am I doing wrong?
    >
    >

    At the moment when the redirect (the >) is performed you have no longer
    root rights (sudo ends before that point on your command line).
    Try
    Code:
    su -
    echo -e "0.0 0 0.0\n0\nLOCAL" > /etc/adjtime
    instead.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
    eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10
    Thank you, that worked!

    Unfortunately, there's no change in the system clock issue... The BIOS clock still get set 5 hours ahead of local time and that interferes with the time displayed when booting up Windows 7.

    If anyone has another suggestion, please speak up!

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Missing /etc/adjtime resets clock to UTC after reboot

    Let us have a look at the process. First we start YaST:



    Hardware Clock set to UTC is unchecked. Make sure the correct time zone is checked. Now lets select the Change Button:



    Here is what I have in Change Date & Time Window. Next I hit the Configure button:



    I removed the undisciplined local clock after I made sure I could contact the selected Server.



    Then I pressed OK, Accept and OK again as I remember.

    Thank You,
    Last edited by jdmcdaniel3; 29-Sep-2012 at 18:37.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    On 2012-09-30 03:06, tb75252 wrote:

    > Thank you, that worked!
    >
    > Unfortunately, there's no change in the system clock issue... The BIOS
    > clock still get set 5 hours ahead of local time and that interferes with
    > the time displayed when booting up Windows 7.


    After the change, you must make sure that the system time is copied to the cmos clock, and that
    after making sure that the system time is correct.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10

    Default Re: Missing /etc/adjtime resets clock to UTC after reboot

    Thank you for the detailed instructions.
    Followed all your instructions and made sure that I also set the correct time/date in the BIOS. Unfortunately every time that I boot up openSUSE the CMOS clock gets set to UTC time...

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •