Results 1 to 7 of 7

Thread: kwallet either doesn't start up or doesn't open a wallet

  1. #1
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default kwallet either doesn't start up or doesn't open a wallet

    Since two or three days ago kwallet is not working. It doesn't start up (the icon is not in systemtray) or if it starts up I'm unable to open a wallet.
    I tried deleting ~/.kde4/share/config/kwallet* and ~/kde4/apps/kwallet but what happens now is that the configuration wizard starts and seems to finish normally, but when an application tries to open a wallet I see again the last window of the wizard but the wallet doesn't open. Next time an application tries to use kwallet the same thing happens again and it goes always like that.

    As a result, other applications like smb4k don't work properly, because they don't manage to open the wallet.

    I don't know what else to do. If somebody has an idea, I would be grateful.

    opensuse 12.1 kde 4.9.1

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    Review the configuration in

    System Settings>> Account Details >> KDE Wallet

  3. #3
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    I disabled the kwallet system where you say. Then I enabled it again. With little faith, I must say.
    But it worked.
    I can't understand why it didn't work before, but...
    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    Quote Originally Posted by wrbbt View Post
    I disabled the kwallet system where you say. Then I enabled it again. With little faith, I must say.
    But it worked.
    I can't understand why it didn't work before, but...
    Thanks
    Good it's back on track again
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    I'm glad it was trivial

  6. #6
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    41

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    I am running openSUSE 12.3 and my KWallet stopped working. I could not open it and, after deleting kdewallet, I could not create it again. Creation steps would go through without error, but without wallet creation, as described by the OP.

    Problem was solved the same way by disabling, then re-enabling KWallet.
    Thanks!
    ------------- FATAL ERROR: COFFEE NOT FOUND --- SYSTEM HALTED ---------------

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: kwallet either doesn't start up or doesn't open a wallet

    Problem was solved the same way by disabling, then re-enabling KWallet.
    Thanks!
    Good for you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •