Results 1 to 6 of 6

Thread: OpenGL Compositing Crashing KWin

  1. #1

    Default OpenGL Compositing Crashing KWin

    Hey! I recently installed openSUSE 12.2 and have gotten most things working/driver **** taken care of. However, I haven't been able to get Desktop effects to function. When I open up the "Configure Desktop Effects" application I'm greeted by the following error:

    Desktop effects are not available on this system due to the following technical issues:


    OpenGL compositing (the default) has crashed KWin in the past.
    This was most likely due to a driver bug.

    If you think that you have meanwhile upgraded to a stable driver,
    you can reset this protection but be aware that this might result in an immediate crash!
    Alternatively, you might want to use the XRender backend instead.

    Below that error message is a button to re-enable OpenGL detection (above the button it says "Pressing this button can crash the desktop.") Whenever I press it it... crashes the desktop, logs me out and sends me back to the login screen.

    I've researched the problem a little bit and apparently it has something to with the kdebase-workspace package, but I haven't been able to figure out exactly what to do.

    I'd rather not switch to XRender because I've heard it works like **** with Nvidia.


    Anyhow, if it helps, I have an Nvidia Geforce GT240M and am using this driver: NVIDIA DRIVERS 304.51Certified

    Thanks!

    -ascii234

  2. #2

    Default Re: OpenGL Compositing Crashing KWin

    Might be the same problem: http://forums.opensuse.org/english/g...pt-2012-a.html
    try to reinstall the nvidia-driver

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: OpenGL Compositing Crashing KWin

    Quote Originally Posted by ascii234 View Post
    Hey! I recently installed openSUSE 12.2 and have gotten most things working/driver **** taken care of. However, I haven't been able to get Desktop effects to function. When I open up the "Configure Desktop Effects" application I'm greeted by the following error:

    Desktop effects are not available on this system due to the following technical issues:


    OpenGL compositing (the default) has crashed KWin in the past.
    This was most likely due to a driver bug.

    If you think that you have meanwhile upgraded to a stable driver,
    you can reset this protection but be aware that this might result in an immediate crash!
    Alternatively, you might want to use the XRender backend instead.

    Below that error message is a button to re-enable OpenGL detection (above the button it says "Pressing this button can crash the desktop.") Whenever I press it it... crashes the desktop, logs me out and sends me back to the login screen.

    I've researched the problem a little bit and apparently it has something to with the kdebase-workspace package, but I haven't been able to figure out exactly what to do.

    I'd rather not switch to XRender because I've heard it works like **** with Nvidia.


    Anyhow, if it helps, I have an Nvidia Geforce GT240M and am using this driver: NVIDIA DRIVERS 304.51Certified

    Thanks!

    -ascii234
    I had this happen and I had KDE switching to XRENDER on me as well. The nVIDIA driver would show 2D only when KDE did run. Finally, I downloaded the latest nVIDIA driver, I logged out of KDE, did an Alt-F1 to switch to terminal, logged in as root, issued an INIT 3 command to make sure desktop was not loaded and then installed the latest nVIDIA driver 304.51 using my lnvhw bash script again. I restarted my PC and on startup of KDE, I went in and switch XRENDER to OPENGL in menu / Configure Desktop / Desktop Effects / Advanced Tab / Compositing Type. The first time I got some error message after the switch, but I just logged out of KDE and back in and the problem has went away, for now it would seem.

    Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

    AND

    LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: OpenGL Compositing Crashing KWin

    Thanks jdmcdaniel3, that worked! Sorry this is such a late response, but I've been too busy and lazy to actually reinstall the drivers until today. Anyhow, everything is working now, though the animations are a little laggy at times.

    All the best,
    ascii234

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: OpenGL Compositing Crashing KWin

    Quote Originally Posted by ascii234 View Post
    Thanks jdmcdaniel3, that worked! Sorry this is such a late response, but I've been too busy and lazy to actually reinstall the drivers until today. Anyhow, everything is working now, though the animations are a little laggy at times.

    All the best,
    ascii234
    Hey, happy to hear of your success. We all have things going on and coming back here may be at the bottom of the list. None-the-less, your confirmation of a fix may also help someone else as well who reads this message. Please let us know if we can be of any other assistance to you.

    Thank You,.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: OpenGL Compositing Crashing KWin

    I had the same problem after an automatic Apper update (the first time I've seen Apper operate all by itself - don't know why this should be so). I have an ATI Radeon 4800, OpenSuse 12.2, KDE 4.8.5 (4.8.5) "release 2", 64-bit machine. The desktop effects had been set to XRender suddenly after the update. I changed it back, got the warning again, and simply went ahead. Everything is working fine.
    I don't know whether this bit of info will be of help to anyone, but I hope so.
    Thanks in any case to all who have posted here, it is always a pleasure to know that there is help available.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •