Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Impossible de démarrer Windows après installation d'OpenSUS

  1. #11
    Join Date
    Sep 2012
    Posts
    5,185

    Default Re: Impossible de démarrer Windows après installation d'OpenSUS

    Quote Originally Posted by please_try_again View Post
    Yes, you have to blank the mbr and the GPT headers.
    No, just replace it with protective MBR:
    Code:
    gdisk /dev/sda
    x
    n
    w
    It should work now. If not, it is always time to reinstall. You can install gdisk in openSUSE using "zypper install gptfdisk". Double check that it is the right HDD with Windows. If you do the same for second disk with openSUSE, it will be unbootable too ...

    But I am surprised that the second disk is actually MBR. I would not expect it on UEFI system ... or legacy boot was selected to boot openSUSE installation DVD.

  2. #12

    Default Re: Impossible de démarrer Windows après installation d'OpenSUS

    Quote Originally Posted by arvidjaar View Post
    No, just replace it with protective MBR:
    Code:
    gdisk /dev/sda
    x
    n
    w
    It believe that @wkolar didn't try that in the other thread because it should have worked:

    Quote Originally Posted by wkolar View Post
    The gdisk (gpt fdisk) was version 0.8.5. I added new partitions fine, but gdisk did not touch the bogus protective mbr.

    Quote Originally Posted by arvidjaar View Post
    But I am surprised that the second disk is actually MBR. I would not expect it on UEFI system ... or legacy boot was selected to boot openSUSE installation DVD.
    Look at the size! It's a USB stick.

  3. #13

    Default Re: Impossible de démarrer Windows après installation d'OpenSUS

    Quote Originally Posted by arvidjaar View Post
    No, just replace it with protective MBR:
    Well, it depends if we're talking about reinstalling WIndows or reparing it. If you're going to reinstall it, blanking the first track is just fine. If you only want to be able to reboot it without reinstalling, fixing the MBR is the right way to go.

  4. #14

    Default Re: Impossible de démarrer Windows après installation d'OpenSUS

    Okay, so I blanked as please_try_again advised me to, and then reinstalled Windows : it now works perfectly, thanks!
    I'll just follow the guide for OpenSUSE hoping I won't encounter another issue.
    Thank you.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •