Results 1 to 6 of 6

Thread: Desktop Folder View does not display application icons

  1. #1

    Default Desktop Folder View does not display application icons

    I've recently upgraded to OpenSUSE 12.2 (64-bit) and KDE 4.9. Since then, the Folder View plasmoid for my Desktop folder only displays the default KDE gearwheel icon for all the apps in the folder. I've tried enabling preview for desktop files in the Folder View settings but that then shows the textual content of the file rather than the icon. The Properties dialog for each of the folder entries shows that the correct icon is set.

    Any ideas?

  2. #2

    Default Re: Desktop Folder View does not display application icons

    We have the same problem, but with KDE 4.8.5. However, our kde-folder is ~/.kde4/ instead of ~/.kde/. Is that also true in your case, lauranon? Until now we only know, that deleting the home folder does not help.

    Additionally I want to say, that also Dolphin does not show the icons, when going to ~/Desktop/, but nautilus does. Maybe someone has a hint for us. Thanks in advance.

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Desktop Folder View does not display application icons

    Quote Originally Posted by lauranon View Post
    I've recently upgraded to OpenSUSE 12.2 (64-bit) and KDE 4.9. Since then, the Folder View plasmoid for my Desktop folder only displays the default KDE gearwheel icon for all the apps in the folder. I've tried enabling preview for desktop files in the Folder View settings but that then shows the textual content of the file rather than the icon. The Properties dialog for each of the folder entries shows that the correct icon is set.

    Any ideas?
    Normally, the problem has to do with permissions but in an upgrade, can have to do with missing icons as well. The permission problem normally has to do with the icon picture file its self most of which are located in the folder /usr/share/icons/. As to where the program start icon might be located, the old place, which still works is $HOME/Desktop, but with KDE 4 can also be $HOME/.local/share/applications. These are then special text files, marked executable that, among other things, point to the name of an icon picture file, located somewhere else on your PC. Normally, if you can right click on the icon and use open with Kwrite, its probably located in $HOME/Desktop, but you can change where this folder actually looks. Sometimes I find just recreating the program icon works best over any other solution. You can copy icons from $HOME/.local/share/applications to $HOME/Desktop if you wish. This type of problem is common on openSUSE upgrades, KDE Desktop upgrades and when more than one user uses the same PC and then it gets upgraded. If you find the location of the icon picture file, I have a bash script that can be helpful in determining how permissions work on that file.

    S.A.F.P. - SUSE Automated File Permissions - Version 1.0.4 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Desktop Folder View does not display application icons

    Yes, my kde folder is ~/.kde4/

    I had a look at the desktop files. The "Icon" setting is a simple name e.g. "rekonq". I tried changing that to an absolute pathname pointing to an existing, readable icon e.g. "/usr/share/icons/hicolor/64x64/apps/rekonq.png" but that made no difference to the Folder View display

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Desktop Folder View does not display application icons

    Quote Originally Posted by lauranon View Post
    Yes, my kde folder is ~/.kde4/

    I had a look at the desktop files. The "Icon" setting is a simple name e.g. "rekonq". I tried changing that to an absolute pathname pointing to an existing, readable icon e.g. "/usr/share/icons/hicolor/64x64/apps/rekonq.png" but that made no difference to the Folder View display
    I don't have rekong installed, but using my safp bash script, you could determine its permissions with the the command:

    Code:
    safp /usr/share/icons/hicolor/64x64/apps/rekonq.png
    As for the hidden folder ~/.kde4, we all have that folder, but that is not exactly where your desktop icons are kept.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: Desktop Folder View does not display application icons

    OK, thank you for your answers. I was further looking around for the origin of the problem and found a bug report, which describes the problem. To make it short:
    Icons of .desktop-files only work in local folders, but not in NFS-mounted folders (like my home folder), since KDE 4.7.3 or 4.7.4.

    Possible workarounds:
    1. change some KDE code as suggested in the bug report (link, see above)!? ;-)
    2. use symbolic links to local .desktop-files (e.g. by dragging from the K starter menu while holding ctrl+shift)
    3. use symbol-widgets instead of a folder view, by right clicking in the K starter menu on a symbol and say "add to desktop" (or similar)

    I hope someone knows how and is willing to fix it - for all users.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •