Results 1 to 7 of 7

Thread: could not start ksmserver check your installation

  1. #1

    Default could not start ksmserver check your installation

    using opensuse tumbleweed, I updated from kde4.9.0 to kde 4.9.1 (switch package of kde49 repository), at restart "could not start ksmserver check your installation" message appear in the upper left of screen, at center a kde bug report box with this detail: "executable kdeinit4 PID 2564 signal: segmentation fault(11)", if I click close on kde bug report box and ok on the upper left message the nvidia logo appear and the login screen appear again, if I login in XFCE it's ok, if I login in LXDE it's ok. how can I have again my amazing kde4 evironment??? thnx P :-))

  2. #2

    Default Re: could not start ksmserver check your installation

    On 09/23/12 05:06, pier andreit pecked at the keyboard and wrote:
    > using opensuse tumbleweed, I updated from kde4.9.0 to kde 4.9.1 (switch
    > package of kde49 repository), at restart "could not start ksmserver
    > check your installation" message appear in the upper left of screen, at
    > center a kde bug report box with this detail: "executable kdeinit4 PID
    > 2564 signal: segmentation fault(11)", if I click close on kde bug report
    > box and ok on the upper left message the nvidia logo appear and the
    > login screen appear again, if I login in XFCE it's ok, if I login in
    > LXDE it's ok. how can I have again my amazing kde4 evironment??? thnx P
    > :-))
    >
    >


    DO NOT use any repo that is not specifically created for tumbleweed,
    doing so can/will mess up your system.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,789
    Blog Entries
    14

    Default Re: could not start ksmserver check your installation

    First try and see if the problem exists for a newly created user.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: could not start ksmserver check your installation

    Quote Originally Posted by Knurpht View Post
    First try and see if the problem exists for a newly created user.
    yes the problem persist also with a newly created user.
    thanks:-)

  5. #5

    Default Re: could not start ksmserver check your installation

    Hi, after logging in my kdeinit4 crashes to.

    I use KDE 4.9.1 on openSUSE 12.2 and it started with this today.



    The last time I was logged in (couple of days) my themes seemed broken, picking opensuse air for instance gave transparancy on a left vertical panel but not on the top horisontal one. As a remedy of this I tried to "reinstall unconditionally" or whatever for some kdebase and libkde packages and their branding. All of them are from x86_64 KDE49 repository.

    Logged out and then both kwin and kdeinit4 crashed. I've done the same for the packages again and now all I get is kdeinit4 for whatever reason.


    I don't know whatever I'm the cause of this or not because earlier I also got an update of a bunch of ktp packages so I wonder if that may have anything to do with it? I'm thought about disabling ktp/telepathy but I don't know how to do that except disable the accounts.

    I don't really know where to go from here. Remove all KDE packages and install them again is one way.

    Currently running razor-qt with openbox instead (kwin crashed now and then if using kwin with it.)

  6. #6

    Default Re: could not start ksmserver check your installation

    Btw my repos:

    # | Alias | Name | Enabled | Refresh
    ---+-------------------------------------------------+-------------------------------------------------+---------+--------
    1 | Packman | Packman | Yes | Yes
    2 | QTdesktop_1 | QTdesktop | Yes | Yes
    3 | SuSE | VideoLAN | No | Yes
    4 | nvidia | nvidia | Yes | Yes
    5 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | Yes | Yes
    6 | openSUSE-12.2-KDE-Extra | openSUSE-12.2-KDE-Extra | No | Yes
    7 | openSUSE-12.2-KDE-Unstable-Playground-Telepathy | openSUSE-12.2-KDE-Unstable-Playground-Telepathy | No | Yes
    8 | openSUSE-12.2-KDE-Updates | openSUSE-12.2-KDE-Update | No | Yes
    9 | openSUSE-12.2-KDE49 | openSUSE-12.2-KDE49 | Yes | Yes
    10 | openSUSE-12.2-KDE49-Extra | openSUSE-12.2-KDE49-Extra | Yes | Yes
    11 | openSUSE-12.2-Multimedia-Apps | openSUSE-12.2-Multimedia-Apps | Yes | Yes
    12 | repo-debug | openSUSE-12.2-Debug | No | Yes
    13 | repo-debug-update | openSUSE-12.2-Update-Debug | No | Yes
    14 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No | Yes
    15 | repo-non-oss | openSUSE-12.2-Non-Oss | Yes | Yes
    16 | repo-source | openSUSE-12.2-Source | No | Yes
    17 | repo-update | openSUSE-12.2-Update | Yes | Yes
    18 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss | Yes | Yes


    Update hold newer branding packages + kdebase4 and kdebase4-branding-opensuse I believe.

    Packman hold newer gstreamer and libgst* packages.

  7. #7

    Default Re: could not start ksmserver check your installation

    I think I solved deleting kde49 repo, switching everything to tumbleweed repo, had a problem with kdm, changed the theme to opensuse, and solved, but now I'm with kde4.8.5 :-((, I will try to use kde49 rpos at december when I have more time to solve problems:-))
    many thanx, ciao, pier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •