Results 1 to 8 of 8

Thread: CUPS 1.5.0

  1. #1

    Exclamation CUPS 1.5.0

    I am almost ready to give up SuSE and go back to the devil (windoz) because of CUPS. When I installed SuSE 12.1 (and all previous versions I have used). I could print well. I use an HP DJ 4160 and use the HP drivers which includes HP device manager. For some unknown reason after many months when I print I get a notification that the print job started then a couple of seconds go by and I get a second notification that the print job completed but the printer does nothing. I go into HP device manager and go to status and the latest status is the printer is idle, the previous status is print job has completed. When I go to the Printer Control tab is says that the printer halted and when I click on the start/stop printer button it says could not connect to CUPS is user in lp group. The answer should be yes but nothing happens. When I try to go to Cups configuration there is no apparent way to add user to any group. Sometimes when I go into Yast and resetup the printer I am able to print for a short time ( a couple of days to a couple of weeks). I don't want to go back to windoz but this time I had no choice but to use windoz to print my document. HELP!

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,852
    Blog Entries
    14

    Default Re: CUPS 1.5.0

    Please post output of
    Code:
    lpstat -t
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: CUPS 1.5.0

    scheduler is running
    system default destination: Deskjet-D4100-series
    device for Deskjet-D4100-series: hp:/usb/Deskjet_D4100_series?serial=TH6B1D30TN04D6
    device for Deskjet_D4100: hp:/usb/Deskjet_D4100_series?serial=TH6B1D30TN04D6
    Deskjet-D4100-series accepting requests since Tue 25 Sep 2012 03:46:32 PM EDT
    Deskjet_D4100 accepting requests since Tue 25 Sep 2012 02:58:33 PM EDT
    printer Deskjet-D4100-series is idle. enabled since Tue 25 Sep 2012 03:46:32 PM EDT
    /usr/lib/cups/filter/pstoraster failed
    printer Deskjet_D4100 is idle. enabled since Tue 25 Sep 2012 02:58:33 PM EDT
    /usr/lib/cups/filter/pstoraster failed
    Deskjet-D4100-series-43 unknown 353280 Tue 25 Sep 2012 02:27:45 PM EDT
    Deskjet_D4100-45 jim 50176 Tue 25 Sep 2012 02:58:32 PM EDT
    Deskjet-D4100-series-46 jim 50176 Tue 25 Sep 2012 03:46:29 PM EDT

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: CUPS 1.5.0

    No idea if it relates to your problem, but...

    In a recently installed oS 12.1 64-bit KDE 4.9 I also couldn't print to an hp deskjet, although the previous version (oS 11.3) had no problems. But hp-setup would report an error and ask if the user belonged to group sys, which he didn't, only to lp. Adding him to sys solved the problem.

    YMMV

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: CUPS 1.5.0

    When I try to go to Cups configuration there is no apparent way to add user to any group.
    You can add yourself to a group with the 'groupmod' command.
    For example, add user 'dean' to 'sys' group
    Code:
    su -
    Enter root password when prompted, then
    Code:
    groupmod sys -A dean
    For lp group membership
    Code:
    group sys -A dean
    The graphical tool for doing this is

    YaSY>> Security and Users>>User and Group Management...

  6. #6

    Default Re: CUPS 1.5.0

    OK, I had a similar problem. Probably after an update (I use Opensuse current), my system stopped to see all network printers. When I added myself to a group 'sys', the problem has been solved. Does anybody know why I had to do it? It used to work earlier even when I wasn't in the group 'sys'.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: CUPS 1.5.0

    This requirement is defined in /etc/cups/cupsd.conf
    Code:
    LogLevel warn
    SystemGroup sys root
    Listen localhost:631
    Listen /var/run/cups/cups.sock
    Browsing On
    .
    .
    .
    You can change it as you'd like, but it is all part of improving security practices.

    See here:

    http://www.cups.org/documentation.ph...upsd-conf.html
    Last edited by deano_ferrari; 09-Oct-2012 at 16:34.

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: CUPS 1.5.0

    I used to have this problem in 12.1 (an other printing probs) and if I remember correctly the culprit was ghostscript - not cups.

    Troubleshooting with HP they confirmed there is a bug in ghostscript 9.02 (which ships with OS 12.1) and HPLIP does not play nicely with it.

    I'd recommend switching all files to this repo and see if that helps

    Index of /repositories/Printing/openSUSE_12.1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •