Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: shutdown does not power off

  1. #1

    Unhappy shutdown does not power off

    I installed openSuse 12.2 on a hp pavilion product name p6-2027de equipped with an AMD A6-3600 processor. Bios: HOL_706
    I did the last online update via yast yesterday. The bootloader is grub2 integration the EFI partition.

    The system does not power off when doing a shutdown (using the graphical interface and on the command line as well). A restart works properly. Booting into recovery mode via grub2 Advanced options ... no success when shutting down.
    Booting a knoppix live CD (7.0.3) and issueing a shutdown from there, powers off the machine.

    I tested the 12.1 RC 2 in the past showing the same symptoms.
    I did not test a previous version(11.4) of openSuSEtoo much because of graphic drives were not working as expected.

    Did anybody made similar experiences ? On a similar PC ?
    I tried: acpi=off ... apm=power-off (picked up form knoppix's /proc/cmdline .... no success
    Any suggestions ?

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: shutdown does not power off

    in yast - system - /etc/sysconfig Editor is

    DISPLAYMANAGER_SHUTDOWN

    set to all?

  3. #3

    Default Re: shutdown does not power off

    Changed setting in /etc/sysconfig Editor

    After restarting the system and testing a shutdown the system(hitting the F2 key) shows the same symtoms:
    harddisk spins down, display remains active showing the shutdonw messages (this time the last line shows "System halted" wereas it showed "Power down" without the setting described above.
    no keyboard action possible, i have to use the power button to turn off the system

    Any other suggestions ?

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: shutdown does not power off

    What kernel have you installed?

    Last year the ability to power-off was lost so used the following script,
    it was placed in /home/<user_name>/bin/ directory, made executable, and called hhip,
    this makes it executable from any terminal or the 'Run command' drop down box, with cmd hhip
    however the root password is asked for before execution

    Code:
    #!/bin/sh
    # lost ability of normal power-down
    # 120819 16:51
    # 
    
    kdesu -c 'halt -hip'

  5. #5

    Default Re: shutdown does not power off

    This is the output from uname -a
    Linux sixpack 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64 x86_64 x86_64 GNU/Linux

    When using the scritp zo shutdown it ends up as described before.
    Last message that can be seen on the display is: ...Power Down

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: shutdown does not power off

    the only kernel i used in that series was kernel-desktop-3.4.6-2.9.1.x86_64 (31-Jul-2012),
    a jump was then made to kernel-desktop-3.4.6-5.1.x86_64 (01-Aug-2012)
    so you are using a kernel i've had no experience with

    however there are two other areas where you can effect the logoff process

    1. -system settings --session manager ---general, ---default leave options, --on login

    and

    2. -system settings --login screen ---shut down
    my setting here are
    -local: everybody
    -remote: nobody
    and under ---miscellaneous select the boot manager in use

    if none of the above help, the only other suggestion is to upgrade to a newer kernel

  7. #7

    Default Re: shutdown does not power off

    Does HALT="poweroff" in /etc/sysconfig/shutdown make any difference?
    I've seen a bios that will never shutdown with a default "auto" setting.

  8. #8

    Default Re: shutdown does not power off

    For general interest purposes related to the thread's subject matter -- as per the release notes, be advised that:
    5.4. systemd: System Shutdown

    To halt and poweroff the system when using systemd, issue halt -p or shutdown -h now on the command-line or use the shutdown button provided by your desktop environment.

    Note: A plain halt will not shutdown the system properly.

  9. #9

    Default Re: shutdown does not power off

    I update to lastest kernel version via Online update and tried the settings described for /etc/sysconfig/.... still the same situation.
    Shuting down from the command line does not power off ... neither shutdown -h nor halt -p. I tried init 0 .....

    Is anybody running opensuse on a similar computer ?

  10. #10

    Unhappy Re: shutdown does not power off

    Quote Originally Posted by cs7940 View Post
    I update to lastest kernel version via Online update and tried the settings described for /etc/sysconfig/.... still the same situation.
    Shuting down from the command line does not power off ... neither shutdown -h nor halt -p. I tried init 0 .....

    Is anybody running opensuse on a similar computer ?
    I don't have a similar system but I have similar problem.
    This is not an update, it's a installation from KDE live CD.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •