Hi There
I have tried to find similar reports of this both on OS forums and elsewhere and simply cannot resolve this issue.

I am unable to SSH into servers with more than one PTR (reverse DNS) record. This has only begun to happen since I upgraded from 12.1 to 12.2. I have tried everything from copying over the krb5.conf and ~/.ssh/ folders from the working 12.1 and even Ubuntu versions of the files from other working desktops. We make use of GSSAPI auth and use a password-less kinit implementation instead of live keyboard input. I even tried backporting to the version of KRB in 12.1 with not so healthy consequences.

This is how it looks when it works:
marcelf@marcelf:~> ssh www53.BLAAAAAA
Warning: Permanently added '[www53.BLAAAAAA]:22' (RSA) to the list of known hosts.
Linux www53.BLAAAAAAA 3.2.0-0.bpo.3-686-pae #1 SMP Thu Aug 23 08:21:41 UTC 2012 i686
Last login: Tue Sep 25 14:51:48 2012 from office.BLAAAAAA
When it does not work:
 marcelf@marcelf:~> ssh www32.BLAAAAAAWarning: Permanently added '[www32.BLAAAAAA]:22' (RSA) to the list of known hosts.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
This ONLY happens when there is more than one PTR record on the IP address of the server. And obviously only on OS12.2
dig -x 196.BLAAAAAA

;; QUESTION SECTION:                                                                                                                                             
;32.BLAAAAAA.in-addr.arpa.     IN      PTR                                                                                                                      
;; ANSWER SECTION:                                                                                                                                               
32.BLAAAAAA.in-addr.arpa. 200  IN      PTR     www32.aaBLAAAAAA.                                                                                        
32.BLAAAAAA.in-addr.arpa. 200  IN      PTR     www32.bbBLAAAAAA.

My sys:
OS Information

OS: Linux 3.4.6-2.10-pae i686
Current user: marcelf@marcelf
System: openSUSE 12.2 (i586)
KDE: 4.9.1 "release 561"

KRB info:
marcelf:/home/marcelf # zypper info krb5-clientLoading repository data...
Reading installed packages...

Information for package krb5-client:

Repository: openSUSE-12.2-Oss
Name: krb5-client
Version: 1.10.2-3.5.1
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 315.8 KiB
Summary: MIT Kerberos5 implementation - client programs

Thank you for your time.
Kind regards,