Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Clock hour changes when previously booted with Windows

  1. #1

    Default Clock hour changes when previously booted with Windows

    WTH!?

    On Windows 7 the hour is correctly displayed, but when booting back with openSUSE 12.2 x86_64 GNOME 3.4 it goes back 5 hours, and I have to change it again!
    What's this?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Clock hour changes when previously booted with Windows

    Quote Originally Posted by F_style View Post
    WTH!?

    On Windows 7 the hour is correctly displayed, but when booting back with openSUSE 12.2 x86_64 GNOME 3.4 it goes back 5 hours, and I have to change it again!
    What's this?
    Have a look at this blog as it might pertain to the problem that you see.

    What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its solution. - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    ab NNTP User

    Default Re: Clock hour changes when previously booted with Windows

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Most operating systems correctly set the hardware clock to UTC/GMT,
    which is the time that computers all use internally; these OS's (Linux
    included) then calculate the timezone and daylight savings time offset
    and display that to you when required. windows incorrectly sets the
    hardware clock to local time. As a result when you boot back into Linux
    your time is off by your current different from GMT (5 hours could be
    CDT (central time in the USA) during daylight savings time, or eastern
    time during non-daylight-savings-time, or somewhere else over in Asia if
    it's +5 instead of -5.

    Easiest fix: stop using windows or other dumb OS's.

    Other easy fix from the OS that accommodates ****, even windows ****, go
    into Yast in your time settings and have Linux treat your hardware clock
    as if set to local time.

    Good luck.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.19 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

    iQIcBAEBAgAGBQJQX3RrAAoJEF+XTK08PnB5T8gP/1VN8B4ZV3UfqdTKolNtOdH6
    wdb2byVpd6DpRgQhwFdd+Kiyt84cfTTcECaGHAvFPKG8Am+y5T5jc8c1oEVzZ2Rc
    dGpOYLJ2C50Xqxjf2k0L++apxJJQ9iZZALoL9jNqltpWBKWiiV42YOk+/Fnl1w3a
    cVePT633YbQRJSssIkQO4T+VSEyCi9yKkKljiw26lWFBSXy/tdCcX54EJQHCYhg6
    wylP7UOLClBrecSSxkmAsna5n7W6oaQ4FLOcOGNbWyMmoETTKlsKnO37JZRkcAr+
    GFg9HfqctTp31pgRvexovwKIBo3lUTnDaVMfKFfY2UoM4UiLCvBM9ZGZ11GNydy4
    i9v/4Fg3qImzKc5HAH83qIacD0QrZQi4E9tZ+n43t6SrlokiI9RkZM2BoRojo57u
    Y3E+Fh3YIlrZIbxmxqz5bmQyLfwnRfNlaKY/A1/PkbQL7Ia5I0aReBi4cwS95GL7
    cjYkLxdNP6163UZAWkPrX7vatxrkzkZr21THrlf3cVagqnz5lmE2sfrOzDhmo+nR
    rpS75+Er2tS0OnmxojJ1aBYli8/s6lOo3bGIMiRdkoeTOWS9NpcPvoJhBy5EOWR4
    KRkVCITTyvU4CA4F6b2TE+NedQz05poNrnUE8/9UWRBRi10Tp3u5wOy6OIYp7VnA
    6FRFdWZPV/6Ng95kvWy9
    =OL+f
    -----END PGP SIGNATURE-----

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Clock hour changes when previously booted with Windows

    On 2012-09-23 20:56, F style wrote:
    >
    > WTH!?
    >
    > On Windows 7 the hour is correctly displayed, but when booting back
    > with openSUSE 12.2 x86_64 GNOME 3.4 it goes back 5 hours, and I have to
    > change it again!
    > What's this?


    Must be one of the most frequently asked questions these days. You did not search the forum
    before asking, did you? :-)

    View this thread
    View this thread

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,130

    Default Re: Clock hour changes when previously booted with Windows

    Quote Originally Posted by ab View Post

    Other easy fix from the OS that accommodates ****, even windows ****, go
    into Yast in your time settings and have Linux treat your hardware clock
    as if set to local time.

    Good luck.
    That is all correct, but you missed that there is a bug in 12.2 where this setting is not saved.
    See @jmcdaniel3's blog and the other (several) threads abbout this since 12.2 was released.
    Henk van Velden

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Clock hour changes when previously booted with Windows

    On 2012-09-24 10:26, hcvv wrote:
    >
    > ab;2489882 Wrote:
    >>
    >>
    >> Other easy fix from the OS that accommodates ****, even windows ****,
    >> go
    >> into Yast in your time settings and have Linux treat your hardware
    >> clock
    >> as if set to local time.
    >>
    >> Good luck.
    >>

    > That is all correct, but you missed that there is a bug in 12.2 where
    > this setting is not saved.
    > See @jmcdaniel3's blog and the other (several) threads abbout this
    > since 12.2 was released.


    I have not looked, but I wonder if this is in the release notes? Mmm, yes, it is. So, it is the
    OP fault for not reading :-) Or perhaps not. The info in the release notes is too brief and
    incomplete.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Sep 2012
    Location
    Thailand
    Posts
    19

    Default Re: Clock hour changes when previously booted with Windows

    It's not difficult to alter the registry in Windows so that it uses UTC. Simply paste the following into a notepad file:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    "RealTimeIsUniversal"=dword:00000001

    and save it with the .reg extension. Then double click on it and agree with everything you are asked. The key will be added to the registry database and you can set openSUSE to use UTC too. Then you should not have any further problems.

    I don't think Windows is dumb just because a small amount of effort is required to change its default behaviour.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Clock hour changes when previously booted with Windows

    On 2012-09-27 20:46, eaglesgift wrote:
    >
    > It's not difficult to alter the registry in Windows so that it uses UTC.
    > Simply paste the following into a notepad file:


    This is included in the link that jmcdaniel3 posted days ago.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  9. #9
    Join Date
    Sep 2012
    Location
    Thailand
    Posts
    19

    Default Re: Clock hour changes when previously booted with Windows

    My apologies - I didn't follow the link.

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,924

    Default Re: Clock hour changes when previously booted with Windows

    Quote Originally Posted by eaglesgift View Post
    It's not difficult to alter the registry in Windows so that it uses UTC. Simply paste the following into a notepad file:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    "RealTimeIsUniversal"=dword:00000001

    and save it with the .reg extension. Then double click on it and agree with everything you are asked. The key will be added to the registry database and you can set openSUSE to use UTC too. Then you should not have any further problems.

    I don't think Windows is dumb just because a small amount of effort is required to change its default behaviour.
    I have changed this and then my widnows as well as linux clocks were off I guess changing the clock in the BIOS is required for this as well.
    Best regards,
    Greg

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •