Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Attempting to access "Boot Loader Options" freezes system

  1. #11

    Default Re: Attempting to access "Boot Loader Options" freezes system

    Quote Originally Posted by Tyler_K View Post
    Anyway, all problems solved as far as I can see with limited testing.
    Actually, I was able to re-trigger the original problem: "going into the Boot loader Options (Yast > System > Boot Loader > Boot Loader Options) to edit GRUB2 options almost immediately, and absolutely, freezes up the system (requires a hard reset)"

    I have, however, also been able to narrow things down to what is causing this: when I have both the integrated graphics (iGPU) and the discrete graphics (dGPU) enabled in the system, via turning both on in the BIOS (though the adapters are not both enabled via xorg), then this freezing will occur.

    My earlier explained HDMI audio "issue" actually helped to bring that knowledge to light. If you bear with me I will clarify:

    Recall that I complained that using the radeon.audio kernel boot option did not work and also introduced a vertical pink line display artifact But in the process of discovering that those "bugs" were solely a case of user error (because such support for the dGPU is not available in the stock driver for 12.2), I first trouble shot by testing the very same on the iGPU -- something which involved unhooking the HDMI cable from the dGPU and hooking it up to the iGPU, as well as taking the extra step of disabling the dGPU in the BIOS. As the iGPU has appropriate driver support for HDMI audio, it worked flawlessly and I realized shortly afterwards where my folly lay in this regards.

    Next I resolved the other issue (slow "read partitioning") by disabling floppy support in the BIOS. After that, I reported back here, in my very last message, that everything seemed to be working fine.

    However, after running with just the iGPU for a day or two (during which time everything in regards to the Yast Bootloader Module did indeed seem to work fine on several uses of it), I switched back to having both the iGPU and dGPU enabled in the system. In the process of doing this, I switched the HDMI cable back to the dGPU, but what I initially forgot about was that I still had the radeon.audio option set in the bootloader kernel boot options and, because of this, I re-encounterd the same vertical pink line artifact. No problem right? I mean its just a case of going into the GRUB2 settings and removing that particular boot option causing this issue. Lets see now, I can do it manually (via editing the /etc/default/grub.cfg file and then running that grub2 command) or I can even more effortlessly do that via my now apparently perfectly functioning Yast Bootloader module. I choose Yast. And upon attempting -- Bingo! I immediately find the module & system impaired by the freezing issue once again and requires a hard reboot. Ugh.

    (Incidently, upon booting up after that, or coincidently shortly there afterwards, I discovered that the Plymouth bootsplash animation no longer worked on system startup. I have not been able to get it back, so have started another thread about that particular error here)

    I checked a few more times with attempts to use the Yast module, but the result was the same case of a complete system freeze each time. As that's not much fun, I set this aside.

    Now, in the course of tracking down a couple of other annoying bugs (not related to this issue, but related to the use of multiple graphics adapters), I have since disabled the iGPU in the BIOS. For kicks and giggles (and given my experiences above which were leading me to believe that the presence of the two graphics adapters are at the heart of the Yast module freezing issue), I tested the Yast bootloader module once again. The result? Fully functional again. So, in my mind, that further isolates the fact that this freezing issue in the Yast module appears only when the two adapters are enabled concurrently.

    The only other test that I am curious about is what the result will be when I enable both adapters in the system via the BIOS and then enable use of them both in X via enabling the appropriate server layout. I suspect that won't make any difference, but then again, maybe it is having some impact on the situation. I'll have a look when I get a chance.

    In the meantime, as it is, it looks like the freezing issue I've encounterd is a bug that is only brought to light in more of an edge case usage scenario. Can anyone else replicate this?

  2. #12

    Default Re: Attempting to access "Boot Loader Options" freezes system

    Quote Originally Posted by Tyler_K View Post
    Looks like this was indeed related to floppy probing. Although I did not have any such entry in my device.map file, what I did have was floppy drive support enabled in the mobo's BIOS (I had performed a BIOS update likely in July and must have cleared settings and overlooked it ... it was on the first page of the Award BIOS and not in the advanced chipset options).

    I'll make a note of this in the that other thread too.

    Anyway, all problems solved as far as I can see with limited testing.
    Hi all,
    I can confirm the trouble about the floppy.
    Also if not installed in the system i had to disable in the bios of the Gigabyte putting on "none" the option.
    The floppy give trouble also at the system creating some lag.
    Then... attually I dont use grub2 so i cant confirm other issue.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •