Results 1 to 9 of 9

Thread: X.Org crashes since update on 21. Sept 2012

  1. #1

    Exclamation X.Org crashes since update on 21. Sept 2012

    My desktop crashes unexpectedly since I installed these updates:

    Code:
    /var/log/zypp/history:
    2012-09-21  23:24:18|install|k9copy|2.3.8-3.54|x86_64||packman.inode.at-suse|aae146b8a3a9468a7f8a856e600f4ade1ceaa3c32584d63089b6b85998c30330
    2012-09-21   23:24:19|install|libxine2-codecs|1.2.2-78.1|x86_64||packman.inode.at-suse|2fb8a99e711e66568ea8ad5ad22e452b805084e7604ef7388f4f2b101a7e0e02
    2012-09-21   23:24:19|install|libvlccore5|2.0.2-5.13|x86_64||packman.inode.at-suse|1bfd901ea2ae92e1984754a6ec61992f43fd273388fff5d6af3e11a46823fd92
    2012-09-21   23:24:19|install|libaudio2|1.9.2-2.24|x86_64||packman.inode.at-suse|297247fa3dd5a2e3d11c1dc92940fca13b74b1bc70541756591d8835a7a29813
    2012-09-21   23:24:19|install|alsa-plugins|1.0.25-3.4.1|x86_64||repo-update|88d452df2b92af1546b8794c6abcb6acce46d18dfb5d9207b60e0eac5a3c4a63
    2012-09-21   23:24:19|install|alsa-plugins-32bit|1.0.25-3.4.1|x86_64||repo-update|05e2c21ee4b70cb47f66beefe3eb9fd2a5d1ecaabc858fc08be4b52b01de872e
    2012-09-21   23:24:20|install|libpulse0|1.1-6.4.1|x86_64||repo-update|e3f73c310a3e0fa3b672d8e7e9f597a45a8b68bf867056c647bb72af59cb6ed5
    2012-09-21   23:24:20|install|libpulse0-32bit|1.1-6.4.1|x86_64||repo-update|53733624a49e3d2b9c8e5af26fef39172e904e26a17d1280b5470532cf7760bb
    2012-09-21   23:24:20|install|libtevent0|0.9.16-2.8.1|x86_64||repo-update|af8b9ce63c479678f6100c9a81c601a14e7abad17702f312ae7dd1bf656f3903
    2012-09-21   23:24:20|install|xorg-x11-Xvnc|7.6_1.12.3-1.5.1|x86_64||repo-update|50da4be13fd55c55b84ddbe87f01434bd30a78b06984c5ac5c8a4258124f0f5a
    # 2012-09-21 23:24:20 xorg-x11-server-7.6_1.12.3-1.5.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/displaymanager...
    # /usr/bin/Xorg: cannot verify root:root 0755 - not listed in /etc/permissions
    # 
    2012-09-21   23:24:20|install|xorg-x11-server|7.6_1.12.3-1.5.1|x86_64||repo-update|8055515ec2166cecc1e77195e80c5c5119901f7e004fa84ae9581ed8af75b10b
    2012-09-21   23:24:20|install|git-core|1.7.10.4-2.4.1|x86_64||repo-update|93839685864d37061a56ad50553efdb0f72c596139b62c54a4acf940c984d416
    2012-09-21   23:24:21|install|libglib-2_0-0|2.32.4-4.8.1|x86_64||repo-update|cb1cd6afe43e4c52c822f1641d251c884bba6da20d04df95cf06abfad7b7e878
    2012-09-21   23:24:21|install|libglib-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|93130f641ba49641ae5a7ce348c2c5f4edf675f67065280db7fa8baad28f7a70
    2012-09-21   23:24:21|install|bind-libs|9.9.1P3-1.4.1|x86_64||repo-update|0e155c36bac7138de4d42992cb000d2b81afc820b4e11b35df35262ff2e79fe6
    2012-09-21 23:24:21|install|SuSEfirewall2|3.6.295-1.6.1|noarch||repo-update|04a42c5b86a50a562fb250cb45f9975a863f68d3282052c73d9d274aa8936f1e
    2012-09-21 23:24:22|install|opensuse-manuals_en|12.2-3.11.1|noarch||repo-update|00ac33a2435e29630f28e144b7f0058f09c743bf3b8e7611b3823d495c0d6674
    # 2012-09-21 23:24:23 pulseaudio-1.1-6.4.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/sound...
    # 
    2012-09-21 23:24:23|install|pulseaudio|1.1-6.4.1|x86_64||repo-update|bf289dc802f0b5769907bad1c5bca7af06f3015f0343ff28a05d158f8bc7b7f9
    2012-09-21 23:24:23|install|alsa-plugins-pulse-32bit|1.0.25-3.4.1|x86_64||repo-update|a532dc6ab9327a2614e6c66ba2ccde6056e8d384cd4d00574254550be0157079
    2012-09-21 23:24:23|install|libldb1|1.1.10-2.8.1|x86_64||repo-update|e56ba1980e7ac1e5c9690f2a29d80f2de402b27f51e3129423b06073f458573d
    2012-09-21 23:24:23|install|gitk|1.7.10.4-2.4.1|x86_64||repo-update|8a6346194f527db941d102431f223f29c1552f874d15e630c2d49b907da7a647
    2012-09-21 23:24:23|install|git-web|1.7.10.4-2.4.1|x86_64||repo-update|7191abe9c120b057a73b6defc5c154c93cf0e67ddeb5dca781a194e767a913b9
    2012-09-21 23:24:23|install|git-svn|1.7.10.4-2.4.1|x86_64||repo-update|2fe1194c5572ac6083c2303da6a31cb1158c2c0cddbc11a6cc7a636e14872046
    2012-09-21 23:24:23|install|git-gui|1.7.10.4-2.4.1|x86_64||repo-update|680662c3554ba9fb5ce791e790c82ea64e1e4fd4c4b155548b13897121ec20f5
    2012-09-21 23:24:23|install|git-email|1.7.10.4-2.4.1|x86_64||repo-update|9b83228a28b5a1667cc812bac724d08cbb8a4946172162164f221170400f07f4
    2012-09-21 23:24:23|install|git-cvs|1.7.10.4-2.4.1|x86_64||repo-update|afde5e89b3abe22f12ec7dfdd8a516ff6607d7ca6ac99b9aedff714fa8862a40
    2012-09-21 23:24:23|install|git|1.7.10.4-2.4.1|x86_64||repo-update|6ba03f9bf0c6bf02cc935e83bc2e9a3f4af72f6d81caea3f772f741953382651
    2012-09-21 23:24:23|install|libgthread-2_0-0|2.32.4-4.8.1|x86_64||repo-update|d97da0eb533bafce8712987e3f23436339ed44cd405a67e3cf2a225fa94f1d06
    2012-09-21 23:24:23|install|libgobject-2_0-0|2.32.4-4.8.1|x86_64||repo-update|4007214402d1928b00866a28f9f2e298ac0e10bccfce9e1f255735f33871c093
    2012-09-21 23:24:23|install|libgmodule-2_0-0|2.32.4-4.8.1|x86_64||repo-update|2d4eba54987b08e3b495d9509da5372d724e3da0857649772ee5e458edc4581d
    2012-09-21 23:24:23|install|libpulse-mainloop-glib0|1.1-6.4.1|x86_64||repo-update|a290044adb8c9f2f87001c6266e42cbb45f19cb68a809099ef17e194d330269d
    2012-09-21 23:24:24|install|libgthread-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|cbb88a27746218a9acba7f147520ef2fd153a6e8dc9306367094b75bad56d652
    2012-09-21 23:24:23|install|libgobject-2_0-0|2.32.4-4.8.1|x86_64||repo-update|4007214402d1928b00866a28f9f2e298ac0e10bccfce9e1f255735f33871c093
    2012-09-21 23:24:23|install|libgmodule-2_0-0|2.32.4-4.8.1|x86_64||repo-update|2d4eba54987b08e3b495d9509da5372d724e3da0857649772ee5e458edc4581d
    2012-09-21 23:24:23|install|libpulse-mainloop-glib0|1.1-6.4.1|x86_64||repo-update|a290044adb8c9f2f87001c6266e42cbb45f19cb68a809099ef17e194d330269d
    2012-09-21 23:24:24|install|libgthread-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|cbb88a27746218a9acba7f147520ef2fd153a6e8dc9306367094b75bad56d652
    2012-09-21 23:24:24|install|libgobject-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|c2c91f0dd4c6fbdb158b924175ff94c14c98f6afe6720b93d06435f77cff51bc
    2012-09-21 23:24:24|install|libgmodule-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|9dd4c2b0d10467d652b552ca3201e8ada783560dcd5972c8e637076bda1e257c
    2012-09-21 23:24:24|install|bind-utils|9.9.1P3-1.4.1|x86_64||repo-update|fe900519202c363bc05a289b2572d22a9942a04684467b608a1d90e04a4603fb
    2012-09-21 23:24:24|install|pulseaudio-module-zeroconf|1.1-6.4.1|x86_64||repo-update|8acd40165be7fc78425eb02d65182affa021672cd0aa95e447baa6b405d370cd
    2012-09-21 23:24:24|install|pulseaudio-module-lirc|1.1-6.4.1|x86_64||repo-update|96c396e3a62b3c72b9dd5578ac33b7749a8e7e7c60bc21b83bf483c97233c510
    2012-09-21 23:24:24|install|pulseaudio-module-jack|1.1-6.4.1|x86_64||repo-update|03ef8d6ed557362be0b675e6ae2c6aed833c8e65d4da5f54b23f0ee97045aef1
    2012-09-21 23:24:24|install|pulseaudio-module-bluetooth|1.1-6.4.1|x86_64||repo-update|543f81f3c9096aea4ffb9d6400e2324e229884037561fa7af424ba8e4ee654e8
    # 2012-09-21 23:24:24 alsa-plugins-pulse-1.0.25-3.4.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Enabling PulseAudio for ALSA...
    # Enabling PulseAudio for libao...
    # Default driver is pulse already in /etc/libao.conf
    # Enabling PulseAudio for mplayer...
    # Enabling PulseAudio for OSS...
    # Application aumix already setup for PulseAudio
    # Application sox already setup for PulseAudio
    # Enabling PulseAudio for SDL...
    # Enabling PulseAudio for Timidity...
    # Timidity already setup for using PulseAudio
    # Enabling PulseAudio autospawn...
    # Enabling PulseAudio for Phonon...
    # Enabling PulseAudio for speech dispatcher...
    # 
    2012-09-21 23:24:24|install|alsa-plugins-pulse|1.0.25-3.4.1|x86_64||repo-update|e8acdfde6d169b597295285e9f979bb6851247d490e16b05e05b58ca9b80e0d2
    # 2012-09-21 23:24:24 chromium-suid-helper-23.0.1255.0-1.14.1.x86_64.rpm installed ok
    # Additional rpm output:
    # setting /usr/lib/chrome_sandbox to root:root 4755. (wrong permissions 0755)
    # 
    2012-09-21 23:24:24|install|chromium-suid-helper|23.0.1255.0-1.14.1|x86_64||repo-update|4247f78da36caec1499bd96f4b931d66287b4ad78e480ffd6015548f29253ad7
    2012-09-21 23:24:24|install|libgio-2_0-0|2.32.4-4.8.1|x86_64||repo-update|2845129d1c9580e49693e2dfc5c1524249aa52c12c3230f662a097e947bb8ece
    2012-09-21 23:24:24|install|pulseaudio-utils|1.1-6.4.1|x86_64||repo-update|93a3f002a2e09c39fea77ead6f3a22ee0b597672e69580ce5d4558b63283ee06
    2012-09-21 23:24:24|install|libgio-2_0-0-32bit|2.32.4-4.8.1|x86_64||repo-update|0c5ce405ace3f332696be1ec6eb5f96261a20b3e47338c134fc3a5617afbc05b
    2012-09-21 23:24:29|install|chromium|23.0.1255.0-1.14.1|x86_64||repo-update|84aad4844792e6d5c750605666db7a9e04b22a67626c9a74f6b652048c9d0e3a
    2012-09-21 23:24:29|install|glib2-tools|2.32.4-4.8.1|x86_64||repo-update|a719402339726bcdd00bbb92e846ff6795e2b1f61be3c36a265f20888fc4bb98
    2012-09-21 23:24:32|install|java-1_7_0-openjdk|1.7.0.6-3.12.1|x86_64||repo-update|2bb7dd71b8cd0f7a09491c37accbfff731c699e3eb830088aa78a710c4275b55
    2012-09-21 23:24:32|install|pulseaudio-module-x11|1.1-6.4.1|x86_64||repo-update|ed165df9458acb460227017ec5d3005cf21eb78887623ecdab7ba76820101908
    2012-09-21 23:24:32|install|chromium-desktop-kde|23.0.1255.0-1.14.1|x86_64||repo-update|c2701604787a920d284d81c5afecd78d0819150fba50577ca5eb750e2a74c067
    2012-09-21 23:24:32|install|glib2-devel|2.32.4-4.8.1|x86_64||repo-update|283772dcad32e916d89dd1673c86d42d73c8f0ad5c14533b9525d8bbc2f57860
    2012-09-21 23:24:32|install|icedtea-web|1.3-1.5.1|x86_64||repo-update|b43e0e781f65d2942888ab143749f62bdf7d18d629af833a42448aed4dc90e40
    2012-09-21 23:24:32|install|libpulse-devel|1.1-6.4.1|x86_64||repo-update|60a8eec673df343295b745ca8b3393562ac0b66f39d7d0df38773e4b4b257255
    2012-09-21 23:24:33|install|vlc-noX|2.0.2-5.13|x86_64||packman.inode.at-suse|18069342f2e05c07881c96655be2b74da099ec02bf392d5f5551a80d2602ed94
    2012-09-21 23:24:35|install|MPlayer|1.1+35127-1.6|x86_64||packman.inode.at-suse|c18727ec3cea79500383e348cd73945067b0c8908cc0ef3b828be144da8fbbe7
    2012-09-21 23:24:35|install|gstreamer-0_10-plugins-ffmpeg|0.10.13-2000.5|x86_64||packman.inode.at-suse|7d4f44308ee481177fe5e1ed6d5eb7dc97febbb535f5edbadf7d271e943abb0c
    2012-09-21 23:24:35|install|fpm2|0.79-5.18|x86_64||packman.inode.at-suse|b13adac7778a8cee993ab00bd51d16a1758c7542ea9fd36f6e3aa471291b140d
    2012-09-21 23:24:35|install|xvidcap|1.1.7-7.20|x86_64||packman.inode.at-suse|5e1f6a4ee022f52cee4d410916ff2b5e74d54c24e5a046bdd92a581745d33227
    2012-09-21 23:24:35|install|libvlc5|2.0.2-5.13|x86_64||packman.inode.at-suse|d16c03914dac730aeec861f1379f4e97b5b00f3924e9012bc1bfa164563b7427
    2012-09-21 23:24:35|install|gmplayer|1.1+35127-1.6|x86_64||packman.inode.at-suse|9a9612a34968d874fce846db5e22f408c37f4d7cd6fd504d5db8d0f75badf071
    2012-09-21 23:24:35|install|vlc-qt|2.0.2-5.13|x86_64||packman.inode.at-suse|ef3a5b3f334c70469c63e48a4687ade401aafba436609a486accde4345489a33
    The first crash happened while I tried to log in while KDE showed the "I'm starting icons" It was about to display the last icon (the desktop?) -> black screen -> login dialog.

    When I tried again, I got to see the desktop. Then it crashed when I started Chromium.

    Code:
    kdm.log
    X.Org X Server 1.12.3
    Release Date: 2012-07-09
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux silent1 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64
    Kernel command line: root=/dev/sda7 resume=/dev/disk/by-id/ata-Corsair_Force_3_SSD_12136503000013410698-part6 splash=silent quiet  video=1920x1200 vga=0x346
    Build Date: 07 September 2012  07:00:23PM
    ...
    Errors from xkbcomp are not fatal to the X server
    
    Backtrace:
    0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x564616]
    1: /usr/bin/Xorg (0x400000+0x168349) [0x568349]
    2: /lib64/libpthread.so.0 (0x7f1d1618b000+0xf140) [0x7f1d1619a140]
    
    Segmentation fault at address (nil)
    
    Fatal server error:
    Caught signal 11 (Segmentation fault). Server aborting
    
    
    Please consult the The X.Org Foundation support 
             at http://wiki.x.org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
    Server terminated with error (1). Closing log file.
    The important part is probably this:

    Code:
    Backtrace:
    0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x564616]
    1: /usr/bin/Xorg (0x400000+0x168349) [0x568349]
    2: /lib64/libpthread.so.0 (0x7f1d1618b000+0xf140) [0x7f1d1619a140]
    From the stack trace, only the last line changes:

    Code:
    2: /lib64/libpthread.so.0 (0x7f1d1618b000+0xf140) [0x7f1d1619a140]
    2: /lib64/libpthread.so.0 (0x7f97a2b7c000+0xf140) [0x7f97a2b8b140]
    2: /lib64/libpthread.so.0 (0x7f3fd4766000+0xf140) [0x7f3fd4775140]
    2: /lib64/libpthread.so.0 (0x7f3f25801000+0xf140) [0x7f3f25810140]
    I tried to downgrade X to the previous release 7.6_1.12.3-1.2.3 (Mi 25 Jul 2012 21:43:19 CEST) but that didn't help.

    I deleted Nepomuk because I saw segfaults in /var/log/messages but that didn't help, either.

    I'm posting this now before I do the next experiment so I don't lose it.

  2. #2

    Default Re: X.Org crashes since update on 21. Sept 2012

    I have now downgraded chromium to 22.0.1226.0-1.9.1

    I noticed something odd: I have chromium-ffmpeg installed but there is no version for 23.0. Maybe this causes the problem?

    Starting chromium ...

  3. #3

    Default Re: X.Org crashes since update on 21. Sept 2012

    :-( Still crashes but later. I could open a few tabs.

    Uninstalling chromium-ffmpeg doesn't help, either.

    Ideas, anyone?

  4. #4
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,120

    Default Re: X.Org crashes since update on 21. Sept 2012

    Hope I'm not hijacking your thread but I'm having similar problems. I updated to 12.2 and KDE 4.9 but don't remember the date of the last update. Several times, as I try to go to various web pages in Chrome (not THOSE web pages) I get an instant reboot. This last time, I was trying to reach a page for the new tv show Revolution. I can't get a reboot so fast the normal way! I never thought to look to see if it was an xorg crash. Didn't try Firefox yet, but I will. Also, will check to see if it was the same as your crash.

  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,120

    Default Re: X.Org crashes since update on 21. Sept 2012

    The Revolution site works in both Firefox and Konqueror, although there is a horrible lag in either one. The video is a good 2 seconds behind the audio. When I had only 1 tab open in Chrome and went to this site, it began to load and then rebooted me. It was too fast to see what element it was trying to load.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  6. #6

    Default Re: X.Org crashes since update on 21. Sept 2012

    Aah finally someone with the same problem
    Here is my description: http://forums.opensuse.org/english/g...s-crash-x.html

    There are a lot of similitaries, that must be the same problem..
    When I'm back home I'll check the history log of zypper for other packets that we have updated besides xorg-x11-Xvnc and xorg-x11-server

    side note:
    I've installed chromium after the crash because I needed an "alternative" browser..

  7. #7

    Default Re: X.Org crashes since update on 21. Sept 2012

    Found it: The installation overwrites the file /usr/lib64/xorg/modules/extensions/libglx.so (installed by the NVIDIA installer) with the version from Xorg.

    Reinstalling the NVIDIA driver again fixed the problem for me.

  8. #8

    Default Re: X.Org crashes since update on 21. Sept 2012

    Quote Originally Posted by digulla View Post
    Found it: The installation overwrites the file /usr/lib64/xorg/modules/extensions/libglx.so (installed by the NVIDIA installer) with the version from Xorg.

    Reinstalling the NVIDIA driver again fixed the problem for me.
    Works like a charm

    Thanks a lot

  9. #9

    Default Re: X.Org crashes since update on 21. Sept 2012

    Quote Originally Posted by digulla View Post
    Found it: The installation overwrites the file /usr/lib64/xorg/modules/extensions/libglx.so (installed by the NVIDIA installer) with the version from Xorg.

    Reinstalling the NVIDIA driver again fixed the problem for me.
    Same here ! Thanks for the solution

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •