Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: sshd Xforwarding

  1. #1

    Default sshd Xforwarding

    After starting sshd on Opensuse 12.2 x64

    On the putty I get error message:
    Xforwarding refused.
    sshd config seems ok.

    Any idea?

  2. #2
    ab NNTP User

    Default Re: sshd Xforwarding

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Did you configure Putty to forward X? It doesn't by default, but it's a
    checkbox that when enabled seems to work pretty well. Also, I presume
    Putty is on windows; if that's the case, do you have an X server on the
    windows side as well? xming is an example of a free/easy one to get
    going if you do not already have one. Also, did this work in the past?
    Does it work with other machines?

    Good luck.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.19 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

    iQIcBAEBAgAGBQJQWdbKAAoJEF+XTK08PnB5t7YQAI+fE+Pc4475PJIePWAykcMX
    GBdfjsG+nsDDX/yR86KVakdgX6qIWu3C0IzdaB3fUfJcXUZ3+Nbd+HHDPAF2JrQG
    IfHS7mmddCfZhX8pMyiJiZ7ojFBE4wy7QKm94RBofDD4WPzX4aoaDhuY1beI+SbB
    N2loB7QEDXn0pp1MAhpph74qjjdDYY9kPWCNH9Ff8tTG9viQC6OnQHvSfnc0vt2R
    XZHYMcL+GZs14+h1bX+XSfvKcQUpE4QamE5zJbLKYXPqcW2tqyE2A565riSsEr2G
    3ZBv9Rd2W8nuoiRjhfb97IJu7EPPN17NQ/AM6YFBb4uuxNP/o5BAnAwEKsQKpQ/V
    rz4lHZA6Dvei3yfvbvt7ttYws+xl44TFymUu656jww53f9i9BTlnM1Vkt8q+P+NV
    ONveqxjLcWEkrQI79fxSywTmxZ/yTXV9xK1d75/5sCB09zXHZSn87jWdYmK7Q/uv
    Di8zrSp7WEIZaOrKakF9kY91P3lq0Mv3n0i5QKlM4gSgYzKdIIp8gdkIG5kYnAkt
    x7EuJ67xEOeskoidLh2BEbRUN67KlAfYO3hZBYw8kJOqLy+sGFeY+1D9v4941EAw
    Lrd4UjSEgJF/cHJ8zdJpJ7wgy1mSVRdrmC++04Ht9UOxaWTNSYacMgvTPDDFk5ei
    vnOwQcjGpf69Vgt7oyZB
    =9BKF
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: sshd Xforwarding

    On the server side, it should work out of the box. On the client side, you need to use ssh -X or ssh -Y.

  4. #4

    Default Re: sshd Xforwarding

    Did you configure Putty to forward X?

    Only the new OpenSuse 12.2 install not working. Other systems yes.

  5. #5

    Default Re: sshd Xforwarding

    Quote Originally Posted by please_try_again View Post
    On the server side, it should work out of the box. On the client side, you need to use ssh -X or ssh -Y.
    With the ssh -X host command I have the same situation. The DISPLAY environment variable not setting.

    On firewall port 22 open.
    In /etc/ssh/sshd_config file
    Port 22 uncommented
    X11Forwarding yes (originaly uncommented)

  6. #6

    Default Re: sshd Xforwarding

    Quote Originally Posted by afeher View Post
    With the ssh -X host command I have the same situation. The DISPLAY environment variable not setting.

    On firewall port 22 open.
    In /etc/ssh/sshd_config file
    Port 22 uncommented
    X11Forwarding yes (originaly uncommented)
    You only need to uncomment "Port 22" in /etc/ssh/sshd_config if you run sshd on other ports (too).
    DISPLAY has to be set to the IP:<display>[.screen] of the ssh client.

    example:

    Code:
    export DISPLAY=192.168.1.4:0.0

  7. #7

    Default Re: sshd Xforwarding

    I want to use via the SSH tunel, so this DISPLAY setting doesn't working automatically. (NAT, etc.)

  8. #8

    Default Re: sshd Xforwarding

    I installed CEntOS its working properly. I installed again OpenSuSe and have the same problem.
    On remote:
    ssh -X host


    On OpenSuse
    xterm

    xterm: Xt error: Can't open display:
    xterm: DISPLAY is not set

    PLEASE HELP !!!

  9. #9
    ab NNTP User

    Default Re: sshd Xforwarding

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What are you doing that is non-standard during installation? I just
    built a new OpenSUSE 12.2 x86_64 host and while it is not running a GUI
    it does have the X libraries installed (running at runlevel 3). I just
    SSH'd in with -X (from the command line, not using Putty) and am able to
    get 'xeyes' running properly by calling it normally (a simple test of X
    functionality). After this I ran the following command:

    env | grep DISPLAY

    and found the following set on the server side via my SSH connection:

    DISPLAY=localhost:10.0

    This, I believe, is working normally. As this is the second box I've
    tried after seeing your thread I'm led to believe this is either an odd
    issue with Putty or is related to how you are installing OpenSUSE.

    Good luck.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.19 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

    iQIcBAEBAgAGBQJQYImOAAoJEF+XTK08PnB5VkQP/2Ts9Nwvqh7kV7s+CffPeEe4
    Xsn+rEKqx6IEo2MIAIQZs38WqvdG1aeeXOlfSzywVQPVrsP4fAv2JZkBYuvnbG67
    2Sdqdsktdo754VX3e+AZmDX9t6FT+flELu33kEtFgVDyL8E9EauuEle9w1LvjV2F
    vyfc7twxWIMTlZ57kQBVdnCiznvnq2j+GdgFOipUNvkX3/pocVnAYPrhx0+tqKV7
    S3IWqF7QKx85Qh6ALQQmB0eJuvTLQCG7eeCIxw/v/1FnQzCEV6gD/Hoq8QFrgFqo
    say1yQ1941cZBLs6Bdxj7R+F5kV08BEw+9uRXmyCuXRSbsNtiBlW+WgLgilsiY1N
    Il2Hzgl2/DC8mA1Dnst1exS7QGhwNEItl9WhQ+9Gwyx0YIzn165ey5UB97YTL/yy
    nI3mjkL2dcCAGt5bC1/zH58HbNvtphauPRd/Nj6ltCNFWxlbl/D1Ilw/vdDNz5kb
    vZ79PBVV8aNm3XDNrLOWZsYveZ3Ym46BWQcJ87vcGcJiyErvJXiYaL9EjqeTfPGa
    s++xNkwPsn3DZ9ZnAaaue7QdqrTMSRAxIg3o1v18eavochOmG8o0S17sM1W0R46m
    FsSzgwdhaYap1JrCjOqYW3Mn+gmIYczTcjsS7w3VxWW5+bRYmmdkJ+l08RZuiGbo
    +TdfMdOxZ2WUrLwH69Yi
    =DX20
    -----END PGP SIGNATURE-----

  10. #10

    Default Re: sshd Xforwarding

    I runing with GNOME desktop. I get:
    afeher@web:~> env | grep DISPLAY
    afeher@web:~>

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •