Results 1 to 4 of 4

Thread: KDE switches keyboard layout after login...

  1. #1

    Default KDE switches keyboard layout after login...

    Hi

    I've upgraded from 12.1 to 12.2 and when I log in, my keyboard changes from a UK layout to US. Boot menu shows UK layout, YAST Control Panel shows UK layout, but when I type in the the 'Test' box, the @ key has become ", no £ sign ($ instead) etc, etc. If I click on any other layout and then back to UK layout, then I get the UK layout again. Any ideas on how to make it stay as a UK layout, like it did in 12.1 please?

    Thanks in advance.

    x86_64, KDE 4.8

  2. #2
    josephkk NNTP User

    Default Re: KDE switches keyboard layout after login...

    On Wed, 19 Sep 2012 10:56:01 GMT, McToo <McToo@no-mx.forums.opensuse.org>
    wrote:

    >
    >Hi
    >
    >I've upgraded from 12.1 to 12.2 and when I log in, my keyboard changes
    >from a UK layout to US. Boot menu shows UK layout, YAST Control Panel
    >shows UK layout, but when I type in the the 'Test' box, the @ key has
    >become ", no sign ($ instead) etc, etc. If I click on any other
    >layout and then back to UK layout, then I get the UK layout again. Any
    >ideas on how to make it stay as a UK layout, like it did in 12.1 please?
    >
    >Thanks in advance.
    >
    >x86_64, KDE 4.8


    This may be a KDE setting rather than a system setting. Try looking for
    equivalent KDE settings.

    ?-)

  3. #3

    Default Re: KDE switches keyboard layout after login...

    Hi Joseph

    Thanks for the reply. You were right, I had to go to Applications->System Settings->Input Devices->Keyboard and change the keyboard to a Logitech Cordless and now I get my UK layout when I log-in :-)

    Thanks again for the suggestion.

    Regards
    KM

  4. #4
    josephkk NNTP User

    Default Re: KDE switches keyboard layout after login...

    On Wed, 26 Sep 2012 08:36:01 GMT, McToo <McToo@no-mx.forums.opensuse.org>
    wrote:

    >
    >Hi Joseph
    >
    >Thanks for the reply. You were right, I had to go to
    >Applications->System Settings->Input Devices->Keyboard and change the
    >keyboard to a Logitech Cordless and now I get my UK layout when I log-in
    >:-)
    >
    >Thanks again for the suggestion.
    >
    >Regards
    >KM


    Congrats on fixing your system.
    It is a kick that i might have helped.

    ?-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •