Results 1 to 3 of 3

Thread: zypper refresh problem

  1. #1

    Default zypper refresh problem

    Hi, to all

    There are a couple o days now that when i try to add a repo or refresh all my repos i get the following errors

    uname -a
    Linux hakarako 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) i686 i686 i386 GNU/Linux

    cat /etc/issue
    Welcome to openSUSE 12.2 "Mantis" - Kernel \r (\l).

    zypper repos --sort-by-priority --details
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------+--------
    1 | Packman | Packman | Yes | Yes | 99 | NONE | Index of /pub/linux/packman/suse/12.2
    2 | google-earth | google-earth | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/i386
    3 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.2/
    4 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-S203B,/dev/sr0 |
    5 | repo-debug | openSUSE-12.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.2/repo/oss |
    6 | repo-debug-update | openSUSE-12.2-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.2 |
    7 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | Index of /debug/update/12.2-non-oss |
    8 | repo-non-oss | openSUSE-12.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.2/repo/non-oss |
    9 | repo-oss | openSUSE-12.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.2/repo/oss |
    10 | repo-source | openSUSE-12.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.2/repo/oss |
    11 | repo-update | openSUSE-12.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.2 |
    12 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/12.2-non-oss

    zypper ref
    Retrieving repository 'Packman' metadata ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------[\]
    Permission to access 'http://ftp.gwdg.de/pub/linux/packman/suse/12.2/repodata/repomd.xml' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Retrieving repository 'Packman' metadata ........................................................................................................................................................................[error]
    Repository 'Packman' is invalid.
    [|] Valid metadata not found at specified URL(s)
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'Packman' because of the above error.
    Permission to access 'http://dl.google.com/linux/earth/rpm/stable/i386/repodata/repomd.xml' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'google-earth':
    SKIP request: User-requested skipping of a file
    Skipping repository 'google-earth' because of the above error.
    Permission to access 'http://opensuse-guide.org/repo/12.2/repodata/repomd.xml' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'libdvdcss':
    SKIP request: User-requested skipping of a file
    Skipping repository 'libdvdcss' because of the above error.
    Permission to access 'http://download.opensuse.org/distribution/12.2/repo/non-oss/content' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'openSUSE-12.2-Non-Oss':
    SKIP request: User-requested skipping of a file
    Skipping repository 'openSUSE-12.2-Non-Oss' because of the above error.
    Permission to access 'http://download.opensuse.org/distribution/12.2/repo/oss/content' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'openSUSE-12.2-Oss':
    SKIP request: User-requested skipping of a file
    Skipping repository 'openSUSE-12.2-Oss' because of the above error.
    Permission to access 'http://download.opensuse.org/update/12.2/repodata/repomd.xml' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'openSUSE-12.2-Update':
    SKIP request: User-requested skipping of a file
    Skipping repository 'openSUSE-12.2-Update' because of the above error.
    Permission to access 'http://download.opensuse.org/update/12.2-non-oss/repodata/repomd.xml' denied.

    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'openSUSE-12.2-Update-Non-Oss':
    SKIP request: User-requested skipping of a file
    Skipping repository 'openSUSE-12.2-Update-Non-Oss' because of the above error.
    Some of the repositories have not been refreshed because of an error.

    I removed /var/cache/zypp
    I did
    rpm --rebuilddb

    and the problem continues the same ...
    Any help .....

  2. #2

    Default Re: zypper refresh problem

    Problem solved, i had made a change in proxy server and that was it ...

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: zypper refresh problem

    On 2012-09-16 16:36, akarako wrote:
    >
    > Problem solved, i had made a change in proxy server and that was it ...


    Ok.

    But next time please remember to post using code tags.

    Posting in Code Tags - A Guide


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •