Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

  1. #1

    Default How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    If anyone could help, I would be very grateful.

    How can I stop the **** screen going into standby every ten minutes or so, and yes I have all settings in the 'display' & also 'power management' areas of system settings set correctly ie. screensaver disabled, dim display after... disabled, turn off display after... disabled.

    It's really annoying. Has anyone else got this happening (12.2)?

  2. #2
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Well, a simple way to 'practically' disabling screen going off, is to enable 'Dim Display' and 'Screen Energy Saving' in 'Power Management', and set their values to something really big, like 360 minutes for example.

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by icekool View Post
    If anyone could help, I would be very grateful.

    How can I stop the **** screen going into standby every ten minutes or so, and yes I have all settings in the 'display' & also 'power management' areas of system settings set correctly ie. screensaver disabled, dim display after... disabled, turn off display after... disabled.

    It's really annoying. Has anyone else got this happening (12.2)?
    In KDE there is another setting that, if not present, can allow your screen to go blank. There are three places that can cause this in KDE:

    1. Screen Saver Settings: Menu / Configure Desktop / Hardware / Display and Monitor / Screen Saver
    2. Power Settings: Menu / Configure Desktop / Hardware / Power Management
    3. KDE Screen Saver Settings in kscreensaverrc:

    Edit the file (in the hidden $HOME folder) ~/.kde4/share/config/kscreensaverrc as a normal user (not as root!)

    Code:
    [ScreenSaver]
    PlasmaEnabled=true
    Saver=glmatrix.desktop
    Timeout=600
    DPMS-dependent=false
    Add the setting DPMS-dependent=false at the bottom to any other existing entries which will be based on your screen saver settings. This setting can apparently only be added manually as shown in this example. Log out and back into KDE for the setting to take effect immediately.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by jdmcdaniel3 View Post
    In KDE there is another setting that, if not present, can allow your screen to go blank. There are three places that can cause this in KDE:

    1. Screen Saver Settings: Menu / Configure Desktop / Hardware / Display and Monitor / Screen Saver
    2. Power Settings: Menu / Configure Desktop / Hardware / Power Management
    3. KDE Screen Saver Settings in kscreensaverrc:

    Edit the file (in the hidden $HOME folder) ~/.kde4/share/config/kscreensaverrc as a normal user (not as root!)

    Code:
    [ScreenSaver]
    PlasmaEnabled=true
    Saver=glmatrix.desktop
    Timeout=600
    DPMS-dependent=false
    Add the setting DPMS-dependent=false at the bottom to any other existing entries which will be based on your screen saver settings. This setting can apparently only be added manually as shown in this example. Log out and back into KDE for the setting to take effect immediately.

    Thank You,
    Thank you very much, I will do this

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by icekool View Post
    Thank you very much, I will do this
    Please let us know if it fixed the issue for you or not.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by jdmcdaniel3 View Post
    Please let us know if it fixed the issue for you or not.

    Thank You,
    it appears to have fixed this issue, thanks once again

  7. #7

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Actually NO it hasn't fixed the issue, I just turned the pc on after a few days and during update it is back to doing it again.

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by icekool View Post
    Actually NO it hasn't fixed the issue, I just turned the pc on after a few days and during update it is back to doing it again.
    Have you made sure you are now completely up-to-date with openSUSE 12.2? There were a zillion updates after the original installation, including those from Packman cause I always add them at first as well. If you don't know how, just ask and I will give the details of how I do it using YaST.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9

    Default Re: How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

    Quote Originally Posted by jdmcdaniel3 View Post
    Have you made sure you are now completely up-to-date with openSUSE 12.2? There were a zillion updates after the original installation, including those from Packman cause I always add them at first as well. If you don't know how, just ask and I will give the details of how I do it using YaST.

    Thank You,
    I have fully updated my system using Apper + YaST, (I started a thread about this nuisance "dual method/s"), so yes i should have everything up to date, I think this is yet another KDE bug, I have now tried enabling the 'turn off display' opton but have set it to 360 mins, maybe that will fix this minor but annoying bug.

    Thanks for your reply

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,799
    Blog Entries
    15

    Default Re: How to stop screen off/standby in KDE desktop even though allsettings are seemingly correct?

    Quote Originally Posted by icekool
    jdmcdaniel3;2489758 Wrote:
    > Have you made sure you are now completely up-to-date with openSUSE
    > 12.2? There were a zillion updates after the original installation,
    > including those from Packman cause I always add them at first as
    > well. If you don't know how, just ask and I will give the details of
    > how I do it using YaST.
    >
    > Thank You,


    I have fully updated my system using Apper + YaST, (I started a thread
    about this nuisance "dual method/s"), so yes i should have everything up
    to date, I think this is yet another KDE bug, I have now tried enabling
    the 'turn off display' opton but have set it to 360 mins, maybe that
    will fix this minor but annoying bug.

    Thanks for your reply

    Hi
    As I indicated in the 'Blank screen in Gnome 3' thread, caffeine should
    work, else use xset to disable dpms.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
    up 4:09, 3 users, load average: 0.01, 0.06, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •