Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: OS 12.2 Problem with Wine

  1. #1

    Default OS 12.2 Problem with Wine

    Hi,

    Running OpenSuse 12.2 KDE 4.9. I installed wine from Yast.

    In trying to install an app that I successfully installed in Opensuse 12.1, I get the following error:

    p11-kit: couldn't load module: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
    err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
    fixme:msvcr90:__clean_type_info_names_internal (0x1002f234) stub

    Any idea of how to correct this? Thank you!

    db

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: OS 12.2 Problem with Wine

    hi,

    for me wine is running well and it was an easier install than for 12.1
    install was from 'http://download.opensuse.org:80/repositories/mozilla/openSUSE_12.2/'

    packages installed :-
    gettext-runtime-0.18.1.1-22.1.x86_64
    wine-32bit-1.5.12-186.1.x86_64
    wine-gecko-1.7-29.1.noarch
    wine-mono-0.0.4-5.3.noarch
    wine-mp3-1.1.39-12.8.i586

    before though, lots of 32bit packages had to be installed to get
    googleearth up and running, ?,
    will send the details if you need them

    kernel 3.5.3-1-desktop x86_64 (64 bit), kde 4.9.1, openSUSE 12.2 (x86_64) + Tumbleweed

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: OS 12.2 Problem with Wine

    Quote Originally Posted by keellambert View Post
    hi,

    for me wine is running well and it was an easier install than for 12.1
    install was from 'http://download.opensuse.org:80/repositories/mozilla/openSUSE_12.2/'

    packages installed :-
    gettext-runtime-0.18.1.1-22.1.x86_64
    wine-32bit-1.5.12-186.1.x86_64
    wine-gecko-1.7-29.1.noarch
    wine-mono-0.0.4-5.3.noarch
    wine-mp3-1.1.39-12.8.i586

    before though, lots of 32bit packages had to be installed to get
    googleearth up and running, ?,
    will send the details if you need them

    kernel 3.5.3-1-desktop x86_64 (64 bit), kde 4.9.1, openSUSE 12.2 (x86_64) + Tumbleweed
    I somehow doubt you use Mozilla repo as the source for installing wine?
    Perhaps: Index of /repositories/Emulators:/Wine/openSUSE_12.2

    @blackbird....
    Details about what you are actually trying to do would help.
    You might also want to check: WineHQ - Wine Application Database
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: OS 12.2 Problem with Wine

    @caf4926, I stand corrected. dragged and dropped the wrong repo

    @blackbirdsr71, apologies for giving bad info again

  5. #5

    Default Re: OS 12.2 Problem with Wine

    Thank you for your replies. I'm trying to install a Windows application (Bloomberg Terminal) that works perfectly on Opensuse 12.1 using wine. I am running OS 12.2 with KDE 4.9. I installed Wine using Yast. I get an error:
    Error while loading application settings by key: 'WineLibs'. File or path does not exist:
    Even if I set the libraries to /usr/lib/wine and /usr/lib64/wine, I still get this error and cannot install any Windows applications.
    Any ideas? Thanks again,
    db

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: OS 12.2 Problem with Wine

    I installed 12.2 clean over 12.1, but I kept my /home
    So I didn't need to re-install wine applications. Did you do this?

    Are you now using wine from the repo I listed or from the 12.2 default repos?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: OS 12.2 Problem with Wine

    I did a complete reinstall, so didn't have my previous /home directory
    I tried loading Wine from Yast, but that led to the problem.
    I have added the Wine repo that you mentioned. So if I run Yast now and try to reinstall Wine, will it come from the new repo? Or do I have to do zypper up from the command line to get the Wine files form your repo?
    Thanks again!
    db

  8. #8
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: OS 12.2 Problem with Wine

    @blackbirdsr71,

    I've no experience with Bloomberg Terminal but to get other programs to run in
    wine I needed lots of files downloaded using winetricks,
    this program was from The Official Wine Wiki and copied into
    /usr/bin/ then run

    if you use this method, careful how you go

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: OS 12.2 Problem with Wine

    Quote Originally Posted by blackbird_sr71 View Post
    I did a complete reinstall, so didn't have my previous /home directory
    I tried loading Wine from Yast, but that led to the problem.
    I have added the Wine repo that you mentioned. So if I run Yast now and try to reinstall Wine, will it come from the new repo? Or do I have to do zypper up from the command line to get the Wine files form your repo?
    Thanks again!
    db
    Go to yast > Software Management
    View by repository and select Wine from the list of repos
    Use the switcher (Like this but on wine: https://dl.dropbox.com/u/10573557/Sw...R49_switch.png )
    FYI: Winetricks is included, or it is for me.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: OS 12.2 Problem with Wine

    @caf4926

    "FYI: Winetricks is included, or it is for me. "

    what is the source of your Winetricks? R49 where?

    if I do a scan for winetricks in yast, the only item that shows up is

    q4wine - Qt4 GUI for WINE
    which gives in the description "- Winetricks support."

    otherwise zilch

    cheers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •