Results 1 to 2 of 2

Thread: Need help w/ KGpg error

  1. #1

    Default Need help w/ KGpg error

    Complete an online update of 12.1 to 12.2, KDE desktop. gpg2 is installed.

    On restart I get "gpg: WARNING: unsafe enclosing directory permissions on configuration file" .gnupg/gpg.conf which is located in my home directory.
    I don't know how to fix this.

    I changed the permissions for gpg.conf from owner/group/others RW to RW/R & none for others. This didn't fix the error.
    Do I need to change the permissions of the .gnupg directory and if so, to what permissions?

    Thanks, Jon

  2. #2
    josephkk NNTP User

    Default Re: Need help w/ KGpg error

    On Mon, 10 Sep 2012 17:36:02 GMT, 6520302
    <6520302@no-mx.forums.opensuse.org> wrote:

    >
    >Complete an online update of 12.1 to 12.2, KDE desktop. gpg2 is
    >installed.
    >
    >On restart I get "gpg: WARNING: unsafe enclosing directory permissions
    >on configuration file" .gnupg/gpg.conf which is located in my home
    >directory.
    >I don't know how to fix this.
    >
    >I changed the permissions for gpg.conf from owner/group/others RW to
    >RW/R & none for others. This didn't fix the error.
    >Do I need to change the permissions of the .gnupg directory and if so,
    >to what permissions?
    >
    >Thanks, Jon


    Unless i am mistaken the correct setting is rwx------ or numeric 700 for
    the file and the directory.

    ?-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •