Results 1 to 6 of 6

Thread: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    379

    Default [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    Greetings,

    I just wonder if tty10 in Linux is dedicated for printing debug informations.
    When I type CTRL-ALT-F10 I got some informations coming straight from /var/log/messages the 12 last lines.

    Code:
    Sep  9 19:28:23 antares kernel: [   36.562840] bridge-eth0: attached
    Sep  9 19:28:23 antares /usr/sbin/cron[3498]: (CRON) bad username (/etc/cron.d/smolt)
    Sep  9 19:28:23 antares /usr/sbin/cron[3498]: (CRON) INFO (running with inotify support)
    Sep  9 19:28:24 antares vmnet-detect[3586]: NetDetectDaemonInit: No host policy file found. Not initializing filter.
    Sep  9 19:28:24 antares vmnet-detect[3586]: Unable to initialize the daemon
    Sep  9 19:28:25 antares SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    Sep  9 19:28:25 antares SuSEfirewall2: using default zone 'ext' for interface eth1
    Sep  9 19:28:25 antares kernel: [   38.388746] start_kdeinit (3789): /proc/3789/oom_adj is deprecated, please use /proc/3789/oom_score_adj instead.
    Sep  9 19:28:25 antares SuSEfirewall2: Firewall rules successfully set
    Sep  9 19:28:27 antares kernel: [   40.866093] EXT4-fs (sdd1): re-mounted. Opts: acl,user_xattr,commit=0
    Sep  9 19:28:40 antares kernel: [   53.071110] ALSA pcm_lib.c:323: BUG: pcmC0D0c:0, pos = 5461, buffer size = 5461, period size = 2730
    Sep  9 19:28:40 antares pulseaudio[4153]: pid.c: Daemon already running.
    I ask you this because the tty10 in /dev is set to read only and all the others are set to write only.
    And when I wake my computer from "hibernation" I got a message telling each minute that there is an I/O error on tty10.

    How can I set rw permissions on tty at boot ? Is that recommended or not ?
    In the negative, how come the "hibernation" cause this to happen ? I never had such issue before the last update of the system.

    I did not test with sleep I never need to put my computer to sleep. But hibernation was often used since the last update.

    Thank you in advance for any advices or enlighments ^^

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    I have 11.4 here. I also see what you see at Ctrl-Alt-F10. But:
    Code:
    boven:/dev # l tty*
    crw-rw-rw- 1 root tty     5,  0 Sep  9 11:09 tty
    crw--w---- 1 root root    4,  0 Sep  9 11:09 tty0
    crw-rw---- 1 root tty     4,  1 Sep  9 11:10 tty1
    crw--w---- 1 root tty     4, 10 Sep  9 11:24 tty10
    crw--w---- 1 root tty     4, 11 Sep  9 11:09 tty11
    crw--w---- 1 root tty     4, 12 Sep  9 11:09 tty12
    crw--w---- 1 root tty     4, 13 Sep  9 11:09 tty13
    .....
    Thus tty10 is not read only and the others not write only.
    Henk van Velden

  3. #3
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    379

    Default Re: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    That is the point, now I have to find first the reason why the tty is set to read only and second how I can fix the issue.
    I have no idea to tell the system to set tty10 in write only for group. In my configuration, I haven't been precise, the read only was set for the group, for the user I got character read and write (crw).
    The owner and owner group are root:root (??)
    Code:
    ls -lisah | grep -e "\ tty[0-9][0-1]*$"
     885    0 crw--w----  1 root root      4,   0 Sep 11 00:12 tty0
     890    0 crw-rw----  1 root tty       4,   1 Sep 11 00:13 tty1
     899    0 crw-r-----  1 root root      4,  10 Sep 11 00:13 tty10
     891    0 crw-rw----  1 root tty       4,   2 Sep 11 00:13 tty2
     892    0 crw-rw----  1 root tty       4,   3 Sep 11 00:13 tty3
     893    0 crw-rw----  1 root tty       4,   4 Sep 11 00:13 tty4
     894    0 crw-rw----  1 root tty       4,   5 Sep 11 00:13 tty5
     895    0 crw-rw----  1 root tty       4,   6 Sep 11 00:13 tty6
     896    0 crw--w----  1 root tty       4,   7 Sep 11 00:12 tty7
     897    0 crw--w----  1 root tty       4,   8 Sep 11 00:12 tty8
     898    0 crw--w----  1 root tty       4,   9 Sep 11 00:12 tty9
    (I volontary deleted the ttyzzz that I really don't care, the regular expressions are not my strength in shell)

    Still digging and I feel a sensive slowness of the responsivness of the kde environment since last update, but this will be the subject of another thread...
    Last edited by soundlord; 10-Sep-2012 at 15:34. Reason: mispelling lol

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    I am not quite sure hat your problem is. I have also messages at tty10, I never looked there, thus I saw this for the first time after seeing this thread. But Why should it be a problem?

    What is a bit strange is the access bits, I have no explanation for it, but again, what is the problem?

    And removing device special files (or anything) from within /dev is futile. It is created dynamicaly and all will be there again after next boot. When you realy hate them (again, why?) you should create udev rules to prevent their creation.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    PS, In the end of the expression in the grep command you have *$. The$ is useless because * allready means "whatever string" and that includes all characters until the end of the line.
    Henk van Velden

  6. #6
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    379

    Default Re: [openSuSE 11.4][kernel 2.6.37.6-0.20-desktop][KDE 4.6.0] tty questions

    Quote Originally Posted by hcvv View Post
    PS, In the end of the expression in the grep command you have *$. The$ is useless because * allready means "whatever string" and that includes all characters until the end of the line.
    ^^

    I'm not fluent with regular expressions ^^ I was trying to say "no or one digit that may be 0" ^^

    The problem is that recently, since last update, when I wake up from "hibernation" I have a I/O error from a process that is tty10 (the pid returned by syslog-ng matches).
    The message is logged in the var/log/message file every minute and that is anoying...
    That's why I'm trying to find a way to change the read only flag on tty10 or find a way to use hibernation again as "before". Since I saw this issue I stopped using the hibernation feature.

    Still have no clues... I can use bash.bashrc to change the permissions on tty10 but it sucks... there is a better way I guess.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •