Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Huge Fonts with Normal/Small Interface

  1. #1
    Join Date
    Apr 2011
    Location
    Vancouver, BC, Canada
    Posts
    92

    Default Huge Fonts with Normal/Small Interface

    Check out the screen shot of my desktop: http://justpaste.it/1alw

    This is set at 1080p on an LCD TV, running 12.2 with nvidia drivers installed the hard way. It's been like this for a while, and I can't figure out why. I've changed the font sizes and such, but it makes no difference. Where else could I check for this strange setting mess? The interface is HUGE and all the text is continually cut off the screen. Real annoying.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: Huge Fonts with Normal/Small Interface

    Your screenshot is not visible in that link. Are you saying that your desktop display is cropped (over-scanned image on your LCD TV)? If so, that is often due to the configuration of the TV display. Check its menu settings first.

  3. #3
    Join Date
    Apr 2011
    Location
    Vancouver, BC, Canada
    Posts
    92

    Default Re: Huge Fonts with Normal/Small Interface

    Try this link instead then: http://i49.tinypic.com/1t0m81.png

    It's not the TV, as video and the constraints on the desktop work just fine. It's the font on the interface is physically too large. For example, if you look at the size of the menu bars and such, they seem normal, but the font is so large that the names of the menus don't fit. Same goes for the system clock in the lower right-hand corner.... the time is so huge that only the first 2 digits of the clock even appear.

  4. #4

    Default Re: Huge Fonts with Normal/Small Interface

    What kind of cable did you use to connect to your tv?
    Is it via hdmi etc.
    Some tv I guess doesn't support 1080p unless it is connected via HDMI.
    If you have used it before and the screen used to be supporting 1080p
    then my guess is it has an edid problem.
    People who do not break things first will never learn to create anything

  5. #5
    Join Date
    Apr 2011
    Location
    Vancouver, BC, Canada
    Posts
    92

    Default Re: Huge Fonts with Normal/Small Interface

    It is HDMI. TV has no issues supporting 1080, at least for anything else going through the same PC (video is good). I'm not familiar with edid, and have no idea how to check the settings for it, but will add this to my google searches for this issue.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: Huge Fonts with Normal/Small Interface

    Okay, since I note you're using KDE, have could you try adjusting DPI (dots per inch) via

    System Settings >> Application Appearance >> Fonts

    (You may need to force fonts DPI to 96 for example.)

    Examination of '/var/log/Xorg.0.log' will show what DPI is detected via EDID, or any other issues.

  7. #7
    Join Date
    Apr 2011
    Location
    Vancouver, BC, Canada
    Posts
    92

    Default Re: Huge Fonts with Normal/Small Interface

    Here's my /var/log/Xorg.0.log: http://pastebin.com/r8PNfqV9

    Logging in and forcing the fonts to 96 DPI and then logging out and in again worked for the login session. However, all the system menus outside the login session (like the login screen) are still huge. Where could I set these?

    According to the pasted log above, the DPI is set to 304 by 304. However, I'm concerned with the following block:

    Code:
    [   572.689] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [   572.689] (**) NVIDIA(0):     device SAMSUNG (DFP-1) (Using EDID frequencies has been
    [   572.689] (**) NVIDIA(0):     enabled on all display devices.)
    [   572.690] (WW) NVIDIA(GPU-0): The EDID for SAMSUNG (DFP-1) contradicts itself: mode
    [   572.690] (WW) NVIDIA(GPU-0):     "1920x1080" is specified in the EDID; however, the EDID's
    [   572.690] (WW) NVIDIA(GPU-0):     valid HorizSync range (30.000-68.000 kHz) would exclude
    [   572.690] (WW) NVIDIA(GPU-0):     this mode's HorizSync (27.0 kHz); ignoring HorizSync check
    [   572.690] (WW) NVIDIA(GPU-0):     for mode "1920x1080".
    [   572.690] (WW) NVIDIA(GPU-0): The EDID for SAMSUNG (DFP-1) contradicts itself: mode
    [   572.690] (WW) NVIDIA(GPU-0):     "1920x1080" is specified in the EDID; however, the EDID's
    [   572.690] (WW) NVIDIA(GPU-0):     valid VertRefresh range (59.000-61.000 Hz) would exclude
    [   572.690] (WW) NVIDIA(GPU-0):     this mode's VertRefresh (24.0 Hz); ignoring VertRefresh
    [   572.690] (WW) NVIDIA(GPU-0):     check for mode "1920x1080".
    [   572.690] (WW) NVIDIA(GPU-0): The EDID for SAMSUNG (DFP-1) contradicts itself: mode
    [   572.690] (WW) NVIDIA(GPU-0):     "1920x1080" is specified in the EDID; however, the EDID's
    [   572.690] (WW) NVIDIA(GPU-0):     valid VertRefresh range (59.000-61.000 Hz) would exclude
    [   572.690] (WW) NVIDIA(GPU-0):     this mode's VertRefresh (30.0 Hz); ignoring VertRefresh
    [   572.690] (WW) NVIDIA(GPU-0):     check for mode "1920x1080".
    [   572.690] (II) NVIDIA(0): Validated MetaModes:
    [   572.690] (II) NVIDIA(0):     "nvidia-auto-select+0+0"
    [   572.690] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    [   572.713] (--) NVIDIA(0): DPI set to (304, 304); computed from "UseEdidDpi" X config
    [   572.713] (--) NVIDIA(0):     option
    ....seems to indicate some sort of conflict/contradiction. Any thoughts?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: Huge Fonts with Normal/Small Interface

    Do you have /etc/X11/xorg.conf present? If so, try adding the following to the 'Device' section:
    Code:
    Option              "UseEdidDpi" "False"
    Option              "DPI" "96 x 96"
    Alternatively, add to it to the newer /etc/X11/xorg.conf.d/50-device.conf file.

  9. #9
    Join Date
    Apr 2011
    Location
    Vancouver, BC, Canada
    Posts
    92

    Default Re: Huge Fonts with Normal/Small Interface

    Awesome. Adding it to my /etc/X11/xorg.conf file did the trick! Would you recommend forcing the refresh rate settings on the monitor to help with the contradiction warning above? I'm not sure if any of this might be affecting things like video playback and such.

    Here's my xorg.conf file for reference: # nvidia-settings: X configuration file generated by nvidia-settings # nvidia-s - Pastebin.com

    I also noticed that I have the newer /etc/X11/xorg.conf.d/50-device.conf file, but it's empty with only a couple comments. Looks like the /etc/X11/xorg.conf file supersedes it.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: Huge Fonts with Normal/Small Interface

    Awesome. Adding it to my /etc/X11/xorg.conf file did the trick!
    I'm glad it worked as expected.

    Would you recommend forcing the refresh rate settings on the monitor to help with the contradiction warning above?
    I see you have forced them (or the 'nvidia-settings' created xorg.conf did)
    Code:
    Section "Monitor"
    Identifier     "Monitor0"VendorName     "Unknown"
    ModelName      "SAMSUNG"
        HorizSync       30.0 - 68.0
        VertRefresh     59.0 - 61.0
        Option         "DPMS"
    EndSection
    You could either use higher allowed horizontal sync rate, or comment out altogether with '#'
    Code:
    #   HorizSync       30.0 - 68.0
    #   VertRefresh     59.0 - 61.0


    I also noticed that I have the newer /etc/X11/xorg.conf.d/50-device.conf file, but it's empty with only a couple comments. Looks like the /etc/X11/xorg.conf file supersedes it.
    No, it's the other way round. However, any valid entries in the legacy xorg.conf are still respected, and take precedence over entries in the newer files.
    Last edited by deano_ferrari; 09-Sep-2012 at 18:08.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •