Results 1 to 6 of 6

Thread: Laptop mouse button erratic on 12.2

  1. #1
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Default Laptop mouse button erratic on 12.2

    Hi all, I have just installed 12.2 onto my laptop. A fresh install. My left mouse button has started to work a little erratically.

    Most of the time it is ok, but sometimes especially on scroll bars, I see no reaction to my input or a delay before anything happens. The scroll bar will jump down as opposed to scroll down when I drag it via the bar. Button actions seem to be ok

    I have a trackpad and a nipple on my laptop. the nipple works fine, its just left the trackpad button that is erratic. Everything was fine on 12.1.

    Any help?

    Lenovo T400, openSuse 12.2, KDE 4.8.4
    Vas
    openSuse 42.2

  2. #2
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Default Re: Laptop mouse button erratic on 12.2

    Is there no one that can at least give me some pointers on this?
    Vas
    openSuse 42.2

  3. #3

    Default Re: Laptop mouse button erratic on 12.2

    Chameleon -> Configure Desktop (System Settings) -> Input Devices -> Touchpad

    or

    /etc/X11/xorg.conf.d/50-synaptics.conf

    Image:

    Setting Taping Touchpad As Left Button Click in KDE | Linux and Virtualization

  4. #4
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Default Re: Laptop mouse button erratic on 12.2

    Thanks but changing button times makes no changes, and i'm not sure what i'm supposed to be looking for in the 50-synaptics.conf file.

    There is a noticeable delay in the colour of the scroll bar when I click on it to drag it. Until it becomes active, dragging it is problematic.

    As for tap to click, no way. I dislike it. This is the contents of my conf file

    Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    # This option is recommend on all Linux systems using evdev, but cannot be
    # enabled by default. See the following link for details:
    # Who-T: How to ignore configuration errors
    MatchDevicePath "/dev/input/event*"
    Option "HorizScrollDelta" "0"
    # enable tap-to-click as default (bnc#722457)
    Option "TapButton1" "1"
    Option "TapButton1" "2"
    Option "TapButton1" "3"
    EndSection


    Section "InputClass"
    Identifier "touchpad ignore duplicates"
    MatchIsTouchpad "on"
    MatchOS "Linux"
    MatchDevicePath "/dev/input/mouse*"
    Option "Ignore" "on"
    EndSection


    # This option enables the bottom right corner to be a right button on
    # non-synaptics clickpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
    Identifier "Default clickpad buttons"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    EndSection


    # This option disables software buttons on Apple touchpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
    Identifier "Disable clickpad buttons on Apple touchpads"
    MatchProduct "Apple|bcm5974"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
    EndSection
    Vas
    openSuse 42.2

  5. #5

    Default Re: Laptop mouse button erratic on 12.2

    I checked and it seems that KDE does not use the configuration file /etc/X11/xorg.conf.d/50-synaptics.conf .

    You're talking about the real button mouse laptop? The touchpad can also be configured as a left button, right button, scroll vertical and horizontal scroll.

    You tried KDE settings?

    Chamaleon -> Configure Desktop (System settings) -> Input Devices -> Mouse or Touchpad.

    or

    /usr/bin/synaptiks


    synaptiks.lunaryorn.de/en/0.8.1/handbook/usage.html

  6. #6

    Default Re: Laptop mouse button erratic on 12.2

    Same for me, 12.2 KDE (previous versions did) does not activate horizontal or vertical scrolling at touchpad bottom or right edge by default. I had to activate manually in Configure Desktop (System settings) -> Hardware -> Input Devices -> Touchpad -> Scrolling the checkbox "Horizontal scrolling at bottom edge" and "Vertical scrolling at right edge" and increment the field "Move distance to scroll a single line" in "Horizontal scrolling" to 100.

    I add this comment just in case some else has the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •