Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Clock is constantly off

  1. #1
    Join Date
    Mar 2010
    Location
    Between a rock and a hard place
    Posts
    51

    Default Clock is constantly off

    The clock on the KDE bar in 64 bit 12.2 is off by several hours. Manually fixing it works until next time I boot in.

    I still have 32 bit 12.1 and Windows 7 on my system and they work correctly so it is a 12.2 issue.

    Even pointing it to a time server fails to keep the clock set to the correct time.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,066

    Default Re: Clock is constantly off

    On Fri, 07 Sep 2012 20:46:01 +0000, Eiledon wrote:

    > The clock on the KDE bar in 64 bit 12.2 is off by several hours.
    > Manually fixing it works until next time I boot in.
    >
    > I still have 32 bit 12.1 and Windows 7 on my system and they work
    > correctly so it is a 12.2 issue.
    >
    > Even pointing it to a time server fails to keep the clock set to the
    > correct time.


    This is a known issue if you've got the hardware clock set to local time
    instead of UTC.

    Linux generally expects it to be set to UTC, but there's a potential bug
    (or an actual bug, I don't recall the specific state of it) that if
    you're not set to UTC, after a reboot the clock comes back off by the
    number of hours between you and UTC because it's still expecting the
    clock to be UTC instead of local time.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,299
    Blog Entries
    2

    Default Re: Clock is constantly off

    I've seen what Jim describes only if you alternate booting to Windows and openSUSE (Windows can modify the hardware clock so openSUSE isn't offset correctly).

    I've generally resolved by simply setting NTP in both OS, that way instead of relying on the hardware clock the OS syncs to a time server (on the corporate network or Internet) with each bootup. Of course, this requires and active Network connection when the OS tries to reach the timeserver.

    HTH,
    TS

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Clock is constantly off

    On 2012-09-08 02:05, Jim Henderson wrote:

    > This is a known issue if you've got the hardware clock set to local time
    > instead of UTC.
    >
    > Linux generally expects it to be set to UTC, but there's a potential bug
    > (or an actual bug, I don't recall the specific state of it) that if
    > you're not set to UTC, after a reboot the clock comes back off by the
    > number of hours between you and UTC because it's still expecting the
    > clock to be UTC instead of local time.


    Yes, there is a bug in 12.2. You need to edit the file /etc/adjtime and change the utc there to
    local. Someone has described how to create this file as new with the proper defaults, but I don't
    have a link handy.

    Alternatively, you may tell Windows 7 to also use UTC - this is described in the wiki:

    Code:
    http://en.opensuse.org/SDB%3AConfiguring_the_clock
    which is what I use now in this laptop.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Clock is constantly off

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Clock is constantly off

    On 2012-09-08 05:16, caf4926 wrote:
    >
    > I always set up this:
    > https://docs.google.com/open?id=0B3e...3dMWkU4VWFJT2s
    >
    >


    Has no effect on this problem in 12.2

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Clock is constantly off

    I can confirm I'm seeing some strange clock behaviour (an not windows booting to cause it).

    Clock displays UTC time but I want it to display local time.
    If I right click and set use ntp server it displays correct time until next boot.
    If I go into yast and disable utc time it corrects my problem but on the next boot utc is enabled again and the time is off.

    very very annoying bug as I use that clock often.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Clock is constantly off

    Has no effect on this problem in 12.2
    I wonder what you mean?
    You probably missed the point of my post. It had nothing to do with the bug in the installer...
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Clock is constantly off

    Quote Originally Posted by farcusnz View Post
    I can confirm I'm seeing some strange clock behaviour (an not windows booting to cause it).

    Clock displays UTC time but I want it to display local time.
    If I right click and set use ntp server it displays correct time until next boot.
    If I go into yast and disable utc time it corrects my problem but on the next boot utc is enabled again and the time is off.

    very very annoying bug as I use that clock often.
    I have no problem now
    But I don't boot in to windows... so maybe windows is the problem

    Though if you configure NTP properly, it should all correct itself once you login to SUSE anyway
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Clock is constantly off

    Quote Originally Posted by caf4926 View Post
    I have no problem now
    But I don't boot in to windows... so maybe windows is the problem

    Though if you configure NTP properly, it should all correct itself once you login to SUSE anyway
    I also do not boot into wondows.
    The failure of ntp to correct the problem was throwing me off as it was not a behaviour I observed in 12.1.

    However, a very quick and easy fix was simply for me to set the bios time to UTC time and now my local clock displays the correct time on boot.

    There is something buggy in the clock though as it did not respect my setting to disable utc in yast and renabled it every time I rebooted.
    Having the bios clock set to utc somewhat negates the need to disable it now though.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •