Results 1 to 6 of 6

Thread: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

  1. #1
    Join Date
    Jun 2011
    Location
    China
    Posts
    68

    Default Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

    Hi,
    I used to echo OFF to switch file to turn off ATI card. But I really hope i can use ATI card in openSUSE. So, after i installed openSUSE 12.2. I tried to install ATI drivers again. No doubt, i failed again. I got a Xorg log like below:
    Code:
    [    23.752] 
    X.Org X Server 1.12.3
    Release Date: 2012-07-09
    [    23.752] X Protocol Version 11, Revision 0
    [    23.752] Build Operating System: openSUSE SUSE LINUX
    [    23.752] Current Operating System: Linux linux.home 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64
    [    23.752] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.4.6-2.10-desktop root=UUID=c8de270f-3ce5-49a5-bf0d-34e1d5b0bc20 video=1366x768 resume=/dev/disk/by-id/ata-WDC_WD5000BEKT-75KA9T0_WD-WXE1A51E3770-part10 splash=silent quiet showopts
    [    23.752] Build Date: 25 July 2012  07:36:24PM
    [    23.752]  
    [    23.752] Current version of pixman: 0.24.4
    [    23.752]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    23.752] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    23.753] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep  7 22:42:43 2012
    [    23.753] (==) Using config file: "/etc/X11/xorg.conf"
    [    23.753] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    23.753] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    23.753] (==) ServerLayout "aticonfig Layout"
    [    23.753] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [    23.753] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
    [    23.753] (**) |   |-->Device "aticonfig-Device[0]-0"
    [    23.753] (==) Automatically adding devices
    [    23.753] (==) Automatically enabling devices
    [    23.819] (WW) The directory "/usr/share/fonts/URW/" does not exist.
    [    23.819]     Entry deleted from font path.
    [    23.822] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [    23.822]     Entry deleted from font path.
    [    23.822] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
    [    23.822] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [    23.822] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    23.822] (II) Loader magic: 0x7ccae0
    [    23.822] (II) Module ABI versions:
    [    23.822]     X.Org ANSI C Emulation: 0.4
    [    23.822]     X.Org Video Driver: 12.0
    [    23.822]     X.Org XInput driver : 16.0
    [    23.822]     X.Org Server Extension : 6.0
    [    23.823] (--) PCI:*(0:0:2:0) 8086:0116:1028:04c1 rev 9, Mem @ 0xe0000000/4194304, 0xd0000000/268435456, I/O @ 0x00005000/64
    [    23.823] (--) PCI: (0:1:0:0) 1002:6741:1028:04c1 rev 0, Mem @ 0xc0000000/268435456, 0xe1700000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
    [    23.823] (II) Open ACPI successful (/var/run/acpid.socket)
    [    23.823] (II) "extmod" will be loaded by default.
    [    23.823] (II) "dbe" will be loaded by default.
    [    23.823] (II) "glx" will be loaded by default.
    [    23.823] (II) "record" will be loaded by default.
    [    23.823] (II) "dri" will be loaded by default.
    [    23.823] (II) "dri2" will be loaded by default.
    [    23.823] (II) LoadModule: "extmod"
    [    23.830] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
    [    23.830] (II) Module extmod: vendor="X.Org Foundation"
    [    23.830]     compiled for 1.12.3, module version = 1.0.0
    [    23.830]     Module class: X.Org Server Extension
    [    23.830]     ABI class: X.Org Server Extension, version 6.0
    [    23.830] (II) Loading extension MIT-SCREEN-SAVER
    [    23.830] (II) Loading extension XFree86-VidModeExtension
    [    23.830] (II) Loading extension XFree86-DGA
    [    23.830] (II) Loading extension DPMS
    [    23.830] (II) Loading extension XVideo
    [    23.830] (II) Loading extension XVideo-MotionCompensation
    [    23.830] (II) Loading extension X-Resource
    [    23.830] (II) LoadModule: "dbe"
    [    23.831] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
    [    23.831] (II) Module dbe: vendor="X.Org Foundation"
    [    23.831]     compiled for 1.12.3, module version = 1.0.0
    [    23.831]     Module class: X.Org Server Extension
    [    23.831]     ABI class: X.Org Server Extension, version 6.0
    [    23.831] (II) Loading extension DOUBLE-BUFFER
    [    23.831] (II) LoadModule: "glx"
    [    23.831] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    23.831] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    [    23.831]     compiled for 6.9.0, module version = 1.0.0
    [    23.831] (II) Loading extension GLX
    [    23.831] (II) LoadModule: "record"
    [    23.831] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
    [    23.832] (II) Module record: vendor="X.Org Foundation"
    [    23.832]     compiled for 1.12.3, module version = 1.13.0
    [    23.832]     Module class: X.Org Server Extension
    [    23.832]     ABI class: X.Org Server Extension, version 6.0
    [    23.832] (II) Loading extension RECORD
    [    23.832] (II) LoadModule: "dri"
    [    23.832] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
    [    23.832] (II) Module dri: vendor="X.Org Foundation"
    [    23.832]     compiled for 1.12.3, module version = 1.0.0
    [    23.832]     ABI class: X.Org Server Extension, version 6.0
    [    23.832] (II) Loading extension XFree86-DRI
    [    23.832] (II) LoadModule: "dri2"
    [    23.832] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
    [    23.833] (II) Module dri2: vendor="X.Org Foundation"
    [    23.833]     compiled for 1.12.3, module version = 1.2.0
    [    23.833]     ABI class: X.Org Server Extension, version 6.0
    [    23.833] (II) Loading extension DRI2
    [    23.833] (II) LoadModule: "fglrx"
    [    23.833] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    [    24.050] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
    [    24.050]     compiled for 1.4.99.906, module version = 8.98.2
    [    24.050]     Module class: X.Org Video Driver
    [    24.050] (II) Loading sub module "fglrxdrm"
    [    24.050] (II) LoadModule: "fglrxdrm"
    [    24.050] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
    [    24.051] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
    [    24.051]     compiled for 1.4.99.906, module version = 8.98.2
    [    24.051] (II) AMD Proprietary Linux Driver Version Identifier:8.98.2
    [    24.051] (II) AMD Proprietary Linux Driver Release Identifier: 8.982                                
    [    24.051] (II) AMD Proprietary Linux Driver Build Date: Jul 27 2012 20:37:56
    [    24.051] (++) using VT number 7
    
    [    24.051] (WW) Falling back to old probe method for fglrx
    [    24.086] (II) Loading PCS database from /etc/ati/amdpcsdb
    [    24.087] (--) Chipset Supported AMD Graphics Processor (0x6741) found
    [    24.088] (II) fglrx: intel VGA device detected, load intel driver.
    [    24.088] (II) LoadModule: "intel"
    [    24.089] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [    24.090] (II) Module intel: vendor="X.Org Foundation"
    [    24.090]     compiled for 1.12.3, module version = 2.20.3
    [    24.090]     Module class: X.Org Video Driver
    [    24.090]     ABI class: X.Org Video Driver, version 12.0
    [    24.093] ukiDynamicMajor: found major device number 251
    [    24.093] ukiDynamicMajor: found major device number 251
    [    24.093] ukiOpenByBusid: Searching for BusID PCI:1:0:0
    [    24.093] ukiOpenDevice: node name is /dev/ati/card0
    [    24.093] ukiOpenDevice: open result is 8, (OK)
    [    24.093] ukiOpenByBusid: ukiOpenMinor returns 8
    [    24.093] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    [    24.095] (II) AMD Video driver is running on a device belonging to a group targeted for this release
    [    24.095] (II) AMD Video driver is signed
    [    24.095] (II) fglrx(0): pEnt->device->identifier=0x230e910
    [    24.097] (II) intel(1): pEnt->device->identifier=(nil)
    [    24.097] (EE) Screen 1 deleted because of no matching config section.
    [    24.097] 
    [    24.097] Backtrace:
    [    24.098] 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x564616]
    [    24.098] 1: /usr/bin/Xorg (0x400000+0x168349) [0x568349]
    [    24.098] 2: /lib64/libpthread.so.0 (0x7fd9e7ca2000+0xf140) [0x7fd9e7cb1140]
    [    24.098] 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fd9e4121000+0x15c4b) [0x7fd9e4136c4b]
    [    24.098] 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fd9e4121000+0x16feb) [0x7fd9e4137feb]
    [    24.098] 5: /usr/bin/Xorg (xf86DeleteScreen+0x7c) [0x47e0ac]
    [    24.098] 6: /usr/bin/Xorg (xf86BusConfig+0x1c7) [0x46b347]
    [    24.098] 7: /usr/bin/Xorg (InitOutput+0x7a0) [0x477330]
    [    24.098] 8: /usr/bin/Xorg (0x400000+0x277c6) [0x4277c6]
    [    24.098] 9: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fd9e6b50455]
    [    24.098] 10: /usr/bin/Xorg (0x400000+0x27c3d) [0x427c3d]
    [    24.098] 
    [    24.098] Segmentation fault at address (nil)
    [    24.098] 
    Fatal server error:
    [    24.098] Caught signal 11 (Segmentation fault). Server aborting
    [    24.098] 
    [    24.098] 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    24.098] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    24.098] 
    [    24.263] Server terminated with error (1). Closing log file.
    /etc/X11/xorg.conf is like below:
    Code:
    Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    /etx/X11/xorg.conf.d/50-device.conf is like below:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    #Section "Device"
    #  Identifier "Default Device"
    #
    #  #Driver "radeon"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
    #  #Option "monitor-DVI-0" "Default Monitor"
    #
    #EndSection
    I don't know what is the main problem that result in this. Hope anyone can give me some guide.

    Thanks a lot.

  2. #2

    Default Re: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

    As you can see from my lspci:
    Code:
    00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
    00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
    00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
    00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
    00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
    00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames [Radeon 7500M/7600M Series] (rev ff)
    03:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
    03:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
    03:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 30)
    04:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
    i have a Radeon 7xxxM and an integrated Intel.
    Had same problem as your, so i made some experiments. Problems arised after 12.2 installation, but i was not sure that was a problem related to 12.2.
    I've reinstalled 12.2, and installed the fglrx driver. Everything worked fine until ad update of the Intel Video driver, that cause the segmentation fault in X.

    The old driver before that update was xf86-video-driver-2.20.0, the updated driver provided by the Update repo is 2.20.3
    Code:
    linux-7pat:/home/morgenstern # zypper se -s xf86-video-intel
    Loading repository data...
    Warning: Repository 'openSUSE-12.2-Update-Non-Oss' appears to outdated. Consider using a different mirror or server.
    Reading installed packages...
    
    
    S | Name                   | Type       | Version      | Arch   | Repository          
    --+------------------------+------------+--------------+--------+---------------------
    v | xf86-video-intel       | package    | 2.20.3-1.8.1 | x86_64 | openSUSE-12.2-Update
    i | xf86-video-intel       | package    | 2.20.0-1.5.1 | x86_64 | openSUSE-12.2-1.6   
    v | xf86-video-intel       | package    | 2.20.3-1.8.1 | i586   | openSUSE-12.2-Update
    v | xf86-video-intel       | package    | 2.20.0-1.1.1 | i586   | openSUSE-12.2-1.6   
      | xf86-video-intel       | srcpackage | 2.20.3-1.8.1 | noarch | openSUSE-12.2-Update
      | xf86-video-intel-32bit | package    | 2.20.3-1.8.1 | x86_64 | openSUSE-12.2-Update
      | xf86-video-intel-32bit | package    | 2.20.0-1.1.1 | x86_64 | openSUSE-12.2-1.6
    Downgrade the driver using
    Code:
    zypper in -f xf86-video-intel-2.20.0-1.5.1
    and reboot, X should load correctly.

    Hope that help.

    Now, some question for developers:

    Is this issue with the Intel driver a known problem? Since the package come from Update repo, i'll bet that many people can be affected.
    Or it's from the combination of the ati and intel with Xorg, coming out from FGLRX issue or Xorg-Server issue?
    From the logs, the segmentation fault happens when the FGLRX driver detect the "secondary card" and instruct X to load drivers for it (did i understood well?).
    Not pointing fingers on anyone, let's be clear. I't just difficult for people that get these hybrid graphics to find where the problem arise.

    Also, zypper now is complaining about openSUSE-12.2-Update-Non-Oss being outdated. It's a warning that can be ignored or is it something wrong?
    This system is a fresh 12.2 install, plus FGLRX driver and updates. Nothing more.

  3. #3
    Join Date
    Jun 2008
    Location
    Bellaria Igea Marina
    Posts
    24

    Default Re: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

    Same problem on HP dv6:

    Code:
    linux-vdkc:/home/gallochri # lspci 
    00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
    00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
    00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
    00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
    00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour XT/PRO [Radeon HD 7400M Series]
    07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
    0d:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
    13:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
    13:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
    Code:
    zypper se -s xf86-video-intel
    Lettura dei dati del repository in corso...
    Attenzione: Il repository 'openSUSE-12.2-Update-Non-Oss' non sembra essere aggiornato. Si consideri l'uso di un mirror o di un server diverso.
    Lettura dei pacchetti installati in corso...
    
    S | Nome                   | Tipo               | Versione     | Arch   | Repository          
    --+------------------------+--------------------+--------------+--------+---------------------
    v | xf86-video-intel       | pacchetto          | 2.20.3-1.8.1 | x86_64 | openSUSE-12.2-Update
    i | xf86-video-intel       | pacchetto          | 2.20.0-1.5.1 | x86_64 | openSUSE-12.2-1.6   
    i | xf86-video-intel       | pacchetto          | 2.20.0-1.5.1 | x86_64 | openSUSE-12.2-Oss   
    v | xf86-video-intel       | pacchetto          | 2.20.3-1.8.1 | i586   | openSUSE-12.2-Update
    v | xf86-video-intel       | pacchetto          | 2.20.0-1.1.1 | i586   | openSUSE-12.2-Oss   
      | xf86-video-intel       | pacchetto sorgente | 2.20.3-1.8.1 | noarch | openSUSE-12.2-Update
      | xf86-video-intel-32bit | pacchetto          | 2.20.3-1.8.1 | x86_64 | openSUSE-12.2-Update
      | xf86-video-intel-32bit | pacchetto          | 2.20.0-1.1.1 | x86_64 | openSUSE-12.2-Oss]

  4. #4
    Join Date
    Jun 2008
    Location
    Bellaria Igea Marina
    Posts
    24

    Default Re: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.


  5. #5

    Default Re: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

    My good sir, you are a lifesaver, thanks a lot!

  6. #6

    Default Re: Switchable graphics card, ATI and intel, failed to boot after install ati drivers.

    Quote Originally Posted by morgenst3rn View Post
    Downgrade the driver using
    Code:
    zypper in -f xf86-video-intel-2.20.0-1.5.1
    and reboot, X should load correctly.
    Amazing, this actually works. Thanks. Downgrading, wow.

    I had the same problem on my Dell Inspiron 7520 which had Intel Graphics + AMD Radeon HD 7570.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •