Results 1 to 5 of 5

Thread: BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

  1. #1

    Default BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

    Code:
    File mode specification error: (error "Face height does not produce a positive integer" 0.0)
    Hi,

    I asked this question yesterday at the Emacs-Mailinglist, but I think it is a bug of openSuse 12.2.

    Between version 12.1 and version 12.2 of openSuse is a difference: Emacs is
    partially broken. I tried with Emacs 23.3 from openSuse and a self compiled
    Emacs 24.2. I tried with ICEWM and (how do you call it?) LX-something, I created a new user, always the same result!

    After Emacs -Q --debug-init I get the message:

    Code:
    File mode specification error: (error "Face height does not produce a positive 
    integer" tex-suscript-height)
    as soon as I try to open a *.tex-file. And with my usual .emacs I get:

    Code:
    :~>Emacs --debug-init
    
       Debugger entered--Lisp error: (error "Face height does not produce a
         positive integer" 0.0)
         internal-set-lisp-face-attribute(cfw:face-annotation :height
         0.0 #<frame emacs@linux-nat6.site 0xea4f10>)
         set-face-attribute(cfw:face-annotation #<frame emacs@linux-nat6.site
         0xea4f10> :height 0.0) apply(set-face-attribute
         cfw:face-annotation #<frame emacs@linux-nat6.site 0xea4f10> (:height
         0.0)) face-spec-set-2(cfw:face-annotation #<frame
         emacs@linux-nat6.site 0xea4f10> ((t :height 0.0)))
         face-spec-recalc(cfw:face-annotation #<frame emacs@linux-nat6.site
         0xea4f10>) face-spec-set(cfw:face-annotation ((t :height 0.0)) t)
         custom-theme-set-faces(user (default ((t (:inherit nil :stipple
         nil :background "#fcfbf7" :foreground "#000000" :inverse-video
         nil :box nil :strike-through nil :overline nil :underline nil :slant
         normal :weight normal :height 112 :width normal :foundry
         "unknown" :family "Liberation Mono")))) (cfw:face-annotation
         ((t :height 0.0))) (cfw:face-default-content ((t (:height 0.0))))
         (cfw:face-periods ((t :height 0.0))) (org-column ((t (:background
         "grey90" :strike-through nil :underline nil :slant normal :weight
         normal))))) apply(custom-theme-set-faces user ((default ((t
         (:inherit nil :stipple nil :background "#fcfbf7" :foreground
         "#000000" :inverse-video nil :box nil :strike-through nil :overline
         nil :underline nil :slant normal :weight normal :height 112 :width
         normal :foundry "unknown" :family "Liberation Mono"))))
         (cfw:face-annotation ((t :height 0.0))) (cfw:face-default-content
         ((t (:height 0.0)))) (cfw:face-periods ((t :height 0.0)))
         (org-column ((t (:background "grey90" :strike-through nil :underline
         nil :slant normal :weight normal)))))) custom-set-faces((default ((t
         (:inherit nil :stipple nil :background "#fcfbf7" :foreground
         "#000000" :inverse-video nil :box nil :strike-through nil :overline
         nil :underline nil :slant normal :weight normal :height 112 :width
         normal :foundry "unknown" :family "Liberation Mono"))))
         (cfw:face-annotation ((t :height 0.0))) (cfw:face-default-content
         ((t (:height 0.0)))) (cfw:face-periods ((t :height 0.0)))
         (org-column ((t (:background "grey90" :strike-through nil :underline
         nil :slant normal :weight normal))))) eval-buffer(#<buffer *load*>
         nil "/home/AW/.emacs" nil t) ; Reading at buffer position 21856
         load-with-code-conversion("/home/AW/.emacs" "/home/AW/.emacs" t t)
         load("~/.emacs" t t)
         #[0 "\205\262
    This makes me !

    Exept for installing 12.2 again, I ran out of ideas!

  2. #2

    Default Re: BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

    I found a temporary solution to get Emacs and AucTeX working by adding those two lines to my .emacs at the custom-faces:

    Code:
    '(font-latex-subscript-face ((t nil)))
    '(font-latex-superscript-face ((t nil)))
    I opened a bug report 779248

    This is a nightmare: A new version of openSuse brings a partially broken Emacs.

  3. #3
    Join Date
    Jul 2011
    Location
    Swansea, UK
    Posts
    105

    Question Re: BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

    Hello,

    I installed XEmacs (and not Auctex, as it should be included in XEmacs, and the Auctex-package
    says it is incompatible with XEmacs).
    Now (with 12.2) Auctex is not available at all, that is, opening a .tex-file with XEmacs creates something like
    the naked Latex-style, without the possibilities for compilation etc. offered by Auctex.

    On the Internet I found to add
    Code:
    (require 'tex-site)
    to ~/.xemacs/.init.el, and that does something, namely now we get the additional menus
    Code:
    LaTeX
    Command
    however, on start-up we get an error-message
    Code:
    (1) (custom/warning) custom: widget custom-variable, option LaTeX-section-hook has no associated group
    And furthermore, with my last Suse-version, 11.4, there were these nice menu-buttons (icons) for compilation
    and for xdvi, which now disappeared.

    And when for example calling Command/View, then I get the error message
    Code:
    (3) (menubar/warning) Error in `activate-menubar-hook': (invalid-change (Modification of this buffer not currently permitted  *Echo Area*))
    Backtrace follows:
    nil
    So either the fix for getting back Auctex is somewhat broken, or Auctex itself is broken (or XEmacs).

    Shall I open another thread, for XEmacs (not Emacs, which I do not use, and accordingly I do not know about it)?

    Oliver

  4. #4

    Default Re: BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

    Emacs is unable to calculate correctly, as long as the environment variable LC_NUMERIC is not set to C.

    You can fix this by setting the variable via Yast-->"Editor for /etc/sysconfig"-->System-->Environment-->Language-->RC_LC_NUMERIC

    Gruß -- Olaf Meltzer

  5. #5

    Default Re: BUG: LaTeX-Mode broken in Emacs in openSuse 12.2!

    omeltzer wrote:
    > Emacs is unable to calculate correctly, as long as the environment
    > variable LC_NUMERIC is not set to C.
    >
    > You can fix this by setting the variable via Yast-->"Editor for
    > /etc/sysconfig"-->System-->Environment-->Language-->RC_LC_NUMERIC
    >
    > Gruß -- Olaf Meltzer


    AFAIK, emacs is a shell script. You could fix the environment locally in
    that script to avoid having to change the global numeric environment,
    which would affect numerical display in all applications.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •