Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: gnucash on opensuse 12.2: ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"

  1. #1
    Join Date
    Dec 2009
    Location
    Zurich
    Posts
    15

    Default gnucash on opensuse 12.2: ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"

    Installed 64 bit OpenSUSE 12.2 right after the release yesterday. Installed gnucash. On first run there was some dialog about settings but main GUI never came up. When starting gnucash the spash screen briefly pops up and then crashes with the message:

    user@host:~> gnucash
    gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

    ERROR: In procedure dynamic-link:
    ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"
    richi@zwirgli:~>

    Google reveals that there might be an issue with the guile library?

    How to remediate?

    TIA
    Richard

  2. #2

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    On Thu, 06 Sep 2012 06:36:02 GMT
    richardeigenmann <richardeigenmann@no-mx.forums.opensuse.org> wrote:

    >
    > Installed 64 bit OpenSUSE 12.2 right after the release yesterday.
    > Installed gnucash. On first run there was some dialog about settings
    > but main GUI never came up. When starting gnucash the spash screen
    > briefly pops up and then crashes with the message:
    >
    > user@host:~> gnucash
    > gnc.bin-Message: main: binreloc relocation support was disabled at
    > configure time.
    >
    > ERROR: In procedure dynamic-link:
    > ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"
    > richi@zwirgli:~>
    >
    > Google reveals that there might be an issue with the guile library?
    >
    > How to remediate?
    >


    No idea, but I've got exactly the same error.
    I've used versions 2.4.11 from Update and Gnome-apps repos.


    --
    Graham Davis, Bracknell, Berks.
    openSUSE 12.2 (64-bit); KDE 4.9.1; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: gnucash on opensuse 12.2: ERROR: file: "libguile-srfi-srfi-1-v-3",

    Am 06.09.2012 18:05, schrieb Graham P Davis:
    >> ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"


    There is a libguile-srfi-srfi-1-v-3-3 package, is that installed?

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  4. #4

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    On Thu, 06 Sep 2012 16:05:54 GMT
    Graham P Davis <cloddy@no-mx.forums.opensuse.org> wrote:

    > On Thu, 06 Sep 2012 06:36:02 GMT
    > richardeigenmann <richardeigenmann@no-mx.forums.opensuse.org> wrote:
    >
    > >
    > > Installed 64 bit OpenSUSE 12.2 right after the release yesterday.
    > > Installed gnucash. On first run there was some dialog about settings
    > > but main GUI never came up. When starting gnucash the spash screen
    > > briefly pops up and then crashes with the message:
    > >
    > > user@host:~> gnucash
    > > gnc.bin-Message: main: binreloc relocation support was disabled at
    > > configure time.
    > >
    > > ERROR: In procedure dynamic-link:
    > > ERROR: file: "libguile-srfi-srfi-1-v-3", message: "file not found"
    > > richi@zwirgli:~>
    > >
    > > Google reveals that there might be an issue with the guile library?
    > >
    > > How to remediate?
    > >

    >
    > No idea, but I've got exactly the same error.
    > I've used versions 2.4.11 from Update and Gnome-apps repos.
    >
    >


    Used "versions" tab in Yast to back off to 2.4.10 and all seems OK with
    that one. When installing 2.4.10, Yast added a lot of linked software including guile libs.

    I've now updated 2.4.10 to 2.4.11 and it still works. It seems that the
    versions in "update" and "Gnome-apps" don't have the necessary info to
    tell the system what other modules need to be linked in.

    I suspect that if I'd installed Gnucash during the initial installation
    process, I wouldn't have had a problem. I'll try that out tomorrow on
    another machine. Instead, I installed the program after the 12.2
    installation had completed and so Yast installed the "update" version
    and so bypassing installation of 2.4.10, hence missing all the
    necessary ancillary modules.


    --
    Graham Davis, Bracknell, Berks.
    openSUSE 12.2 (64-bit); KDE 4.9.1; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  5. #5
    Join Date
    Dec 2009
    Location
    Zurich
    Posts
    15

    Default Re: gnucash on opensuse 12.2: ERROR: file: "libguile-srfi-srfi-1-v-3",

    Thanks

    zypper in libguile-srfi-srfi-1-v-3-3

    Fixed the issue.

    Perhaps the dependency could be added to the gnucash package?

    Regards,
    Richard

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: gnucash on opensuse 12.2: ERROR: file: "libguile-srfi-srfi-1-v-3",

    You need to make a bugreport for that, the developers do not read the
    forums as far as I know.
    https://bugzilla.novell.com
    login is the same as for the forum.


    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    Quote Originally Posted by Martin Helm
    You need to make a bugreport for that, the
    developers do not read the forums as far as I know.
    https://bugzilla.novell.com
    login is the same as for the forum.
    Hi
    I've made them aware

    @richardeigenmann please raise a bug report, I will assign it to the
    right person.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
    up 20:35, 3 users, load average: 0.21, 0.17, 0.20
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  8. #8

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    On Thu, 06 Sep 2012 20:03:20 GMT
    malcolmlewis <malcolmlewis@no-mx.forums.opensuse.org> wrote:

    >
    Quote Originally Posted by Martin Helm
    You need to make a bugreport for that, the
    > developers do not read the forums as far as I know.
    > https://bugzilla.novell.com
    > login is the same as for the forum.
    >
    > Hi
    > I've made them aware
    >
    > @richardeigenmann please raise a bug report, I will assign it to the
    > right person.
    >


    There are a couple of reports already. The active one is
    https://bugzilla.novell.com/show_bug.cgi?id=779458

    --
    Graham Davis, Bracknell, Berks.
    openSUSE 12.2 (64-bit); KDE 4.9.1; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    Quote Originally Posted by Graham P Davis
    On Thu, 06 Sep 2012 20:03:20 GMT
    malcolmlewis <malcolmlewis@no-mx.forums.opensuse.org> wrote:

    >
    Quote Originally Posted by Martin Helm
    You need to make a bugreport for that, the
    > developers do not read the forums as far as I know.
    > https://bugzilla.novell.com
    > login is the same as for the forum.
    >
    > Hi
    > I've made them aware
    >
    > @richardeigenmann please raise a bug report, I will assign it to the
    > right person.
    >


    There are a couple of reports already. The active one is
    https://bugzilla.novell.com/show_bug.cgi?id=779458
    Hi Graham
    Thanks for the heads up, I see Dominique has assigned it to himself

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
    up 1 day 1:05, 3 users, load average: 0.30, 0.13, 0.08
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  10. #10
    Join Date
    Jul 2008
    Location
    Germany / Saxony / Chemnitz
    Posts
    40

    Default Re: gnucash on opensuse 12.2: ERROR: file:

    Hi all,
    Unfortunately installing libguile-srfi-srfi-1-v-3-3 helped me only a few days.
    I did an update on Sept 18, some components of libguile were updated and
    now GnuCash won't start -> I don't get beyond the splash

    the terminal gives:
    > gnucash
    gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

    WARNING: gnome-keyring:: couldn't connect to: /run/user/ralf/keyring-chVysw/pkcs11: Datei oder Verzeichnis nicht gefunden
    Backtrace:
    In unknown file:
    ?: 0* [primitive-load-path "slib/guile.init"]

    <unnamed port>: In procedure primitive-load-path in expression (primitive-load-path name):
    <unnamed port>: Unable to find file "slib/guile.init" in load path

    what do I need to do or downgrade?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •