Results 1 to 4 of 4

Thread: "Default" resolution for Grub2

  1. #1

    Default "Default" resolution for Grub2

    Ever since I replaced my old graphics card with a fairly recent AMD device (HD6670), I run into trouble booting with the regular VGA settings:

    On 12.1, the image on one of my screens would be displaced during the bootsplash and once KDM took over that screen flickered intensely and KDE would stop loading altogether after four or five icons. Setting the resolution in Grub from whatever it suggested to "Default" fixed this issue all the way. The bootsplash graphics would not load, but I got a proper framebuffer console and KDE would start up without a hitch.

    The issue still occurs with the 12.2 KDE live CD, but again, setting the resolution to "Default" fixes it and even preserves the splash screen this time.

    However, once 12.2 is installed, I'm greeted by a black and white Grub2, with the image on one screen again displaced and the flicker issue will start immediately after selecting the OpenSUSE option. Temporarily removing the "splash=silent" option from the Grub2 settings will again result in a console without the flickering screen, but now the issue just returns once KDM kicks in and KDE again hangs during load.

    I am not entirely sure what the technical differences between "1280x1024" and "Default" were on the old Grub, but I really need a "don't try fancy stuff" setting for Grub2, that covers both the framebuffer/splash phase and the desktop.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: "Default" resolution for Grub2

    Quote Originally Posted by cyrusxiii View Post
    Ever since I replaced my old graphics card with a fairly recent AMD device (HD6670), I run into trouble booting with the regular VGA settings:

    On 12.1, the image on one of my screens would be displaced during the bootsplash and once KDM took over that screen flickered intensely and KDE would stop loading altogether after four or five icons. Setting the resolution in Grub from whatever it suggested to "Default" fixed this issue all the way. The bootsplash graphics would not load, but I got a proper framebuffer console and KDE would start up without a hitch.

    The issue still occurs with the 12.2 KDE live CD, but again, setting the resolution to "Default" fixes it and even preserves the splash screen this time.

    However, once 12.2 is installed, I'm greeted by a black and white Grub2, with the image on one screen again displaced and the flicker issue will start immediately after selecting the OpenSUSE option. Temporarily removing the "splash=silent" option from the Grub2 settings will again result in a console without the flickering screen, but now the issue just returns once KDM kicks in and KDE again hangs during load.

    I am not entirely sure what the technical differences between "1280x1024" and "Default" were on the old Grub, but I really need a "don't try fancy stuff" setting for Grub2, that covers both the framebuffer/splash phase and the desktop.
    After you are running openSUSE 12.2, you can go into YaST / System / Boot Loader / Type: Boot Loader Options / Console Resolution where you can select a fixed value or use Autodetect by Grub 2. Have you looked at this option before? Have you just installed the new openSUSE 12.2 GM or are you using an RC version? I have a bash script that can be helpful with the new Grub 2 you can find here: GNU Grub2 Command Help/Config Editor - Version: 1.75 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: "Default" resolution for Grub2

    Or just set 800x600 instead of autodetect during installation. It might be safer after all.

  4. #4

    Default Re: "Default" resolution for Grub2

    Changing "gfxpayload=keep" to "gfxpayload=640x480" did get the system to boot properly. I then set that resolution in YaST's bootloader module and things have worked fine since. Not sure about 800x600, I guess it might work too?

    A few notes:
    • In spite of Grub2 being set to 640x480, the framebuffer/bootsplash phase still uses the native resolution of each display - KMS magic?
    • The placement of the splash graphics was still all over the place so I disabled them by removing "splash=silent" from the boot options as well.
    • I was able to fix the Grub2 theme by selecting it manually in YaST. Not sure if it didn't intially appear due to me selecting the "Default" VGA setting when booting the installer or using a separate boot partition (encrypted root and such).


    Aw well, mark as solved then?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •