Results 1 to 3 of 3

Thread: iFolder Client in 12.2

  1. #1

    Default iFolder Client in 12.2

    Hi, I jumped the gun and installed 12.2 RC 2, and am now looking to get the iFolder Client installed.

    There are no 12.2 packages in OBS yet, so I thought I'd try with the factory.
    From past experience I made sure to add mono-devel and mono-wcf.
    It installs fine, but won't run - from console I get the response below.

    -Any clues as to which runtime version it might refer to? (mono in this install is 2.10.6-5.6.1 vs a happy 2.10.6-2.4.1 on a 12.1/tumbleweed)
    -A web search on the glib errors wound an ifolder user with a missing 'gnome' package, but didn't identify what....

    Any suggestions welcome!

    Code:
    WARNING: The runtime version supported by this application is unavailable.
    Using default runtime: v2.0.50727
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
    (process:7061): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
    (process:7061): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
    (process:7061): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed
    (process:7061): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed
    (process:7061): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
    (process:7061): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,039

    Default Re: iFolder Client in 12.2

    On Sun, 02 Sep 2012 22:56:02 +0000, agt499 wrote:

    > There are no 12.2 packages in OBS yet, so I thought I'd try with the
    > factory.
    > From past experience I made sure to add mono-devel and mono-wcf.
    > It installs fine, but won't run - from console I get the response below.
    >
    > -Any clues as to which runtime version it might refer to? (mono in this
    > install is 2.10.6-5.6.1 vs a happy 2.10.6-2.4.1 on a 12.1/tumbleweed) -A
    > web search on the glib errors wound an ifolder user with a missing
    > 'gnome' package, but didn't identify what....


    I wouldn't expect a version that works with 12.2 yet. But the
    dependencies for iFolder do list the versions of the Mono components
    required, and Mono is *extremely* picky about having the correct versions
    - when it says version "1.23", it means *exactly* that version and not
    "version 1.23 or newer".

    Have a look at the dependencies for the iFolder package, as that'll tell
    you what you need to have installed.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: iFolder Client in 12.2

    Thanks for that Jim.

    It turns out the missing package I had to install was libgnomeui, which wasn't listed as a dependency.
    I found it sort-of-by-accident, -I realised iFolder was working this morning and managed to "rpm -qa --last" my way to finding what did it!

    (I agree that it's a miracle that the Mono versions behaved this time)

    Thanks for your input!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •