Results 1 to 4 of 4

Thread: Unable to set PATH variable permanently

  1. #1

    Default Unable to set PATH variable permanently

    Whenever I restart the terminal session the setting is lost and I get the following message:

    If 'eclipse' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf eclipse

    What is wrong?

    larilund

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,224
    Blog Entries
    15

    Default Re: Unable to set PATH variable permanently

    Quote Originally Posted by larilund
    Whenever I restart the terminal session the setting is lost and I get
    the following message:

    If 'eclipse' is not a typo you can use command-not-found to lookup the
    package that contains it, like this:
    cnf eclipse

    What is wrong?

    larilund

    Hi
    Either create a softlink to the eclipse executable in your ~/bin or add
    the path to your ~/.profile you could also create a desktop file.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
    up 3:28, 3 users, load average: 0.36, 0.21, 0.16
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Unable to set PATH variable permanently

    I do not know where and when you set it. Thus I can not tell if it is extraordinaly that it is not set to your liking at some later, not defined by you, point in time.

    But you normaly set the environment variable PATH in a way that it is set for next login sessions in one's .profile.
    Henk van Velden

  4. #4
    josephkk NNTP User

    Default Re: Unable to set PATH variable permanently

    On Sat, 01 Sep 2012 16:56:02 GMT, larilund
    <larilund@no-mx.forums.opensuse.org> wrote:

    >
    >Whenever I restart the terminal session the setting is lost and I get
    >the following message:
    >
    >If 'eclipse' is not a typo you can use command-not-found to lookup the
    >package that contains it, like this:
    >cnf eclipse
    >
    >What is wrong?
    >
    >larilund


    How did you install eclipse? If it was installed normally (yast or
    zypper) the installer would have taken care of this.

    ?-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •