Results 1 to 5 of 5

Thread: Add an aplication Startup to XFCE 4.8

  1. #1

    Default Add an aplication Startup to XFCE 4.8

    Hi! I want to add 2 aplications to execute when i loged in, but my OpenSuse 12.1 XFCE 4.8 don't have the Startup Manager like Gnome, how can i do this?

  2. #2

    Default Re: Add an aplication Startup to XFCE 4.8

    Don't you see an icon for "Session and Startup" in XFCE settings manager? If you can not find it, type:

    Code:
    $ xfce4-session-settings
    Then open the tab "Application Autostart" and click on 'Add'.

    Alternately you can create a .desktop file and put it in ~/.config/autostart.

    Here's an example:

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Name=Main Console
    Comment=Run a terminal in the background
    Exec=terminal-wrapper
    StartupNotify=false
    Terminal=false
    Hidden=false
    OnlyShowIn=GNOME;XFCE;LXDE;
    X-GNOME-Autostart-enabled=true
    Replace the text in red with your command. Setting "Hidden" to true will prevent this application from starting under XFCE. Thus it should either be false or this key should not exist.

  3. #3

    Default Re: Add an aplication Startup to XFCE 4.8

    Quote Originally Posted by please_try_again View Post
    Don't you see an icon for "Session and Startup" in XFCE settings manager? If you can not find it, type:

    Code:
    $ xfce4-session-settings
    Then open the tab "Application Autostart" and click on 'Add'.

    Alternately you can create a .desktop file and put it in ~/.config/autostart.

    Here's an example:

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Name=Main Console
    Comment=Run a terminal in the background
    Exec=terminal-wrapper
    StartupNotify=false
    Terminal=false
    Hidden=false
    OnlyShowIn=GNOME;XFCE;LXDE;
    X-GNOME-Autostart-enabled=true
    Replace the text in red with your command. Setting "Hidden" to true will prevent this application from starting under XFCE. Thus it should either be false or this key should not exist.
    When i do that i get this message:

    Unable to contact settings server
    Did not receive a reply. Possible causes include: the
    remote application did not send a reply, the message
    bus security policy blocked the reply, the reply
    timeout expired, or the network connection
    was broken.

  4. #4

    Default Re: Add an aplication Startup to XFCE 4.8

    Quote Originally Posted by kevingcfcb88 View Post
    When i do that i get this message:
    Unable to contact settings server
    Did not receive a reply. Possible causes include: the
    remote application did not send a reply, the message
    bus security policy blocked the reply, the reply
    timeout expired, or the network connection
    was broken.
    When you do what? With which application/command?

  5. #5

    Default Re: Add an aplication Startup to XFCE 4.8

    Quote Originally Posted by please_try_again View Post
    When you do what? With which application/command?
    SOLVED

    That message it came to me when i do

    # xfce4-session-settings
    But in root user, when i do it in my user, all goes good... Thanks a lot!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •