Results 1 to 3 of 3

Thread: Firefox opens pdf with gedit

  1. #1

    Default Firefox opens pdf with gedit

    I don't know when exactly it started doing it, it wasn't doing it in the beginning for sure. What happens is that when you click on a link to a pdf file, Firefox asks you what to do with it - open with, save file, etc. Since a couple of days "open with" defaults to gedit, instead of evince. And it's really annoying, as even if you manually select /usr/bin/evince , the next time you try to open another pdf, Firefox keeps offering gedit as a default pdf viewer.

    Anyway, I don't know what is the reason for this, but here is the solution that worked for me, I hope it is useful for others as well:

    Go to ~/.local/share/applications/ folder and check its contents. If you see the files mimeapps.list and defaults.list - delete them or move them elsewhere. Restart firefox and voila. If you're curious - check the contents of these files to try to find out what have put them there.

    P.S. This is openSUSE 12.1 x64 with Gnome Cinnamon

    Cheers

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Firefox opens pdf with gedit

    Simeonof wrote:

    >
    > I don't know when exactly it started doing it, it wasn't doing it in the
    > beginning for sure. What happens is that when you click on a link to a
    > pdf file, Firefox asks you what to do with it - open with, save file,
    > etc. Since a couple of days "open with" defaults to gedit, instead of
    > evince. And it's really annoying, as even if you manually select
    > /usr/bin/evince , the next time you try to open another pdf, Firefox
    > keeps offering gedit as a default pdf viewer.
    >
    > Anyway, I don't know what is the reason for this, but here is the
    > solution that worked for me, I hope it is useful for others as well:
    >
    > Go to ~/.local/share/applications/ folder and check its contents. If
    > you see the files mimeapps.list and defaults.list - delete them or move
    > them elsewhere. Restart firefox and voila. If you're curious - check the
    > contents of these files to try to find out what have put them there.
    >
    > P.S. This is openSUSE 12.1 x64 with Gnome Cinnamon
    >
    > Cheers
    >
    >


    Firefox prefs > Applications
    Search PDF
    Change

  3. #3
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Firefox opens pdf with gedit

    Quote Originally Posted by Simeonof View Post
    I don't know when exactly it started doing it, it wasn't doing it in the beginning for sure. What happens is that when you click on a link to a pdf file, Firefox asks you what to do with it - open with, save file, etc. Since a couple of days "open with" defaults to gedit, instead of evince. And it's really annoying, as even if you manually select /usr/bin/evince , the next time you try to open another pdf, Firefox keeps offering gedit as a default pdf viewer.

    Anyway, I don't know what is the reason for this, but here is the solution that worked for me, I hope it is useful for others as well:

    Go to ~/.local/share/applications/ folder and check its contents. If you see the files mimeapps.list and defaults.list - delete them or move them elsewhere. Restart firefox and voila. If you're curious - check the contents of these files to try to find out what have put them there.

    P.S. This is openSUSE 12.1 x64 with Gnome Cinnamon

    Cheers
    Install the https://addons.mozilla.org/en-US/firefox/addon/pdfjs/ extension, and most will open in a new tab.

    This will be a feature in a future version of Firefox. Most likely Firefox 18.

    Actually the feature is already there, but disabled by default.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •