Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: YaST on ncurses Yes, YaST on GUI Not

  1. #1
    Join Date
    Apr 2012
    Location
    Switzerland
    Posts
    41

    Default YaST on ncurses Yes, YaST on GUI Not

    Hello,

    I am a Newcomer on OpenSUSE and Linux. This is my first Thread!

    I am the only user of this computer, and some days ago, on shell I changed user and root passwords.

    I don't have any problem since, but YaST2 runs only by commands on shell (as ncurses). In GUI (KDE 4.7) the YaST/root password is apparently accepted but later nothing appears on the screen.

    What to do?
    Thanks.

    Pablo Vegezzi

    _______________________________________________

    Desktop: OpenSUSE 12.1 ; x86_32 ; KDE 4.7.2
    on Dell Dimension E520 ; Intel Core2 1.86GHz ; 6 RAM

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Run the exact same command the yast entry in the menu uses as normal
    user from a terminal and post the output it produces, maybe there is a
    message it logs to the terminal which helps to identify the problem.

    Code:
    /usr/bin/xdg-su -c /sbin/yast2
    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  3. #3
    Join Date
    Apr 2012
    Location
    Switzerland
    Posts
    41

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Hello,
    The answer I get is:

    Code:
    linux-gk:/ # /usr/bin/xdg-su -c /sbin/yast2
    kdesu(14865)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    KCrash: Application 'kdesu' crashing...
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
    sock_file=/root/.kde4/socket-linux-gkkg/kdeinit4__0
    Warning: connect() failed: : Connexion refusée
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
    drkonqi(14866)/kdeui (kdelibs): Session bus not found 
    To circumvent this problem try the following command (with Linux and bash) 
    export $(dbus-launch) 
    linux-gk:/ #
    " .... following command (with Linux and bash) ..." means to write a batch file?

    Thank you,

    Pablo Vegezzi

    ______________________________________________
    Desktop: OpenSUSE 12.1 ; x86_32 ; KDE 4.7.2
    on Dell Dimension E520 ; Intel Core2 1.86GHz ; 6 RAM

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Am 23.08.2012 18:26, schrieb palp56:
    > linux-gk:/ #

    Did you run that as root? I explicitly said as normal user.
    If you do not run that command as normal user the output is useless.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  5. #5
    Join Date
    Apr 2012
    Location
    Switzerland
    Posts
    41

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Hello,

    martin_helm said:
    > Am 23.08.2012 18:26, schrieb palp56:
    > > linux-gk:/ #

    > Did you run that as root? I explicitly said as normal user.
    > If you do not run that command as normal user the output is useless.

    I agree. Runing as user the answer is:

    Code:
    p@linux-gk:/> /usr/bin/xdg-su -c /sbin/yast2
    kdesu(16422)/kdesu (kdelibs) KDESu::KDEsuClient::command: [ /home/abuild/rpmbuild/BUILD/kdelibs-4.7.2/kdesu/client.cpp : 209 ]  no reply from daemon. 
    p@linux-gk:/>
    Pablo Vegezzi
    ______________________________________________
    Desktop: OpenSUSE 12.1 ; x86_32 ; KDE 4.7.2
    on Dell Dimension E520 ; Intel Core2 1.86GHz ; 6 RAM

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    There was a long winded thread about that here
    http://forums.opensuse.org/english/g...koff-menu.html

    I cannot oversee quickly if that was solved.

    What happens when you do
    Code:
    su -
    yast2
    ?
    The minus in "su -" is essential here.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  7. #7
    Join Date
    Apr 2012
    Location
    Switzerland
    Posts
    41

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Quote Originally Posted by martin_helm View Post
    There was a long winded thread about that here
    http://forums.opensuse.org/english/g...koff-menu.html

    I cannot oversee quickly if that was solved.

    What happens when you do
    Code:
    su -
    yast2
    ?
    The minus in "su -" is essential here.
    I have just tryed and the GUI YaST2 runs.
    On the Konsole :

    Code:
      
    p@linux-gk:~> su -
    Password : 
    linux-gk:~ # yast2
    Run command: /sbin/yast2 online_update_configuration &
    linux-gk:~ # exit
    logout
    p@linux-gk:~> 
    It's a big steep!
    I will go to read the 'YaST won't open up ... '

    Really thank you!

    Pablo Vegezzi

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    That confirms a bit that it may be just a problem with kdesu (which is
    the helper program showing the graphical password dialog for root) and
    not some deeper problem.
    Good that su - works for you, so there is at least a workaround. For the
    kdesu problem itself I do not know a solution, I hope there is something
    in the mentioned thread which works for you.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    When we are looking at kdesu as the culprit, can you try Kmenu > System > File manager > File manager in system manager mode (or same wording, I have a translation here). IMHO it uses the same mechanism to become superuser.
    Henk van Velden

  10. #10
    Join Date
    Apr 2012
    Location
    Switzerland
    Posts
    41

    Default Re: YaST on ncurses Yes, YaST on GUI Not

    Quote Originally Posted by hcvv View Post
    When we are looking at kdesu as the culprit, can you try Kmenu > System > File manager > File manager in system manager mode (or same wording, I have a translation here). IMHO it uses the same mechanism to become superuser.
    I tried but as before, after the password nothing happens.

    An option of your proposition, YaST Configuration System > YaST
    gives the same result. And the button 'run YaST' automatically authorizes me as a simple 'user' to the restricted form of YaST.

    martin_helm's proposition works, and I would say that it's OK.
    Simply I am not really conscious of the system problem in which I am.
    I will know.

    I ask me what or how it happened.
    Things will get normal wiht update of KDE or openSUSE?
    I must start by the 16 pages of 'yast-wont-open-up-when-opened-kickoff-menu'.

    Thanks,
    Pablo Vegezzi
    ___________________________________________
    Desktop: OpenSUSE 12.1 ; x86_32 ; KDE 4.7.2
    on Dell Dimension E520 ; Intel Core2 1.86GHz ; 6 RAM

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •