Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: scangear (Canon OSS Inject scanning software) doesn't work

  1. #1

    Default scangear (Canon OSS Inject scanning software) doesn't work

    Greetings, Could somebody help me please to solve this p-roblem. dmesg shows "usbfs: usb_submit_urb returned -121" error message. Greatest thanks in advance,

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,156

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    At least tell what openSUSE version you use.
    Henk van Velden

  3. #3

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    Version 11.4 with Xfce Desktop management system is used there. Scangear version is 1.60-1. It was installed with with install.sh file launching. Multifunctional model is MP280.

  4. #4

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    So no luck to get it solved? Could somebody help to fix it?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    Could somebody help to fix it?
    Not necessarily. It all depends on what the cause is

    1. Are you able to scan at all? I assume not, but your info has so far been very brief.

    2. When you installed scangear via the install script, did you get any errors? It may well be that dependencies were not met - specifically libusb libraries may be missing perhaps.

    Post the output of
    Code:
    # rpm -qa|grep libusb
    This thread may (or may not) be helpful to you

    Puppy Linux Discussion Forum :: View topic - mp280 scanner fails again!

  6. #6

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    Greetings, Thank you for your help. Command output on grep usb is
    Code:
     usbmuxd-1.0.6-5.1.i586
    Code:
     libusb-0_1-4-0.1.13-9.1.i586
    Code:
     usb_modeswitch-data-1.1.6-5.1.noarch
    Code:
     libusbmuxd1-1.0.6-5.1.i586
    Code:
     usbutils-001-3.1.i586
    Code:
     libusb-1_0-0-1.0.8-4.1.i586
    Code:
     usb_modeswitch-1.1.6-5.1.i586
    I tried to compile newer version of scangear, but it fails even to be launched - GUI warning about no scanners in system is being showed on launching scangearmp now. I try to update cnijfilter software package but I can't find information about which version relates to scangear 1.8. Version 3.40 is installed now. So could you please to help me find this information?

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    The MP280 series IJ Printer Driver Ver. 3.40 for Linux (rpm Packagearchive) RPM tarball can be found here

    MP280 series IJ Printer Driver Ver. 3.40 for Linux (rpm Packagearchive)

    I also found MP280 series ScanGear MP Ver. 1.60 for Linux (rpm Packagearchive):

    MP280 series ScanGear MP Ver. 1.60 for Linux (rpm Packagearchive)

    They're both dated 3-Sept-2010

    Anyway, the former site allows you to download a compressed file containing the required cnijfilter-common-3.40-1. and cnijfilter-mp280series-3.40-1 packages. I managed to download,extract, then install the appropriate RPMs without issue. (I'm running openSUSE 11.4, however I don't own Canon hardware to test with).
    Last edited by deano_ferrari; 04-Sep-2012 at 02:35.

  8. #8

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    Greetings, Thank you for your attention to my problem. Unfortunately I have same situation - software is being installed w/out any problem. But in doesn't work - scanning progress was hanged on random step on using scangear 1.60 (between 3% and 17%), even on full-path scanning panel moving; and scangear 1.80 shows GUI message about scanner is not found (after scangearmp update from 1.60 to 1.80 version). Version 3.40 of cnij-stuff is one I try to change for newer version, so I'll thankful for advice cnij of which version could be used with scangear 1.80. Greatest thanks in advance,

  9. #9

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    I'm sorry for lost line breaks in previous message. I meant next:

    Thank you for your attention to my problem. Unfortunately I have same situation - software is being installed w/out any problem. But in doesn't work - scanning progress was hanged on random step on using scangear 1.60 (between 3% and 17%), even on full-path scanning panel moving; and scangear 1.80 shows GUI message about scanner is not found (after scangearmp update from 1.60 to 1.80 version). Version 3.40 of cnij-stuff is one I try to change for newer version, so I'll thankful for advice cnij of which version could be used with scangear 1.80.

    Greatest thanks in advance,

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: scangear (Canon OSS Inject scanning software) doesn't work

    so I'll thankful for advice cnij of which version could be used with scangear 1.80.
    I'm not sure that I can help you with that. It's Canon software, and not currently supported for that model AFAIU. Ideally, we need a user with a Canon scanner of the same (or similar) model to chime in.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •