I've recently installed Factory, and subsequently installed Cinnamon using the one-click link on the Cinnamon website. The problem that I'm having is that each time I start Cinnamon from the DM, it would load and everything, but after about a minute or so, it would crash. A black screen appears with the message,
Oh no! Something has gone wrong. A Problem has occurred and the system can't recover. Please log out and try again.
However, if I were to run the command "cinnamon --replace" in a terminal, the desktop loads and doesn't crash.

This is the printout from the terminal while Cinnamon is running:
Window manager warning: 0 stored in GConf key /desktop/gnome/peripherals/mouse/cursor_size is out of range 1 to 128
JS ERROR: !!! WARNING: 'anonymous function does not always return a value'
JS ERROR: !!! WARNING: file '/usr/share/cinnamon/js/ui/expoThumbnail.js' line 179 exception 0 number 157
JS ERROR: !!! WARNING: 'anonymous function does not always return a value'
JS ERROR: !!! WARNING: file '/usr/share/cinnamon/js/ui/expoThumbnail.js' line 526 exception 0 number 157
JS ERROR: !!! WARNING: 'anonymous function does not always return a value'
JS ERROR: !!! WARNING: file '/usr/share/cinnamon/js/ui/expoThumbnail.js' line 571 exception 0 number 157
JS ERROR: !!! WARNING: 'anonymous function does not always return a value'
JS ERROR: !!! WARNING: file '/usr/share/cinnamon/js/ui/expoThumbnail.js' line 731 exception 0 number 157
JS LOG: Cinnamon started at Thu Aug 23 2012 07:23:01 GMT-0400 (AST)

(cinnamon:4842): Clutter-WARNING **: Failed to set the markup of the actor 'ClutterText': Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &

(cinnamon:4842): Clutter-WARNING **: Attempting to add actor of type 'CinnamonGenericContainer' to a container of type 'StBoxLayout', but the actor has already a parent of type 'StBoxLayout'.
Can anyone help with this issue?