Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: trouble with screens crushing on openSuSE 11.0

  1. #1

    Angry trouble with screens crushing on openSuSE 11.0







    Folks, it is my first post here, and most likely I will be committing something inappropriate, so please have mercy . Besides, I am a plane dumb user; have this in mind when replying...

    OK, I have openSuSE 11.0 installed 4 years ago on desktop Dell Optiplex 745. Yesterday, Comcast people installed a new modem to boost up the internet speed, and when they left, my computer crushed first time in 4 years. It keep happening even after I disconnected the modem and router. I don't know how to call it properly -- both of my monitors (I have two big ones with 21" diagonal each) go monocolor (all the windows and icons disappeared) 5 minutes after I get into my account, and then in a minute both of them go completely dark, with a msg "going into power saving mode" or something like that flashing periodically. To shut it down then I have to disconnect the power.

    Now, I tried a lot of thing at the loading stage, and one of them worked, sort of, -- when I got into "FailSafe Mode", I was able to login into my account, and it would not crash. But then I have both screens/monitors acting as exact copies of each other, with all the X-windows sitting on the top of each other, and all the icons, windows, and fonts being overblown -- so I cannot do my regular work (computations, GNU-plots, Latex, groff, etc). However, I can at least go into internet and cry on your shoulder... -- the connection works!

    I have a (non-expert!) suspicion that a vpnclient_init command is doing something wrong -- at least I can see it being "Failed" on that running checking list both on login and logout stages.

    Please, any idea!? Can I go back to my old-shoe mode of operation?!!! Any help will be greatly appreciated!

    Best,
    alkap

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: trouble with screens crushing on openSuSE 11.0

    On 2012-08-20 04:06, alkap wrote:
    >
    > Folks, it is my first post here, and most likely I will be committing
    > something inappropriate, so please have mercy . Besides, I am a plane
    > dumb user; have this in mind when replying...


    :-)

    The first thing that anybody will tell you is that 11.0 is too old and out of maintenance. It
    will surely have security holes that put you in danger when you connect to internet.

    About your current problem... sorry, no idea at present.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,901

    Default Re: trouble with screens crushing on openSuSE 11.0

    Same as from Carlos. Apart from eventual security risks (which, depending on the environment the system is running in can be bad or negligable), such a system will be verry stable for years to come until the moment that you change something. Then you will find that the system as it is, does not have the support for a piece of new hardware and that the sources of the software running on it have vanished or changed to incompatible versions, etc. Also almost nobody here will have such a system anymore to reconstruct what you have or look into the configuration files as they were years ago. And the memories of people here will have forgotten the peculiarities of long ago.

    At the moment 11.4 and 12.1 are the supported versions and 12.2 will be there in a few monthes.
    Henk van Velden

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: trouble with screens crushing on openSuSE 11.0

    I also want to encourage you to upgrade. In your case I would even go
    for a fresh install, skipping 3 or 4 versions at once will probably lead
    to long winded reconfiguration and trouble shooting on the resulting
    system. I would not even keep the old configurations in the old /home
    (but do a backup of it first it may contain your emails depending on
    what mail client you use and other user data you want to keep).
    If you do not want to upgrade often install 11.4 it will be the next
    Evergreen, read that if you are interested

    http://en.opensuse.org/openSUSE:Evergreen

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  5. #5

    Default Re: trouble with screens crushing on openSuSE 11.0

    Dear Martin,
    thanks for suggestion to upgrade/install more recent release (same goes to the rest of people replied); especially for Evergreen version. Most likely, I will do it but not right away (as a non-expert I would expect with high probability to run into zillion of troubles while doing that, which may be much worse than what I am having right now -- remember, I am a plain user, and have no sysadmin experience...). For that I'd rather wait till I find somebody on our campus to help me out, but this could realistically be done only in September. Meanwhile, I would rather stick to my specific problem and try to deal with it first, especially since my success with FAILSAFE MODE indicates that the problem may be not too unsurmountable.  Thanks again! 

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: trouble with screens crushing on openSuSE 11.0

    Am 20.08.2012 15:26, schrieb alkap:
    > since my success with FAILSAFE MODE indicates that the problem may be
    > not too unsurmountable

    What graphics card do you have and which driver is in use?
    Code:
    /usr/sbin/hwinfo --gfxcard
    glxinfo | grep -i opengl
    /sbin/lspci -nnk | grep VGA -A 2
    hopefully where the same on the old system as they are now to give that
    information.
    You could also give us the
    Code:
    uname -a
    cat /proc/cmdline
    the "cat /proc/cmdline" when NOT in failsafe mode.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  7. #7

    Default Re: trouble with screens crushing on openSuSE 11.0

    Martin,
    Yes Sir!!! (Gosh,  what a relief to hear the voice of an expert...)  

    OK, the (shortened) reply to  /usr/sbin/hwinfo --gfxcard is
    08: PCI 100.1: 0380 Display controller
    [Created at pci.310]
    UDI: /org/freedesktop/Hal/devices/pci_1002_71a3

    Hardware Class: graphics card
    Model: "ATI RV516 [Radeon X1300 Pro] (Secondary)"

    Memory Range: 0xdfdf0000-0xdfdfffff (rw,non-prefetchable)
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #25 (PCI bridge)

    09: PCI 100.0: 0300 VGA compatible controller (VGA)
    [Created at pci.310]
    UDI: /org/freedesktop/Hal/devices/pci_1002_7183

    Hardware Class: graphics card
    Model: "ATI Radeon X1300/X1550 Series (RV516 7183)"
    SubDevice: pci 0x0d02
    Driver: "fglrx_pci"
    Driver Modules: "fglrx"
    Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
    Memory Range: 0xdfde0000-0xdfdeffff (rw,non-prefetchable)
    I/O Ports: 0xdc00-0xdcff (rw)
    Memory Range: 0xdfe00000-0xdfe1ffff (ro,prefetchable,disabled)
    IRQ: 16 (181709 events)
    I/O Ports: 0x3c0-0x3df (rw)
    Driver Info #0:
    XFree86 v4 Server Module: fglrx
    Driver Info #1:
    XFree86 v4 Server Module: fglrx
    3D Support: yes
    Extensions: dri
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #25 (PCI bridge)

    Primary display adapter: #9
    ======================================================

    ======================================================
    reply to "glxinfo | grep -i opengl":
    OpenGL vendor string: Mesa project: Mesa Home Page
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.3)
    OpenGL extensions:
    ======================================================
    reply to "/sbin/lspci -nnk | grep VGA -A 2"
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] [1002:7183]
    Kernel driver in use: fglrx_pci
    Kernel modules: fglrx
    ======================================================


    reply to "cat /proc/cmdline" in REGULAR mode:

    root=/dev/disk/by-id/scsi-SATA_WDC_WD2500JS-75_WD-WCANKA111333-part6 resume=/dev/sda5 splash=silent vga=0x317
    ======================================================
    reply to "uname -a":
    Linux super 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 x86_64 x86_64 x86_64 GNU/Linux
    =========================================

    Hope, it is useful. Thanks!
    Alex

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: trouble with screens crushing on openSuSE 11.0

    Reading your first post again, we maybe do not even need anything from
    that. You seem to have a problem with the powersave settings, in that
    case it can be easy if you are lucky.
    Which desktop environment are you using? KDE or Gnome or something else?

    If you have the default KDE desktop can you run (I am not sure if that
    is the right one for 11.0) in your

    system settings -> advanced -> power management

    this can have somewhat different names (maybe system settings is desktop
    settings or personal settings this changed over the years).

    If you find that disable every setting you find which sends your machine
    to sleep).

    If you cannot find that report back.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: trouble with screens crushing on openSuSE 11.0

    You can also check if some power daemon is running
    Code:
    ps aux | grep power
    if you are not in failsafe mode and compare that to the same command in
    failsafe mode, in that case you could disable it.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: trouble with screens crushing on openSuSE 11.0

    Am 20.08.2012 18:46, schrieb alkap:
    > reply to "cat /proc/cmdline" in REGULAR mode:
    >
    > root=/dev/disk/by-id/scsi-SATA_WDC_WD2500JS-75_WD-WCANKA111333-part6
    > resume=/dev/sda5 splash=silent vga=0x317

    I am almost sure your problem will simply disappear when you add a
    "acpi=off" to the kernel boot line.
    To do that you run
    yast -> system -> boot loader -> select the boot entry which is not
    failsafe and then edit.
    In the field where you see the splash=silent add the acpi=off at the end
    and press ok, then reboot.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •