Results 1 to 8 of 8

Thread: 12.1 Online Update breaks Libre Office on x86 32bit Hw

  1. #1

    Default 12.1 Online Update breaks Libre Office on x86 32bit Hw

    Hello list, moderators!

    I need some help to get the Libre Office version loaded by Yast > Online Update working if possible.

    After the update, the response opening oowriter from a terminal is this:

    frank[2995] /usr/bin/oowriter
    terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
    frank[2995]

    The direct open from the icon brings up the oo logo with a progress bar for a second or two.

    Since I can't get the version from the app, Yast > SwManagement > versions shows 3.4.5.7-4.8.1-586 Vendor openSUSE.

    With a recent 12.1 Online Update on a newer box, I got the same result and posted that experinece to an existing thread in this forum titled Libre Office Problem post #9.

    This existing thread seemed to solve a similar problem, but that solution didn't work for me. One of the responders mentioned something like OBS as a solution, then went on to a zypper update. On my newer box his zypper solution didn't work either.

    I can roll the oo version back to 3.4 like I did with the other box but I would appreciate some help to make this version work. heboland

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    Quote Originally Posted by heboland View Post
    Hello list, moderators!

    I need some help to get the Libre Office version loaded by Yast > Online Update working if possible.

    After the update, the response opening oowriter from a terminal is this:

    frank[2995] /usr/bin/oowriter
    terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
    frank[2995]

    The direct open from the icon brings up the oo logo with a progress bar for a second or two.

    Since I can't get the version from the app, Yast > SwManagement > versions shows 3.4.5.7-4.8.1-586 Vendor openSUSE.

    With a recent 12.1 Online Update on a newer box, I got the same result and posted that experinece to an existing thread in this forum titled Libre Office Problem post #9.

    This existing thread seemed to solve a similar problem, but that solution didn't work for me. One of the responders mentioned something like OBS as a solution, then went on to a zypper update. On my newer box his zypper solution didn't work either.

    I can roll the oo version back to 3.4 like I did with the other box but I would appreciate some help to make this version work. heboland
    I am showing that LibreOffice is up to 3.5 build 403 (which is 3.5.4 something in YaST) and so is that the version you have installed? I have read that with version 3.5.2 did have the same problem you describe and you had to remove the libreoffice-kde4 integration file to remove the problem for kde4 users in YaST. Are you using the KDE 4 Desktop by chance? You can check out your installed copy of LibreOffice with this terminal command:

    Code:
    rpm -V `rpm -qa | grep libreoffice`
    Having no output is good, and you can check any output for this text:

    If everything verified properly there will be no output. If there are any
    discrepancies they will be displayed. The format of the output is a string
    of 8 characters, a possible 'c' denoting a configuration file, and then
    the file name. Each of the 8 characters denotes the result of a comparison
    of one attribute of the file to the value of that attribute recorded in the
    RPM database. A single . (period) means the test passed. The following
    characters denote failure of certain tests:

    5 -- MD5 checksum
    S -- File size
    L -- Symbolic link
    T -- File modification time
    D -- Device
    U -- User
    G -- Group
    M -- Mode (includes permissions and file type)
    ? -- Unreadable file

    Applications that are not installed will produce no
    error message here, should the program be missing!
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    Thanks jdmcdaniel3!

    I didn't get much with the command you suggested for me to run. This is it's output:

    frank[2996] rpm -V `rpm -qa | grep libreoffice`
    5S.T..... c /usr/lib/libreoffice/share/config/javasettingsunopkginstall.xml
    frank[2997] uname -a
    Linux linux-88be.heboland 3.1.10-1.16-default #1 SMP Wed Jun 27 05:21:40 UTC 2012 (d016078) i686 i686 i386 GNU/Linux
    frank[2998]

    I also got my kernel version included this time. I'm actually running LXDE. For its version I got this:

    frank[2999] rpm -qa | grep -i LXDE
    lxde-common-0.5.5-31.1.1.noarch
    patterns-openSUSE-lxde-12.1-25.21.1.i586
    patterns-openSUSE-lxde_office-12.1-25.21.1.i586
    lxde-common-branding-openSUSE-12.1-22.1.1.noarch
    frank[3000] rpm -qa | grep -i libreoffice

    An excerpt from the last command is: libreoffice-writer-3.5.4.7-4.8.1.i586

    Is this the 3.5 build 403 version or can I get 3.5 build 403? That may be what the zypper command given in the other thread I mentioned did. That zypper installed version behaved similarly on my newer box.

    One thing that could be relevent here is the memory size on these old machines. This Pentium3 box has 512MB while the newer box is a Pentium 4 with 1.5GB. heboland

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    If you open up YaST and Software Management and search on libreofiice then look at the versions tab you can see if it is 3.5.4 that you have installed.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    Thanks jdmcdonald!

    I did have 3.5.4, but it's broke! I'm still having an internet BW problem and not sure why. It's not related to the libreoffice problem, but it's limiting my options.

    First I tried the zypper dup from the other thread I posted to, but it aborted because the download link broke on "hyphen". Next I tried to revert libreoffice to 3.4 with SwManager, but the download would race to 99% and then data rate would drop to 8 bits/sec and force a retry! In all afternoon I only got a single 2MB file!

    I want to use oowriter tonight, so I deleted 3.5.4 and reloaded libreoffice from my DVD. It's Vs 3.4.2 build 1206. It is from vendor openSuse and it works, so I have a solution.

    One thing I would still like to know is what would zypper commands look like to upgrade only to the latest 3.4 version?

    Since I deleted the broken version and reinstalled from the DVD, there's no history left in SwMagement. Assuming that I don't know the version of the latest 3.4 version, can I tell zypper to get that? heboland

  6. #6
    dd@home.dk NNTP User

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    On 08/20/2012 04:16 AM, heboland wrote:
    > I tried the zypper dup


    i can't directly answer the question you pose, but:

    it could be that that "zypper dup" is the source of your problem as it
    is a command associated with a *Distribution* UPpgrade (dup)..

    for example, moving from a beta openSUSE 12.2 Milestone 2 to Milestone
    3; or from openSUSE 12.1 to Tumbleweed; or from openSUSE 11.4 to 12.1
    (after doing all the necessary precautions and steps)..

    it was not designed for use when remaining in a particular version (say,
    like the openSUSE 12.1 you were in, and so remain)

    "zypper dup" with enabled repos containing potentially conflicting
    software is well known to cause a multitude of system problems ranging
    from irritations to total system failure.

    "zypper patch" allows the security patches and major bug fixes in the
    update repo to flow to your system....and, "zypper up" allows the
    updating from (say) LibreOffice 3.4.x to 3.5.x

    --
    dd

  7. #7

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    Thanks dd! For the record, I'll try to past the zypper sequence here suggested in the thread I mentioned previously to fix what seemed to me to be a similar problem. "Open a terminal and with your mouse paste this Code: su - zypper ar -f Index of /repositories/LibreOffice:/Stable/openSUSE_12.1 office enter your password when requested Code: zypper ref (a) to accept the key Code: zypper dup -r office Done " When the network traffic didn't stall out (like it is doing now) this installed a version of libreoffice above the one Yast > Sw > Online Update did, but that version also failed with the runtime error. I'll salt the new to me zypper commands. I may need them as the 12.1 drive on the P3 crashed and I had to reinstall on a different drive. Yast > Sw > Online Update keeps stalling on the downloads. I'm going to take that problem to the install forum. Thanks for listening, and the help I got here! Somehow I lost the white space again! heboland

  8. #8
    dd@home.dk NNTP User

    Default Re: 12.1 Online Update breaks Libre Office on x86 32bit Hw

    On 08/22/2012 07:06 PM, heboland wrote:
    > zypper dup -r office


    in that case the "-r office" specifies to upgrade from the 'office'
    repo, but i _guess_ "up -r office" would have also done what you wanted..

    read man "zypper" for all the details and check out the "cheat sheets"
    (though i don't know how current they are)

    https://www.google.com/search?q=site%3Aopensuse.org+"zypper+cheatsheet"

    --
    dd http://tinyurl.com/DD-Caveat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •