Results 1 to 5 of 5

Thread: How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routing tables?

  1. #1
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routing tables?

    I have been using wifi.google.com with success for both 11.4 AND 12.1. Google WiFi is a metro mesh network that has access points installed publicly. Around 15 Aug 2012 after an "icedtea-web" update my access to the network stopped working. I thought "icedtea-web" was the problem until I removed it.

    Now, I believe I may have been the victim of some kind of attack, but what would be capable of removing my configuration files and routing tables? Henk has been helping me at http://forums.opensuse.org/english/g...-update-2.html and he discovered that I am missing files for 11.4:

    Code:
    linux-ppnb:/home/randolph # netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
     
    linux-ppnb:/home/randolph # cat /etc/sysconfig/network/ifcfg-wlan0
    cat: /etc/sysconfig/network/ifcfg-wlan0: No such file or directory
    and 12.1:

    Code:
    linux-l0lg:~ # netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    
    linux-l0lg:~ # cat /etc/sysconfig/network/ifcfg-wlan0
    cat: /etc/sysconfig/network/ifcfg-wlan0: No such file or directory
    I have 11.4 and 12.1 on separate HDD (thinking that I would have a life raft in case one of them failed). At the moment, I am using Windows 7 to write this which is installed in tandem with 11.4.

    I would appreciate someone walking me through the process of putting back my configuration files and routing tables. The methods I have looked up for others were not successful. (example: Re: [opensuse] wlan will not initialize)

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routing tables?

    Code:
    # cat /etc/sysconfig/network/ifcfg-wlan0 cat: /etc/sysconfig/network/ifcfg-wlan0: No such file or directory
    That file may not exist if using the network manager. Or are did you configure using the 'Traditional ifup' with YaST. (An empty routing table is the result of no active network connections).

    In any case, you should just proceed to reconfigure. If you're using a laptop, and need to connect to a number of networks, then use the network manager approach.

  3. #3
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routing tables?

    I'm using knetworkmanager in 11.4 to connect to wifi access points. In 12.4, I'm using a network applet to connect to access points - I'm not sure what to call the applet, but I have the same setup in Yast to use Knetworkmanager and the widget hooks into access points just as well. I'm using a desktop PC.

    Where is the reference for reconfiguring? Thanks in advance!
    Last edited by HealingMindNOS; 18-Aug-2012 at 15:25. Reason: not widget, applet

  4. #4
    dd@home.dk NNTP User

    Default Re: How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routingtables?

    On 08/19/2012 12:26 AM, HealingMindNOS wrote:
    > Where is the reference for reconfiguring?


    if Network Connections is running you should find an icon for it in the
    'tray' (where, on my KDE i also have (for example) a volume icon,
    battery charge condition, clock and other stuff)...left click the
    network icon and select "Manage connections"..

    there is a help button in the lower left corner of that popup dialogue..

    if there is no Network Manager in the tray then press Alt and then F2,
    and start typing in "network manager" but before you finish it should
    pop up a list of applications relevant to networking, click to highlight
    Network Manager, and proceed as above (using help to configure your wi-fi)

    --
    dd http://tinyurl.com/DD-Caveat

  5. #5
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Exclamation Re: How to restore OSS 11.4 and 12.1 missing ifcfg-wlan0 and routing tables?

    in 11.4, I went into network settings, flicked off and on the ipv6 switch, hit OK, then Yast went to work. In root terminal, I input rcnetwork restart, then I restarted my PC.

    The usual handshaking took place between my PC and the network, then I was able to get back on the network through the login page!

    But there's still a problem: I had to go through the same procedure again when I turned on my computer this morning. Network Manager wouldn't even latch on to the access point.

    I'm guessing that something else needs to be done. I appreciate your pointing me in the right direction to sniff out the trouble. Thanks in advance. I will try this in 12.1 next.
    Last edited by HealingMindNOS; 19-Aug-2012 at 10:31. Reason: forgot info

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •