Dear all,

I am trying to install OpenNI lybraries but I've got the following error:

Installing OpenNI
****************************
copying shared libraries...OK
copying executables...OK
copying include files...OK
creating database directory...OK
registering module 'libnimMockNodes.so'.../usr/bin/niReg: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libOpenNI.so)



I've obtained some possible required data from the following commads:
# rpm -qa | grep glibc
glibc-devel-static-2.14.1-14.27.1.i686
glibc-devel-2.14.1-14.27.1.i686
linux-glibc-devel-3.1_rc5-7.1.1.noarch
glibc-2.14.1-14.12.2.i686
glibc-locale-2.14.1-14.12.5.i586

# more /etc/SuSE-release:
openSUSE 12.1 (i586)
VERSION = 12.1
CODENAME = Asparagus

I guess that I should upgrade glibc 2.14 to 2.15!
I will be so pleased to read some instructions to make that upgrade.

Thanks in advance,
zx.