Results 1 to 10 of 10

Thread: Restoring gnome default settings

  1. #1
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Restoring gnome default settings

    I'm running Gnome 3.2 on openSUSE 11.4. I had two gedit windows open, and tried to drag a tab from one into the other. Apparently this isn't supported, and everything stopped responding. Couldn't close gedit, couldn't switch windows or log off. I switched to text mode and killed gedit. I couldn't switch back to X, printing the message "returning to session" (or something like that) but no Gnome. I shut down, and now I can't log into Gnome. Each time I get a generic "Oops. there was an error" message and am forced to log out.

    Gnome still works for a test user, so it shouldn't be hard to fix this problem. I've tried removing some of the conf files, such as '~/.local/share/gnome-shell' and '~/.config/gnome-session', but I'm still locked out. Anybody know how to set Gnome back to the default settings?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Restoring gnome default settings

    On 18/08/12 03:36, chief sealth wrote:
    > Anybody know how to set Gnome back to the default
    > settings?

    Unlike kde, gnome has it's settings all over place.
    I don't know a magic fix
    I'd probably end up backing up my current user files that I need.
    Login to the test user, and delete my current user including it's /home
    Re-create my current user and copy my files back
    Long winded I know

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Restoring gnome default settings

    Quote Originally Posted by caf4926 View Post
    Unlike kde, gnome has it's settings all over place.
    I don't know a magic fix
    I'd probably end up backing up my current user files that I need.
    Login to the test user, and delete my current user including it's /home
    Re-create my current user and copy my files back
    Long winded I know
    Ouch!! I hope it doesn't come to that. Maybe someone knows another way?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Restoring gnome default settings

    On 18/08/12 04:26, chief sealth wrote:
    > Maybe someone knows another way?

    I hope so

  5. #5

    Default Re: Restoring gnome default settings

    Quote Originally Posted by chief_sealth View Post
    Ouch!! I hope it doesn't come to that. Maybe someone knows another way?
    Log out, delete (or rename) ~/.config/dconf/user, log in again.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Restoring gnome default settings

    On 2012-08-18 04:43, caf4926 wrote:
    > On 18/08/12 03:36, chief sealth wrote:
    >> Anybody know how to set Gnome back to the default
    >> settings?

    > Unlike kde, gnome has it's settings all over place.
    > I don't know a magic fix
    > I'd probably end up backing up my current user files that I need.
    > Login to the test user, and delete my current user including it's /home
    > Re-create my current user and copy my files back
    > Long winded I know


    It is enough to delete all gnome related directories: ".gnome*", then perhaps .gtk and I don't
    know what more. .gconf, .config... dunno.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Restoring gnome default settings

    Quote Originally Posted by please_try_again View Post
    Log out, delete (or rename) ~/.config/dconf/user, log in again.
    Thanks, but I'm afraid that doesn't do it. It's time to upgrade pretty soon, I guess I can go with KDE for a few weeks. That's assuming 12.2 is released on the schedule this time.

  8. #8

    Default Re: Restoring gnome default settings

    Quote Originally Posted by chief_sealth View Post
    Thanks, but I'm afraid that doesn't do it.
    Hmm.. This is where gnome-shell saves all the settings. Deleting this file would indeed restore the defaults. I'm afraid you have a weird problem, and btw dragging tabs in gedit to change their order works - if that's what you meant.

    You could try to log in in fallback-mode, using the command:

    Code:
    $ gnome-session --session=gnome-fallback
    If you don't know how, copy/paste the code below, save it in the file /usr/share/xsessions/gnome-fallback.desktop and select "GNOME Classic" in gdm login screen:

    Code:
    [Desktop Entry]
    Name=GNOME Classic (No effects)
    Comment=This session logs you into GNOME with the traditional panel without any graphical effect.
    Exec=gnome-session --session=gnome-fallback
    TryExec=gnome-session
    Icon=
    Type=Application
    Then open a terminal, run this command:

    Code:
    $ gnome-session-properties
    and uncheck "Automatically remember running applications when logging out".

    I would also try to start gnome-shell directly instead of using openSUSE wrapper script (= the command "gnome"). That would be:

    Code:
    gnome-session session=gnome
    and look in ~/.local/share/gnome-shell/application_state if you see something about 'gedit'. gedit is a dconf application. It shouldn't write in ~/.gconf (unlike the former version used gnome2). You can try that:

    Code:
    $ dconf reset -f /org/gnome/gedit/state/window/

  9. #9
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Restoring gnome default settings

    Quote Originally Posted by please_try_again View Post
    Code:
    $ gnome-session --session=gnome-fallback
    If you don't know how, copy/paste the code below, save it in the file /usr/share/xsessions/gnome-fallback.desktop and select "GNOME Classic" in gdm login screen:

    Code:
    [Desktop Entry]
    Name=GNOME Classic (No effects)
    Comment=This session logs you into GNOME with the traditional panel without any graphical effect.
    Exec=gnome-session --session=gnome-fallback
    TryExec=gnome-session
    Icon=
    Type=Application
    I can't even get into fallback mode at this point. Same generic error message forcing me to log out.

    and look in ~/.local/share/gnome-shell/application_state if you see something about 'gedit'. gedit is a dconf application. It shouldn't write in ~/.gconf (unlike the former version used gnome2). You can try that:
    I'VE already deleted the '~/.local/gnome-shell' directory, and there's no application_state file there right now.

  10. #10

    Default Re: Restoring gnome default settings

    And you said you can log in as another user? That's weird. Try to clear your /tmp directory. Also clear ~/.bus/session-bus of the user who can not login - although a new dbus session should be opened every time. Check the access rights of your /tmp. It should be 1777.

    Code:
    $ stat -c "%a" /tmp
    1777
    Are you able to log in in another desktop then Gnome? Try IceWM which should be installed by default. You can also run dconf from there (see my previous post).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •