Sorry if this thread is in the wrong place.


Hi, I'm new to the forums and I have been using openSuSE for a while now. I'm doing some cross platform development, specifically Windows and Linux, and I don't know why I don't have "libgcc_s_dw2-1.dll" in my MinGW bin folder. I need libgcc_s_dw2-1.dll so I can use the
Code:
-static-libgcc
compiler option instead of having to copy over a dll. ( I could use the dll instead, but I don't even have it to begin with! )


This is what I have installed for mingw32:


reportados@ReportadosComp:~> rpm -qa '*mingw*'
mingw32-zlib-1.2.7-1.7.noarch
mingw32-filesystem-52-55.1.noarch
mingw32-pthreads-2.8.0-14.17.noarch
mingw32-libintl-0.18.1.1-13.23.noarch
mingw32-libstdc++-4.7.0-3.15.noarch
mingw32-libintl-devel-0.18.1.1-13.23.noarch
mingw32-headers-20120404-1.1.noarch
mingw32-cross-gcc-4.7.0-8.7.x86_64
mingw32-w32pth-2.0.4-2.18.noarch
mingw32-termcap-1.3.1-3.17.noarch
mingw32-libgnutls-extra-2.12.18-1.19.noarch
mingw32-runtime-20120404-1.9.noarch
mingw32-libmpfr-3.1.0-1.20.noarch
mingw32-cpp-4.7.0-3.15.noarch
mingw32-cross-binutils-2.22.52-2.1.x86_64
mingw32-gcc-4.7.0-3.15.noarch
mingw32-gmp-devel-5.0.5-1.4.noarch
mingw32-w32pth-devel-2.0.4-2.18.noarch
mingw32-libidn-lang-1.22-1.20.noarch
mingw32-readline-6.2-1.17.noarch
mingw32-libgpg-error-lang-1.10-1.23.noarch
mingw32-gnutls-2.12.18-1.19.noarch
mingw32-glib2-lang-2.32.4-1.1.noarch
mingw32-binutils-2.22.52-1.12.noarch
mingw32-libmpc-1.0-1.1.noarch
mingw32-cross-cpp-4.7.0-8.7.x86_64
mingw32-gcc-c++-4.7.0-3.15.noarch
mingw32-cross-pkg-config-0.27-2.1.x86_64
mingw32-mpc-devel-1.0-1.1.noarch
mingw32-libidn-1.22-1.20.noarch
mingw32-libgpg-error-1.10-1.23.noarch
mingw32-libgcrypt-1.4.6-4.14.noarch
mingw32-gnutls-lang-2.12.18-1.19.noarch
mingw32-glib2-2.32.4-1.1.noarch
mingw32-cross-gcc-c++-4.7.0-8.7.x86_64
mingw32-mpfr-devel-3.1.0-1.20.noarch
mingw32-readline-devel-6.2-1.17.noarch
mingw32-libgnutls-2.12.18-1.19.noarch
mingw32-glib2-devel-2.32.4-1.1.noarch
mingw32-libgmp-5.0.5-1.4.noarch
mingw32-libgcc-4.7.0-3.15.noarch
mingw32-pthreads-devel-2.8.0-14.17.noarch
mingw32-libidn-devel-1.22-1.20.noarch
mingw32-libtasn1-2.12-1.13.noarch
mingw32-libffi-3.0.10-2.25.noarch

I'm sure that I'm missing some important dependencies because libgcc_s_dw2-1.dll isn't there. What dependencies am I missing?


Thanks for the help.