Results 1 to 9 of 9

Thread: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

  1. #1

    Default How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Dear all,

    I am trying to install OpenNI lybraries but I've got the following error:

    Installing OpenNI
    ****************************
    copying shared libraries...OK
    copying executables...OK
    copying include files...OK
    creating database directory...OK
    registering module 'libnimMockNodes.so'.../usr/bin/niReg: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libOpenNI.so)



    I've obtained some possible required data from the following commads:
    # rpm -qa | grep glibc
    glibc-devel-static-2.14.1-14.27.1.i686
    glibc-devel-2.14.1-14.27.1.i686
    linux-glibc-devel-3.1_rc5-7.1.1.noarch
    glibc-2.14.1-14.12.2.i686
    glibc-locale-2.14.1-14.12.5.i586

    # more /etc/SuSE-release:
    openSUSE 12.1 (i586)
    VERSION = 12.1
    CODENAME = Asparagus

    I guess that I should upgrade glibc 2.14 to 2.15!
    I will be so pleased to read some instructions to make that upgrade.

    Thanks in advance,
    zx.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    26,555

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    PLease, put your several comuter text parts between CODE tags: http://forums.opensuse.org/english/i...ags-guide.html

    We can now not see what is your story and what are the facts from the computer.

    Also you say "I am trying to install", but you do not explain how you are trying that. There are many ways of "installing" (it is a generic word in English), varying from using Yast/zypper (which repo?) via rpm and builfing/installing to direct copying of files.
    Henk van Velden

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    On 2012-08-18 06:46, Zxoch wrote:
    > I guess that I should upgrade glibc 2.14 to 2.15!
    > I will be so pleased to read some instructions to make that upgrade.


    Don't.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Quote Originally Posted by robin_listas View Post
    On 2012-08-18 06:46, Zxoch wrote:
    > I guess that I should upgrade glibc 2.14 to 2.15!
    > I will be so pleased to read some instructions to make that upgrade.


    Don't.
    +1
    You're most likely going to screw up your system ... and your next post will be: How do I restore the previous version of glibc?

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    On 2012-08-18 14:16, please try again wrote:
    >
    > robin_listas;2480656 Wrote:
    >> On 2012-08-18 06:46, Zxoch wrote:
    >>> I guess that I should upgrade glibc 2.14 to 2.15!
    >>> I will be so pleased to read some instructions to make that upgrade.

    >>
    >> Don't.

    >
    > +1
    > You're most likely going to screw up your system ... and your next post
    > will be: How do I restore the previous version of glibc?


    Rather why does not my system work, what do I do. >:-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Am 18.08.2012 14:16, schrieb please try again:
    > +1
    > You're most likely going to screw up your system ... and your next post
    > will be: How do I restore the previous version of glibc?
    >

    Another +1
    and tell us the exact link where you have the software from, since that
    looks like a binary installer and I see only one for ubuntu.
    If you compile from source you should never get a dependency on a
    library version you don't have.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  7. #7

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Thanks for your kind replies, I have read that I must not do it, and I think I am going to follow your advice.
    Maybe, I have to try with an Ubuntu distribution.

    Let me just share the following information that is asked in the last replied threat.
    I am trying to Install OpenNI from a compressed file which is available at: simple-openni - A simple OpenNI wrapper for processing. - Google Project Hosting.
    The file is: OpenNI_NITE_Installer-Linux32-0.27.zip - simple-openni - Installer OpenNI/NITE Linux32 0.27 - A simple OpenNI wrapper for processing. - Google Project Hosting

    Thanks again! That is why I love opensource software community, because there is always someone who could help you.
    Sorry for my vague idea of install.





    Quote Originally Posted by martin_helm View Post
    Am 18.08.2012 14:16, schrieb please try again:
    > +1
    > You're most likely going to screw up your system ... and your next post
    > will be: How do I restore the previous version of glibc?
    >

    Another +1
    and tell us the exact link where you have the software from, since that
    looks like a binary installer and I see only one for ubuntu.
    If you compile from source you should never get a dependency on a
    library version you don't have.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Am 19.08.2012 03:06, schrieb Zxoch:
    > I am trying to Install OpenNI from a compressed file which is available
    > at: 'simple-openni - A simple OpenNI wrapper for processing. - Google
    > Project Hosting' (http://code.google.com/p/simple-openni/).
    > The file is: 'OpenNI_NITE_Installer-Linux32-0.27.zip - simple-openni -
    > Installer OpenNI/NITE Linux32 0.27 - A simple OpenNI wrapper for
    > processing. - Google Project Hosting' (http://tinyurl.com/8ums97y)


    That is a different software than what I found when googling for so
    forget my comment about the ubuntu package.
    You could try to simply compile it yourself from source, then it will
    most likely work with your system
    http://code.google.com/p/simple-open...ild#UNIX/Linux

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to upgrade glibc 2.14 to 2.15 on openSUSE 12.1 (i586)?

    Just to add, if you have access to Ubuntu it needs to be 12.04 to have
    glibc 2.15 or you can try on openSUSE 12.2 in a few weeks.
    If you are adventurous try the current 12.2 release candidate it has
    glibc 2.15.

    --
    PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •