Results 1 to 3 of 3

Thread: Atheros AR9485 freezes whole system

  1. #1

    Default Atheros AR9485 freezes whole system

    On Acer Aspire 7250, AMD Dual-Core E450, "AMD" Radeon HD 6320, Acer Nplify 802.11b/g/n
    OpenSuse 12.1 64 bit


    product: AR9485 Wireless Network Adapter
    logical name: wlan0
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
    configuration: broadcast=yes driver=ath9k driverversion=3.1.9-1.4-desktop firmware=N/A latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
    resources: irq:17 memory:f0200000-f027ffff memory:f0500000-f050ffff


    The wireless driver comes from OSS repo. At first glance works perfectly showing all available connections.
    By giving in the security key, the wireless connection starts and freezes the installation at 100%.
    However, eth0 works well.

    Has somebody any idea how to fix that? Of course I could plug in a second wireless, but the solution is not very elegant and I am not the laptop owner. I care about the image of our distribution

    Thanks in advance
    Laptop: MSI 60 2PC | OpenSUSE 13.1 (x86_64) | KDE Current| Compiz 8.8 | Intel(R) Core(TM) i7-4700HQ CPU 3.2GHz | GTX850M | 8GB RAM

  2. #2
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    242

    Default Re: Atheros AR9485 freezes whole system

    No, I have no idea to "fix that".
    I had/have the same problem with the Acer 7250. The problem also appears with the Gparted live-cd. My conclusion is that is not a openSUSE-12.1 problem. My solution was to install a D-link DWA-140 adapter, which works perfectly on another 12.1 system.
    However, once I had given it the WPA2 password, I had to blacklist the Atheros drivers to prevent them from being first to connect to the AP and then to freeze the system.
    Modules blacklisted: ath, ath9k, ath9k_common and ath9k-hw.
    Should you find a 'real' solution, please mention it in this thread. Thank you.

    Hans.
    Hans Schreuder

  3. #3
    Join Date
    Jun 2008
    Location
    Mexico
    Posts
    205

    Default Re: Atheros AR9485 freezes whole system

    Hi.

    Maybe too late but at least a solution.

    Today I had the same problem with a Acer Aspire 5250-0619 (64bits) laptop and using 12.1 GNOME.

    Thanks to https://bugs.launchpad.net/ubuntu/+s...ux/+bug/989566 I could fix it, except that instead of issueing the command I re-booted the laptop and that was it.

    It works like a charm.

    Luis.
    La Humildad no es "Status"..
    ... es un �"Don"!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •