Results 1 to 8 of 8

Thread: Problems installing FreeNX on OpenSUSE 12.1

  1. #1

    Default Problems installing FreeNX on OpenSUSE 12.1

    Hi,
    I have been trying to install FreeNX since the last 2 days and it just doesnt work.
    I installed the 'please-try-again' package of FreeNX from FreeNX - openSUSE for OpenSUSE 12.1
    Things didn't work out mentioned in all pages that I read. e.g SDB:FreeNX server - openSUSE .
    There were a lot of issues and I resolved them 1 by 1, and here is how.
    I removed everything in /tmp/.X11-unix directory.
    I installed 'terminal font' package.

    Here are some of the things that I believe might be a way to find the problem.
    when I run 'nxagent' , it shows up the NX splash screen and a back window, and the following
    Code:
    NXAGENT - Version 3.5.0
    
    Copyright (C) 2001, 2011 NoMachine.
    See http://www.nomachine.com/ for more information.
    
    
    Info: Agent running with pid '48960'.
    Session: Starting session at 'Fri Aug 10 13:52:15 2012'.
    Info: Using alpha channel in render extension.
    Info: Not using local device configuration changes.
    error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
    Session: Session started at 'Fri Aug 10 13:52:16 2012'.
    When I try to log in using the NX Client, it shows the NX red splash for a few milliseconds and then closes.
    Following is the 'Detail'
    Info: Display running with pid '38256' and handler '0x4f07ea'.

    NXPROXY - Version 3.4.0


    Copyright (C) 2001, 2010 NoMachine.
    See NoMachine NX - Desktop Virtualization and Remote Access Management Software for more information.


    Info: Proxy running in client mode with pid '38820'.
    Session: Starting session at 'Fri Aug 10 13:53:57 2012'.
    Warning: Connected to remote version 3.5.0 with local version 3.4.0.
    Warning: Consider checking NoMachine NX - Desktop Virtualization and Remote Access Management Software for updates.
    Info: Connection with remote proxy completed.
    Warning: Unrecognized session type 'unix-desktop'. Assuming agent session.
    Info: Using LAN link parameters 1536/24/1/0.
    Info: Using pack method 'adaptive-9' with session 'unix-desktop'.
    Info: Not using NX delta compression.
    Info: Not using ZLIB data compression.
    Info: Not using ZLIB stream compression.
    Info: Not using a persistent cache.
    Info: Forwarding X11 connections to display ':0'.
    Info: Listening to font server connections on port '11100'.
    Session: Session started at 'Fri Aug 10 13:53:58 2012'.
    Info: Established X server connection.
    Info: Using shared memory parameters 0/0K.
    Session: Terminating session at 'Fri Aug 10 13:53:58 2012'.
    Session: Session terminated at 'Fri Aug 10 13:53:58 2012'.
    Then I looked into ~/.nx/ for the logs. The following is the 'session' log.
    NXAGENT - Version 3.5.0

    Copyright (C) 2001, 2011 NoMachine.
    See NoMachine NX - Desktop Virtualization and Remote Access Management Software for more information.


    Info: Agent running with pid '47479'.
    Session: Starting session at 'Fri Aug 10 12:59:22 2012'.
    Info: Proxy running in server mode with pid '47479'.
    Info: Waiting for connection from '127.0.0.1' on port '5100'.
    Info: Accepted connection from '127.0.0.1'.
    Warning: Connected to remote version 3.4.0 with local version 3.5.0.
    Info: Connection with remote proxy completed.
    Info: Using LAN link parameters 1536/24/1/0.
    Info: Using agent parameters 5000/0/50/0/0.
    Info: Using pack method 'adaptive-9' with session 'unix-desktop'.
    Info: Using product 'LFE/None/LFEN/None'.
    Info: Not using NX delta compression.
    Info: Not using ZLIB data compression.
    Info: Not using ZLIB stream compression.
    Info: Not using a persistent cache.
    Info: Listening to X11 connections on display ':1100'.
    Info: Established X client connection.
    Info: Using shared memory parameters 1/1/0/0K.
    Info: Using alpha channel in render extension.
    Info: Using local device configuration changes.
    Error: Aborting session with 'Could not open default font 'fixed''.
    Session: Aborting session at 'Fri Aug 10 12:59:23 2012'.
    Session: Session aborted at 'Fri Aug 10 12:59:23 2012'.
    Warning: Signals were not blocked in process with pid '47479'.
    Info: Watchdog running with pid '47494'.
    Info: Waiting the watchdog process to complete.
    FYI: I have installed all xorg-x11 fonts. including the terminal fonts package.

    Then I followed the steps in : [SOLVED] FreeNX on Fedora 14. How to fix [ Could not open default font 'fixed' ] problem. - FedoraForum.org
    I looked at the logs, and following is what I found relevant. Not sure if it is actually of any help.

    47731 open("/usr/lib/NX/lib/libm.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("/usr/lib/NX/lib/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("/usr/lib/NX/lib/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("/lib64/libc.so.6", O_RDONLY) = 3
    47731 open("/usr/lib/NX/lib/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("tls/x86_64/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("tls/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("x86_64/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    47731 open("/usr/lib/NX/lib/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
    There are many such lines where it is looking for libraries in /usr/lib/NX/lib and it is not able to find those.
    Well, they don't exist. But there are some libraries present there, which the NX install script installed, and I don't see why, I would need anything more than that.

    Moral of the story is , I am not able to access my OpenSUSE server using my NX Client, and I cannot determine the problem.
    All help is appreciated.
    Thanks a lot.

  2. #2

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Hi,
    Here's a solution that works: Setting up NX server (part I: FreeNX)

    Basically, all you need to do is:

    • install my repo:
      Code:
      # zypper ar http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_12.1/  PTA
    • refresh my repo
      Code:
      # zypper  refresh -r PTA
    • install FreeNX (it's a different build)
      Code:
      # zypper in FreeNX
    • and run this script:
      Code:
      # freenx-setup


    If you want to use NoMachine generic key pair, use this instead:
    Code:
    # freenx-setup -n
    If you want to re-use your keys, copy all files present in /var/lib/nxserver/home/.ssh somewhere else and copy them back after you're done with FreeNX setup. These files must be owned by the nx user. But make sure the keys are not in /etc/nxserver - I don't know this version. My version is based on Fedora including some other bugfixes.

    You can see the different options with:
    Code:
    # freenx-setup -h

    If it doesn't work - but it should - I have a new version of freenx-setup I haven't uploaded yet. This new version works on openSUSE, Fedora, Ubuntu, Mandriva and ArchLinux.

    You might be interested in the second article: Setting up NX server (part II: NoMachine NX)


    * Of course you should first uninstall the FreeNX and NX version you have installed (or were trying to install) and make sure you install FreeNX and NX from my repo!
    ** Don't apply any patch you might find on other pages. They are probably obsolete or not needed.

  3. #3

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Hey thanks for the reply.
    I am still unable to run it. Can you tell me where all the 'remains' of my old NX would possibly be. May be I am unable to remove that and hence it's just using the old stuffs/libraries/configs. I did nxsetup --uninstall --purge. Then I did zypper rm FreeNX. Removed contents of /etc/nxserver.
    I am giving it all another shot. Now I will try installing using the rpm instead of repo.

  4. #4

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Well. Just found out. There is no rpm for FreeNX server. Only for client. Never mind. I will try to go more deep into the errors.

  5. #5

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Quote Originally Posted by guptesanket View Post
    Well. Just found out. There is no rpm for FreeNX server. Only for client. Never mind. I will try to go more deep into the errors.
    Of course there is one - in my repo. I just found a bug while looking for another one. See this post: Latest 'zypper update' broke NX . If you install FreeNX as described in post #2, then comment out the offending AGENT_EXTRA_OPTIONS_X line in /etc/nxserver/node.conf, it will work. I justed tested it on a fresh install in a virtual machine.

    I'll fix the package ASAP.

  6. #6

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Quote Originally Posted by guptesanket View Post
    Can you tell me where all the 'remains' of my old NX would possibly be.
    There are files and keys left in /var/lib/nxserver and /etc/nxserver. Remove these directories as well as the nx user and group before reinstalling FreeNX.

    Code:
    # su -l
    # zypper rm <name of the freenx package>*
    # rm -r /var/lib/nxserver /etc/nxserver
    # zypper refresh -r PTA
    # zypper in FreeNX
    # freenx-setup (with the options you need)

    * FreeNX is the name of my package - based on Fedora with a couple more bugs fixed*. You can not delete it without having installed it before. I started building it a while ago, as the one in the official repo didn't work - didn't even install actually. If it's working now, it's fine with me. The other package might have another name (I've seen freenx-server and freenx in other builds).


    * and a couple new bugs, as you just noticed... But I will fix that. In the meantine, commenting out the AGENT_EXTRA_OPTIONS_X line should do the trick.

  7. #7

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Haha.. Funny .. I was just gonna comment out AGENT_EXTRA_OPTIONS_X, but thought, wait let me check whether you have responded yet. And there it was.
    Thanks a lot. That worked.

  8. #8

    Default Re: Problems installing FreeNX on OpenSUSE 12.1

    Package is fixed now.

    To anyone intending to install FreeNX from this repo: make sure you refresh the repo first!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •