Results 1 to 9 of 9

Thread: netpbm-devel?

  1. #1
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,170

    Default netpbm-devel?

    Does anyone know which repo might have this? packman and the stock suse repos don't have the -devel (so I can get ppm.h and libppm.a) option. If I try to get it from pbone, I'm afraid of breaking something in the stock opensuse 12.1 x64 netpbm install (or dependencies) - it seems integrated into the overall system. THANKS!!

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: netpbm-devel?

    libnetpbm-devel is in the standard repos, since I do not have it
    installed I cannot tell you what it contains.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,727

    Default Re: netpbm-devel?

    Like Martin, I have it in the OSS repo. But I am using 11.4 and you keep us uninformed about what you have
    Henk van Velden

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: netpbm-devel?

    Am 04.08.2012 18:49, schrieb Martin Helm:
    > libnetpbm-devel is in the standard repos, since I do not have it
    > installed I cannot tell you what it contains.
    >

    For fun I looked into it (just to explicitly mention for 12.1 as my
    footer indicates) and it contains ppm.h and libppm.so (not the static .a
    one), why do you need the static library and also the question which
    openSUSE are you using?
    It is more than strange if you do not have that package in your repo
    since Henk has it for 11.4 and I have it in 12.1 which are the only
    supported versions (except the more exotic Tumbleweed and Evergreen)!?

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  5. #5
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,170

    Default Re: netpbm-devel?

    You're absolutely right, Martin - it's right there. But I didn't think to search for libnetpbm-devel - I only searched for netpbm-devel - and when I searched for ppm.h (while "file list" was checked) I'm sure it didn't turn up anything. But now that I installed libnetpbm-devel, the search works. I wonder if there was a repo problem earlier today?
    Thank You!!!

    BTW: openSuSE 12.1 x64 with only the standard repos and all of Packman.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,178
    Blog Entries
    3

    Default Re: netpbm-devel?

    Quote Originally Posted by PattiMichelle View Post
    But I didn't think to search for libnetpbm-devel - I only searched for netpbm-devel
    I am wondering how you searched.

    Just for kicks, I typed "netpbm-devel" in the search box of Yast Sofware management. And it found "libnetpbm-devel"

    I don't think searching for file names works unless the package is already installed.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: netpbm-devel?

    Am 05.08.2012 08:06, schrieb nrickert:
    > I don't think searching for file names works unless the package is
    > already installed.
    >

    That's correct, our package system does not have the metadata which file
    is in which rpm unless it is installed, sometimes an unpleasant feature.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

  8. #8

    Default Re: netpbm-devel?

    On 08/05/12 06:34, Martin Helm pecked at the keyboard and wrote:
    > Am 05.08.2012 08:06, schrieb nrickert:
    >> I don't think searching for file names works unless the package is
    >> already installed.
    >>

    > That's correct, our package system does not have the metadata which file
    > is in which rpm unless it is installed, sometimes an unpleasant feature.
    >


    Keep in mind that you only need supply enough of the name to search. You
    could have used just netpbm and still found the package you were looking
    for.


  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: netpbm-devel?

    Am 05.08.2012 17:37, schrieb Ken Schneider:
    >> That's correct, our package system does not have the metadata which file
    >> is in which rpm unless it is installed, sometimes an unpleasant feature.
    >>

    >
    > Keep in mind that you only need supply enough of the name to search. You
    > could have used just netpbm and still found the package you were looking
    > for.
    >

    If you know the package. That was a comment on a completely different
    question: You know a file you need and have no clue which package it is
    in, not really the situation of this thread.
    If if you read the previous posts you see that the original problem has
    long been solved.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •