Results 1 to 6 of 6

Thread: "Dependency resolution failed" on Apper updates

  1. #1

    Default "Dependency resolution failed" on Apper updates

    Hello,

    On 12.1 and the Tumbleweed repository, I cannot run my updates anymore as I keep getting this error:

    Code:
     patch:openSUSE-2012-467-1.noarch conflicts with  libreoffice-l10n-de.noarch < 3.5.4.7-4.8.1 provided by  libreoffice-l10n-de-3.5.4.7-3.1.noarch
    I am not sure how to resolve this conflict without removing OpenOffice. Do you have any suggestions ?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,148

    Default Re: "Dependency resolution failed" on Apper updates

    Do not use Apper. Disable it, or even uninstall it (using YaST of course).

    The prefered system mangements tool on openSUSE is YaST. For many it is an important reason for choosing openSUSE.
    Henk van Velden

  3. #3

    Default Re: "Dependency resolution failed" on Apper updates

    Alright, I uninstalled Apper and I used the Online Update from YaST. At least I had the usual conflict resolution options that allowed me to successfully run my updates.

    Since Apper is to avoid, may be they should simply remove it from the openSUSE distribution...

    Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,148

    Default Re: "Dependency resolution failed" on Apper updates

    Quote Originally Posted by JeromeQc View Post
    Since Apper is to avoid, may be they should simply remove it from the openSUSE distribution...
    You are not alone in thinking this
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: "Dependency resolution failed" on Apper updates

    On 2012-08-04 16:36, JeromeQc wrote:
    >
    > Alright, I uninstalled Apper and I used the Online Update from YaST. At
    > least I had the usual conflict resolution options that allowed me to
    > successfully run my updates.


    Please remember that Tumbleweed is not compatible with "updates" from the update repo.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: "Dependency resolution failed" on Apper updates

    On 2012-08-04 16:46, hcvv wrote:
    >
    > JeromeQc;2478295 Wrote:
    >>
    >> Since Apper is to avoid, may be they should simply remove it from the
    >> openSUSE distribution...
    >>

    > You are not alone in thinking this


    Many of the faults of apper are due to the interface libraries to zypper libs, which are the
    responsibility of the zypper devs. Thus, that those libraries are broken could be interpreted
    as a boicot...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •