Results 1 to 8 of 8

Thread: Configure Desktop KDE Crash Handler error

  1. #1

    Default Configure Desktop KDE Crash Handler error

    Everytime I want to open Configure Dekstop -> Input Devices -> Touchpad KDE Crash Handler error is shown. I'm trying to configure tapping on the touchpad (I know what file to edit). I will appreciate every help to remove that annoying error.. Running openSuSE 12.1 i586, KDE 4.8.4
    Code:
    Executable: systemsettings PID: 3264 Signal: Aborted (6)
    Thank you

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Configure Desktop KDE Crash Handler error

    Sounds like a hardware issue or software driver to me. Did this ever work and when did it stop working then? Was this an issue with KDE 4.7 for instance? Have you ever considered moving to a newer kernel version over 3.1, the default for openSUSE 12.1? For open source drivers, they all exist in the kernel and thus a newer kernel, newer drivers. Not all kernel drivers are newer just because a kernel is newer however, but it is possible a newer kernel can help.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Configure Desktop KDE Crash Handler error

    It all worked fine with kernel 3.1.. then I updated to 3.4.7 using SAKC. After upgrade I was keep on making a mistake by deleting too many files so SuSE booted into the console mode only. Then I reinstalled system, figured out what files to keep, updated Kernel again and since then cannot access Touchpad option.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Configure Desktop KDE Crash Handler error

    Quote Originally Posted by ad4ms3 View Post
    It all worked fine with kernel 3.1.. then I updated to 3.4.7 using SAKC. After upgrade I was keep on making a mistake by deleting too many files so SuSE booted into the console mode only. Then I reinstalled system, figured out what files to keep, updated Kernel again and since then cannot access Touchpad option.
    So, if you updated the version kernel with SAKC, don't you still have the old kernel 3.1.10 there to try again to see if the touchpad starts working? What I need to know is the hardware type and number and if it works OK with kernel 3.1. Then perhaps we could trace down the source of this problem due to the newer kernel. Just recently we heard that kernel 3.5 changes the HID driver for USB keyboards and that you need to put the new driver into the Initrd. I will try to help you determine what the problem is with kernel 3.4 if I can.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: Configure Desktop KDE Crash Handler error

    Laptop model is HP G60 119EM. I haven't got the old kernel as I deleted all files. If updating Initrd will be necessary how to do it? I'm not much experienced with Linux. Thank you

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Exclamation Re: Configure Desktop KDE Crash Handler error

    Quote Originally Posted by ad4ms3 View Post
    Laptop model is HP G60 119EM. I haven't got the old kernel as I deleted all files. If updating Initrd will be necessary how to do it? I'm not much experienced with Linux. Thank you
    To rebuild Initrd your would open up a terminal session and run this command:

    Code:
    sudo /sbin/mkinitrd
    I can tell you that it is NOT recommended that you remove your very last kernel from YaST. I am not sure such a setup is ever supported. My suggestion is to add back in the default or desktop kernels types for openSUSE 12.1 and kernel 3.1.10 along with the suggested kernel source code.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Configure Desktop KDE Crash Handler error

    Initrd repairing didn't help.. Should I reinstall kernel 3.1.10?

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Configure Desktop KDE Crash Handler error

    Initrd repairing didn't help.. Should I reinstall kernel 3.1.10?
    NO matter what else we would do, you should reinstall and test kernel 3.1.10.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •