Results 1 to 9 of 9

Thread: HDMI Audio Output to secondary devices

  1. #1
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default HDMI Audio Output to secondary devices

    I bought a new ASUS UX32VD-DB71. It has an Ivy Bridge CPU. It also has a dedicated nVidia 620M GPU in optimus configuration.

    I've installed openSUSE 12.2 RC1 on it. (I understand it is RC1, but ivy bridge support seems to be better only with the newer kernels and xorg versions especially for graphics and touchpad.)

    I'm running gnome shell. I'm able to attach 2 secondary displays - one over VGA and other over HDMI - switch between clone and extended display modes without any issues.

    Then I tested audio output over HDMI - and this is where I seem to have hit the wall. I get audio only over either my laptop speakers or the headphone jack. I see only these connectors listed in gnome sound settings.

    I have had experience with HDMI audio using pulseaudio and pavucontrol on my workstation - where I got it working easily since the HDMI audio device was being enumerated separately as 'nVidia Digital Output'. But on this laptop - I see only one audio device listed "Internal Audio Analog Stereo"

    Here are some useful info I gathered - let me know if I can provide more.
    Code:
    ash@StarScream:~> cat /proc/asound/cards
      0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xf7918000 irq 48
    
    ash@StarScream:~>aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    Does anyone have any idea/experience with such a scenario and help me out ? I'm perfectly fine with editing config files, building new drivers from source if required and am willing to experiment

    PS: i915 is the main display driver handling my graphics. nouveau driver also seems to be insmodded (since it detected the nvidia card too).
    Haswell i7 4700 | 16GB DDR2400 | ASUS Z87-Pro | 3TB + 3x4TB mdadm5 + 3x1.5TB mdadm5
    Tumbleweed x86_64
    13.1 x86_64

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,499

    Default Re: HDMI Audio Output to secondary devices

    As 12.2 (whatever pre-release version you have) is still not out, this should have gone to the Pre-release/Beta forum.

    I will move it there. Please do not post here until moved.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,499

    Default Re: HDMI Audio Output to secondary devices

    Quote Originally Posted by hcvv View Post
    As 12.2 (whatever pre-release version you have) is still not out, this should have gone to the Pre-release/Beta forum.

    I will move it there. Please do not post here until moved.
    Moved and open again.
    Henk van Velden

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,000
    Blog Entries
    40

    Default Re: HDMI Audio Output to secondary devices

    Note the nouveau driver in the most part does not fully support HDMI audio yet. Hence if you are using a laptop with hybrid (?) graphics, then you may need to either (1) get the proprietary driver working with your nvidia graphics, or switch to using the intel graphic hardware in your laptop.

    Apologies if I misunderstood your laptop's graphic device situation.

  5. #5
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: HDMI Audio Output to secondary devices

    @oldcpu - You're right my laptop does have hybrid graphics. My BIOS/UEFI does not have an explicit switch to control which graphics is used - so I'm stuck with the hybrid graphics in the hardware like many other folks

    From the behavior I see - HDMI video is accessible using the i915 driver, but HDMI audio seems to be controlled by the nvidia driver.

    I can try to install the proprietary nVidia driver but I would have to end up disabling KMS and IIRC i915 requires KMS to function efficiently. I'm willing to do this if someone can confirm that the nvidia proprietary driver is mandatory for the detection of HDMI Digital audio output devices.

    Also , does anyone know if the bumblebee/ironhide projects will help in this regard ?
    Haswell i7 4700 | 16GB DDR2400 | ASUS Z87-Pro | 3TB + 3x4TB mdadm5 + 3x1.5TB mdadm5
    Tumbleweed x86_64
    13.1 x86_64

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,000
    Blog Entries
    40

    Default Re: HDMI Audio Output to secondary devices

    Quote Originally Posted by ash25 View Post
    I can try to install the proprietary nVidia driver but I would have to end up disabling KMS and IIRC i915 requires KMS to function efficiently. I'm willing to do this if someone can confirm that the nvidia proprietary driver is mandatory for the detection of HDMI Digital audio output devices.
    I note this wiki : nouveau Wiki - FeatureMatrix - where 2nd last line in the table has some HDMI audio entries. I do not know if that table is current, or out of date.

  7. #7
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: HDMI Audio Output to secondary devices

    Looking more closely at /proc/asound information, I found out that the HDMI (I believe the intel video driver controls this) audio device seems to be shown under /proc/asound/card0/codec#3

    Any idea if I can add a device under ALSA using this information (hw:0,3 is it ?).

    I've added the info from both codec#3 (HDMI) and codec#0 (the analog audio device)

    Code:
    $ cat /proc/asound/card0/codec#3
    Codec: Intel PantherPoint HDMI
    Address: 3
    AFG Function Id: 0x1 (unsol 0)
    Vendor Id: 0x80862806
    Subsystem Id: 0x80860101
    Revision Id: 0x100000
    No Modem Function Group found
    Default PCM:
        rates [0x0]:
        bits [0x0]:
        formats [0x0]:
    Default Amp-In caps: N/A
    Default Amp-Out caps: N/A
    GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
    Node 0x02 [Audio Output] wcaps 0x6611: 8-Channels Digital
      Converter: stream=0, channel=0
      Digital: Enabled
      Digital category: 0x0
      PCM:
        rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
        bits [0x1e]: 16 20 24 32
        formats [0x5]: PCM AC3
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
    Node 0x03 [Audio Output] wcaps 0x6611: 8-Channels Digital
      Converter: stream=0, channel=0
      Digital: Enabled
      Digital category: 0x0
      PCM:
        rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
        bits [0x1e]: 16 20 24 32
        formats [0x5]: PCM AC3
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
    Node 0x04 [Audio Output] wcaps 0x6611: 8-Channels Digital
      Converter: stream=0, channel=0
      Digital: Enabled
      Digital category: 0x0
      PCM:
        rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
        bits [0x1e]: 16 20 24 32
        formats [0x5]: PCM AC3
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
    Node 0x05 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x00 0x80]
      Pincap 0x09000094: OUT Detect HBR HDMI DP
      Pin Default 0x58560010: [N/A] Digital Out at Int HDMI
        Conn = Digital, Color = Unknown
        DefAssociation = 0x1, Sequence = 0x0
      Pin-ctls: 0x40: OUT
      Unsolicited: tag=00, enabled=0
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
      Connection: 1
         0x02
    Node 0x06 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
      Control: name="HDMI/DP,pcm=3 Jack", index=0, device=0
      Control: name="IEC958 Playback Con Mask", index=0, device=0
      Control: name="IEC958 Playback Pro Mask", index=0, device=0
      Control: name="IEC958 Playback Default", index=0, device=0
      Control: name="IEC958 Playback Switch", index=0, device=0
      Control: name="ELD", index=0, device=3
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x00 0x00]
      Pincap 0x09000094: OUT Detect HBR HDMI DP
      Pin Default 0x18560020: [Jack] Digital Out at Int HDMI
        Conn = Digital, Color = Unknown
        DefAssociation = 0x2, Sequence = 0x0
      Pin-ctls: 0x00:
      Unsolicited: tag=01, enabled=1
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
      Connection: 1
         0x03
    Node 0x07 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x00 0x80]
      Pincap 0x09000094: OUT Detect HBR HDMI DP
      Pin Default 0x58560030: [N/A] Digital Out at Int HDMI
        Conn = Digital, Color = Unknown
        DefAssociation = 0x3, Sequence = 0x0
      Pin-ctls: 0x40: OUT
      Unsolicited: tag=00, enabled=0
      Power states:  D0 D3 EPSS
      Power: setting=D0, actual=D0
      Connection: 1
         0x04
    Node 0x08 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Code:
    $ cat /proc/asound/card0/codec#0
    Codec: Realtek ALC269VB
    Address: 0
    AFG Function Id: 0x1 (unsol 1)
    Vendor Id: 0x10ec0269
    Subsystem Id: 0x10431507
    Revision Id: 0x100100
    No Modem Function Group found
    Default PCM:
        rates [0x560]: 44100 48000 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
    Default Amp-In caps: N/A
    Default Amp-Out caps: N/A
    GPIO: io=2, o=0, i=0, unsolicited=1, wake=0
      IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
      IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
    Node 0x02 [Audio Output] wcaps 0x1d: Stereo Amp-Out
      Control: name="Headphone Playback Volume", index=0, device=0
        ControlAmp: chs=3, dir=Out, idx=0, ofs=0
      Device: name="ALC269VB Analog", type="Audio", device=0
      Amp-Out caps: ofs=0x57, nsteps=0x57, stepsize=0x02, mute=0
      Amp-Out vals:  [0x4d 0x4d]
      Converter: stream=0, channel=0
      PCM:
        rates [0x560]: 44100 48000 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
    Node 0x03 [Audio Output] wcaps 0x1d: Stereo Amp-Out
      Control: name="Speaker Playback Volume", index=0, device=0
        ControlAmp: chs=3, dir=Out, idx=0, ofs=0
      Amp-Out caps: ofs=0x57, nsteps=0x57, stepsize=0x02, mute=0
      Amp-Out vals:  [0x4d 0x4d]
      Converter: stream=0, channel=0
      PCM:
        rates [0x560]: 44100 48000 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
    Node 0x04 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x05 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
      Converter: stream=0, channel=0
      Digital:
      Digital category: 0x0
      PCM:
        rates [0x5e0]: 44100 48000 88200 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
    Node 0x07 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x08 [Audio Input] wcaps 0x10011b: Stereo Amp-In
      Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
      Amp-In vals:  [0x8b 0x8b]
      Converter: stream=0, channel=0
      SDI-Select: 0
      PCM:
        rates [0x560]: 44100 48000 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
      Connection: 1
         0x23
    Node 0x09 [Audio Input] wcaps 0x10011b: Stereo Amp-In
      Control: name="Capture Switch", index=0, device=0
      Control: name="Capture Volume", index=0, device=0
      Device: name="ALC269VB Analog", type="Audio", device=0
      Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
      Amp-In vals:  [0x11 0x11]
      Converter: stream=0, channel=0
      SDI-Select: 0
      PCM:
        rates [0x560]: 44100 48000 96000 192000
        bits [0xe]: 16 20 24
        formats [0x1]: PCM
      Connection: 1
         0x22
    Node 0x0a [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
      Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
      Amp-In vals:  [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
      Connection: 5
         0x18 0x19 0x1a 0x1b 0x1d
    Node 0x0c [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
      Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-In vals:  [0x00 0x00] [0x00 0x00]
      Connection: 2
         0x02 0x0b
    Node 0x0d [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
      Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-In vals:  [0x00 0x00] [0x00 0x00]
      Connection: 2
         0x03 0x0b
    Node 0x0e [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x0f [Audio Mixer] wcaps 0x20010a: Mono Amp-In
      Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-In vals:  [0x00] [0x80]
      Connection: 2
         0x02 0x0b
    Node 0x10 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x12 [Pin Complex] wcaps 0x40000b: Stereo Amp-In
      Control: name="Mic Boost Volume", index=0, device=0
        ControlAmp: chs=3, dir=In, idx=0, ofs=0
      Control: name="Mic Phantom Jack", index=0, device=0
      Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
      Amp-In vals:  [0x00 0x00]
      Pincap 0x00000020: IN
      Pin Default 0x90a60930: [Fixed] Mic at Int N/A
        Conn = Digital, Color = Unknown
        DefAssociation = 0x3, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN
    Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x14 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
      Control: name="Speaker Playback Switch", index=0, device=0
        ControlAmp: chs=3, dir=Out, idx=0, ofs=0
      Control: name="Speaker Phantom Jack", index=0, device=0
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x00 0x00]
      Pincap 0x00010014: OUT EAPD Detect
      EAPD 0x2: EAPD
      Pin Default 0x90170110: [Fixed] Speaker at Int N/A
        Conn = Analog, Color = Unknown
        DefAssociation = 0x1, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x40: OUT
      Unsolicited: tag=00, enabled=0
      Connection: 2
         0x0c 0x0d*
    Node 0x15 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x16 [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x17 [Pin Complex] wcaps 0x40010c: Mono Amp-Out
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x80]
      Pincap 0x00000010: OUT
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x00:
      Connection: 1
         0x0f
    Node 0x18 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
      Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
      Amp-In vals:  [0x00 0x00]
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x80 0x80]
      Pincap 0x00001734: IN OUT Detect
        Vref caps: HIZ 50 GRD 80
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN VREF_HIZ
      Unsolicited: tag=00, enabled=0
      Connection: 1
         0x0d
    Node 0x19 [Pin Complex] wcaps 0x40008b: Stereo Amp-In
      Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
      Amp-In vals:  [0x00 0x00]
      Pincap 0x00001724: IN Detect
        Vref caps: HIZ 50 GRD 80
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN VREF_HIZ
      Unsolicited: tag=00, enabled=0
    Node 0x1a [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
      Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
      Amp-In vals:  [0x00 0x00]
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x80 0x80]
      Pincap 0x0000003c: IN OUT HP Detect
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN
      Unsolicited: tag=00, enabled=0
      Connection: 2
         0x0c* 0x0d
    Node 0x1b [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
      Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x2f, mute=0
      Amp-In vals:  [0x00 0x00]
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x80 0x80]
      Pincap 0x00000034: IN OUT Detect
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN
      Unsolicited: tag=00, enabled=0
      Connection: 2
         0x0c* 0x0d
    Node 0x1c [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x1d [Pin Complex] wcaps 0x400000: Mono
      Pincap 0x00000020: IN
      Pin Default 0x40089b2d: [N/A] Line Out at Ext N/A
        Conn = DIN, Color = Pink
        DefAssociation = 0x2, Sequence = 0xd
        Misc = NO_PRESENCE
      Pin-ctls: 0x20: IN
    Node 0x1e [Pin Complex] wcaps 0x400381: Stereo Digital
      Pincap 0x00000014: OUT Detect
      Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
        Conn = 1/8, Color = Black
        DefAssociation = 0xf, Sequence = 0x0
        Misc = NO_PRESENCE
      Pin-ctls: 0x40: OUT
      Unsolicited: tag=00, enabled=0
      Connection: 1
         0x06
    Node 0x1f [Vendor Defined Widget] wcaps 0xf00000: Mono
    Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
      Processing caps: benign=0, ncoeff=25
    Node 0x21 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
      Control: name="Headphone Playback Switch", index=0, device=0
        ControlAmp: chs=3, dir=Out, idx=0, ofs=0
      Control: name="Headphone Jack", index=0, device=0
      Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-Out vals:  [0x00 0x00]
      Pincap 0x0000001c: OUT HP Detect
      Pin Default 0x04211020: [Jack] HP Out at Ext Right
        Conn = 1/8, Color = Black
        DefAssociation = 0x2, Sequence = 0x0
      Pin-ctls: 0xc0: OUT HP
      Unsolicited: tag=01, enabled=1
      Connection: 2
         0x0c* 0x0d
    Node 0x22 [Audio Selector] wcaps 0x30010b: Stereo Amp-In
      Amp-In caps: N/A
      Amp-In vals:  [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
      Connection: 7
         0x18 0x19 0x1a 0x1b 0x1d 0x0b 0x12*
    Node 0x23 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
      Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
      Amp-In vals:  [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
      Connection: 6
          0x18 0x19 0x1a 0x1b 0x1d 0x0b
    Haswell i7 4700 | 16GB DDR2400 | ASUS Z87-Pro | 3TB + 3x4TB mdadm5 + 3x1.5TB mdadm5
    Tumbleweed x86_64
    13.1 x86_64

  8. #8
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: HDMI Audio Output to secondary devices

    I tried Ubuntu 12.04 LTS, and HDMI audio output works out-of-the-box as soon as I plug in a HDMI TV

    In addition cat /proc/asound/cards shows the HDMI output device too. Only the i915 and nouveau drivers were loaded for this to work.So I do not see this as an issue of having the proprietary nvidia drivers.

    I'm adding the content of all /proc/asound information on Ubuntu and openSUSE.
    Output of /proc/asound from Ubuntu 12.04 LTS and 3.5 kernel - Pastebin.com

    Output of /proc/asound on openSUSE 12.2rc2 linux-3.6rc1 - Pastebin.com

    In terms of difference between the 2 I noticed that the following extra files are being shown in the procfs in Ubuntu:
    Code:
    /proc/asound/card0/pcm3p/sub0/prealloc_max
    /proc/asound/card0/pcm3p/sub0/prealloc
    /proc/asound/card0/pcm3p/sub0/status
    /proc/asound/card0/pcm3p/sub0/sw_params
    /proc/asound/card0/pcm3p/sub0/hw_params
    /proc/asound/card0/pcm3p/sub0/info
    /proc/asound/card0/pcm3p/info
    And pcm3p appears to the HDMI output device:
    Code:
    $ cat /proc/asound/card0/pcm3p/info
    card: 0
    device: 3
    subdevice: 0
    stream: PLAYBACK
    id: HDMI 0
    name: HDMI 0
    subname: subdevice #0
    class: 0
    subclass: 0
    subdevices_count: 1
    subdevices_avail: 1
    
    $ cat /proc/asound/card0/pcm3p/sub0/info
    card: 0
    device: 3
    subdevice: 0
    stream: PLAYBACK
    id: HDMI 0
    name: HDMI 0
    subname: subdevice #0
    class: 0
    subclass: 0
    subdevices_count: 1
     subdevices_avail: 1
    I also read on the Ubuntu forums that even the 3.2 kernels worked fine for HDMI audio output. So I really doubt it has got anything to do with the kernel version.It sounds more like a difference of alsa configuration and how it detects PCM output devices.

    Any further pointers to get this HDMI audio device listed under alsa ?
    PS: Mods - Do you think this thread could be moved to the Multimedia forum - I do not see this in anyway being related to openSUSE pre-release/Beta stuff. More people might view it there.
    Haswell i7 4700 | 16GB DDR2400 | ASUS Z87-Pro | 3TB + 3x4TB mdadm5 + 3x1.5TB mdadm5
    Tumbleweed x86_64
    13.1 x86_64

  9. #9
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: HDMI Audio Output to secondary devices

    Ok - I finally figured out the problem - it was the 3.6rc1 kernel I had built.

    I tried the 3.4.6-1.1 kernel that came with 12.2 RC2 and HDMI audio works out-of-the-box without any issues Could it be that there are few patches used by openSUSE and Ubuntu distros - which are not part of the upstream kernel - that could be causing this issue ?

    The reason I had switched to using a newer kernel was to get asus-wmi module to work better, and better power management support for ivy bridge.

    I think the current openSUSE-factory git tree is at 3.5. I'll try to built it with the patches and see if I can get the asus-wmi also to work there
    Haswell i7 4700 | 16GB DDR2400 | ASUS Z87-Pro | 3TB + 3x4TB mdadm5 + 3x1.5TB mdadm5
    Tumbleweed x86_64
    13.1 x86_64

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •