Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: $PATH setting not being used ??

  1. #11

    Default Re: $PATH setting not being used ??

    Quote Originally Posted by hcvv View Post
    The first line starting with #! (called the "shebang") is a must.
    Not to be confused with "shubang"!

  2. #12
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: $PATH setting not being used ??

    Quote Originally Posted by please_try_again View Post
    Not to be confused with "shubang"!
    Well, I tried all sh?bang in Wikipedia. shabang redirects to shebang. All the others, including shubang, fail to produce a real Wikipedia page (all in the English Wikipedia,, not in the Banglish part).

    Bangerdebangbang-bang-bang.
    Henk van Velden

  3. #13

    Default Re: $PATH setting not being used ??

    On 08/01/12 08:46, hcvv pecked at the keyboard and wrote:
    > please_try_again;2477648 Wrote:
    >> Not to be confused with "shubang"!

    > Well, I tried all sh?bang in Wikipedia. shabang redirects to shebang.
    > All the others, including shubang, fail to produce a real Wikipedia page
    > (all in the English Wikipedia,, not in the Banglish part).
    >
    > Bangerdebangbang-bang-bang.
    >
    >

    The explanation under shebang seems to provide what you are looking for.
    Did you actually read it?


  4. #14
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: $PATH setting not being used ??

    Quote Originally Posted by kensch View Post
    On 08/01/12 08:46, hcvv pecked at the keyboard and wrote:
    > please_try_again;2477648 Wrote:
    >> Not to be confused with "shubang"!

    > Well, I tried all sh?bang in Wikipedia. shabang redirects to shebang.
    > All the others, including shubang, fail to produce a real Wikipedia page
    > (all in the English Wikipedia,, not in the Banglish part).
    >
    > Bangerdebangbang-bang-bang.
    >
    >

    The explanation under shebang seems to provide what you are looking for.
    Did you actually read it?
    Huh? Who is the "you" here you are addressing?
    Henk van Velden

  5. #15

    Default Re: $PATH setting not being used ??

    Quote Originally Posted by PattiMichelle View Post
    Thanks for the explanation. Some of these weather/climate codes I'm building come right out and say, "this code expects csh" and some codes don't, so I look for hints, like seeing a "setenv" suggestion (by the code's docs) suggests csh, but "export" suggests bash. Some docs are kind enough to we non-experts to give both. Some codes don't come out and actually tell you - so it gets kinda tricky. It seems like when I've seen "setenv" suggestions in the docs, they usually go along with suggestions to prepend certain directories into the "path" (i.e., instead of PATH). But when I see instructions for bash, it's in caps (like PATH and LD_LIBRARY_PATH). I guess these are shell-specific conventions (caps or not). Unfortunately, I learned linux starting with a GUI so I'm kinda lean on these kinds of command line underpinnings. Live and learn and thank GOD for user forums and the very kind, supportive folks who are selflessly on here!!!! Patricia
    Well it sounds like you're well underway... awesome. I think you'll appreciate the command line, once some of the voodoo magic fizzles away

  6. #16

    Default Re: $PATH setting not being used ??

    Apparently not everything is in Wikipedia yet. This is a shubang, also written shu-bang or choubang. But people normally don't write it. Totally out of topic here! Sorry. I was just kidding (and assuming that every Dutchman would know that). And it's different from a shebang (or sha-bang), although after using the former (shu-bang) for a too long period of time, you might not be able to tell which is what or pronounce it correctly.

  7. #17
    josephkk NNTP User

    Default Re: $PATH setting not being used ??

    On Wed, 01 Aug 2012 12:46:04 GMT, hcvv <hcvv@no-mx.forums.opensuse.org>
    wrote:

    >
    >please_try_again;2477648 Wrote:
    >> Not to be confused with "shubang"!

    >Well, I tried all sh?bang in Wikipedia. shabang redirects to shebang.
    >All the others, including shubang, fail to produce a real Wikipedia page
    >(all in the English Wikipedia,, not in the Banglish part).
    >
    >Bangerdebangbang-bang-bang.


    Say, are you making bangers and mash?

    ?-)

  8. #18
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: $PATH setting not being used ??

    On 2012-08-01 09:36, hcvv wrote:
    > In short and loosely, when an executable is started by the kernel (is
    > made to run as a process) and it starts wiith a shebang (thus not being
    > a binary executable), the interpreter is started instead and the script
    > given to it as the first parameter field.


    And you can add parameters to the shebang line.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #19
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: $PATH setting not being used ??

    Thanks, Henk! The things you learn on this forum!!

  10. #20
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: $PATH setting not being used ??

    banglish - I like it :-)

    Quote Originally Posted by josephkk View Post
    On Wed, 01 Aug 2012 12:46:04 GMT, hcvv <hcvv@no-mx.forums.opensuse.org>
    wrote:

    >
    >please_try_again;2477648 Wrote:
    >> Not to be confused with "shubang"!

    >Well, I tried all sh?bang in Wikipedia. shabang redirects to shebang.
    >All the others, including shubang, fail to produce a real Wikipedia page
    >(all in the English Wikipedia,, not in the Banglish part).
    >
    >Bangerdebangbang-bang-bang.


    Say, are you making bangers and mash?

    ?-)

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •