Results 1 to 8 of 8

Thread: yast2 downloading and installation of applications asking for proxy password

  1. #1

    Default yast2 downloading and installation of applications asking for proxy password

    Hi I have recently installed OpenSuse and have been using all Flavors of Linux for many many years now and when I select applications in Yast software management and while the download and installation process a dialog appears sometimes asking for a proxy password can you advise as to where this dialog is coming from?

    I have a screengrab but im not sure if it attached to post correctly!

    [IMG]/media/FA42-19F5/pictures/snapshot1.png[/IMG]

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,305
    Blog Entries
    2

    Default Re: yast2 downloading and installation of applications asking for proxy password

    You have to upload your image to any of zillions of possible sites on the Internet before you can link to it (sorry, unless your machine is connected to the Internet 100% of the time and the link is a valid URL it won't work). Options include Flicker, pintor, github, google sites, more.

    Probably more to the point are
    - Are you really connecting from behind a proxy firewall?
    - Has your machine been properly joined to the Network Security in your LAN, eg Active Directory, openLDAP, etc
    - Do you have any kind of control or can communicate to whoever is managing your Proxy Firewall? - This can be informative to know what kind of authentication is being used to permit Linux boxes like yours access to the Internet.

    TS

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: yast2 downloading and installation of applications asking forproxy password

    If you are running KDE and the apper monitor service is enabled it can
    have such an annoying effect.
    What happens is that yast locks the rpm database (of course) and if at
    the same time packagekit (this nasty little online update applets
    bavckend) tries exactly during that time to refresh its database which
    it cannot do it spits out a dialog which asks for proxy settings (duh).
    Disable it and this should disappear.

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10



  4. #4

    Default Re: yast2 downloading and installation of applications asking for proxy password

    Quote Originally Posted by tsu2 View Post
    You have to upload your image to any of zillions of possible sites on the Internet before you can link to it (sorry, unless your machine is connected to the Internet 100% of the time and the link is a valid URL it won't work). Options include Flicker, pintor, github, google sites, more.

    Probably more to the point are
    - Are you really connecting from behind a proxy firewall?
    - Has your machine been properly joined to the Network Security in your LAN, eg Active Directory, openLDAP, etc
    - Do you have any kind of control or can communicate to whoever is managing your Proxy Firewall? - This can be informative to know what kind of authentication is being used to permit Linux boxes like yours access to the Internet.

    TS
    I am using a star based hub to access point with firewall on desktop no proxy as to my knowledge.
    no active directory or LDAP etc just desktop installation and setup
    I have full control over my firewall on my desktop I have i have i think http,https server ports open and samba client as when the installation is done i disconnect my development test machine from internet and use it on a local hub but during installation i get this proxy dialog!

  5. #5

    Default Re: yast2 downloading and installation of applications asking forproxy password

    Yes KDE and i think apper is set to default to open installation files on i think when i double click on an install file but i use yast installation on rpms i install that way. But in this instance I am using yast and its downloading and installing applications and the dialog just appears!.

    I think i have over the last while experienced a lock on yast where packagekit is running in background and yast asks to ask packagekit to quit but it doesnt so my solution to this problem was to open a console and do sudo ps aux | grep packagekit and then to kill packagekit via sudo kill -9 pid_of_packagekit.

    Thanks to all for replies

  6. #6
    dd@home.dk NNTP User

    Default Re: yast2 downloading and installation of applications asking forproxy password

    On 07/25/2012 05:36 PM, michaelcl2012 wrote:
    > but during installation i get this proxy dialog!


    five things:

    1. please tell use the operating system and version you are using

    2. and the desktop environment in use, if you have one

    3.. please upload your image to paste.opensuse.org and return here with
    its URL

    4. [did you see Martin's post?] if you are using the thing in your
    panel/tray named apper or kpackagekit or packagekit (it has different
    names depending on your desktop environment and OS version) to install
    software: do NOT use it, it arrives broken....and can cause conflict
    even when using YaST...just right click it an select "disable" (or
    something like that...many use YaST to uninstall it--i did)

    5. you say you see this notivication 'sometimes', can you associate
    other events/actions with when you see it, or not?

    --
    dd


  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: yast2 downloading and installation of applications asking forproxy password

    Am 25.07.2012 17:46, schrieb michaelcl2012:
    >
    > I think i have over the last while experienced a lock on yast where
    > packagekit is running in background and yast asks to ask packagekit
    > to quit but it doesnt so my solution to this problem was to open a
    > console and do sudo ps aux | grep packagekit and then to kill
    > packagekit via sudo kill -9 pid_of_packagekit.
    >

    But you did not disable it and when it happens the other way around that
    yast is the blocking part and the packagekit daemon wants to access
    while yast is open it gives no meaningful info or is just silent it
    asks instead for a proxy.
    So I see two options:
    1) you just click the dialog away and ignore it popping up
    2) you disable the packagekit daemon (and as consequence the apper
    update monitor)

    --
    PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
    ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
    eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10



  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: yast2 downloading and installation of applications asking forproxy password

    On Tue, 24 Jul 2012 21:06:02 +0000, michaelcl2012 wrote:

    > Hi I have recently installed OpenSuse and have been using all Flavors of
    > Linux for many many years now and when I select applications in Yast
    > software management and while the download and installation process a
    > dialog appears sometimes asking for a proxy password can you advise as
    > to where this dialog is coming from?



    It seems you configured a proxy. Look in "/etc/sysconfig/proxy". What
    type of network do you have? Home, business, college?

    > I have a screengrab but im not sure if it attached to post correctly!
    >
    > [image: /media/FA42-19F5/pictures/snapshot1.png]


    Nope. That's your local path.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" (Minas Tirith))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •