Results 1 to 5 of 5

Thread: Trying to install latest OpenFOAM, OpenMPI (and glibc??)

  1. #1

    Default Trying to install latest OpenFOAM, OpenMPI (and glibc??)

    Hi all,

    I have a fresh install of OpenSUSE 12.1 and am trying to install a few pieces of software - particularly OpenFOAM ( The OpenFOAM&#174 Foundation ).

    I've tracked down the RPMs required (the link from their website was broken but I found a mirror) and successfully installed scotch and paraview (easily; clicked on the RPMs and apper installed them for me, no troubles).

    However, when I try to install OpenFOAM by the same method I get an error that a dependency on OpenMPI 1.5 (.x) is unresolvable. The SUSE repositories only contain up to 1.4.x. So, I download an RPM of OpenMPI 1.5 from pbone, and attempted to install at the same time. This time, the version of glibc (2.15) that OpenMPI 1.5 requires isn't available (only glibc 2.14 on the OpenSUSE repos).

    You see where I'm heading (down a rabbit hole). I don't want to manually resolve dependencies for my entire system (figuring that by the time I'm messing with glibc, this could be a very deep hole).

    BUT...

    I can't find the right repositories to add to allow apper to do it's job.

    There's a potential solution using 'GeekoCFD' appliance from the SUSE Studio, which says they've used Third Party OpenMPI - but I have partitions I want to retain and therefore don't want to wipe the entire drive to install one of their images. I've googled for Third Party OpenMPI and can't find the packages they're mentioning.

    --
    Can anybody guide me in the best practice to use in this kind of situation please? (By 'best' I mean most user friendly to achieve a robust result...).

    Thanks for any help, and best regards

    Tom Clark

  2. #2
    dd@home.dk NNTP User

    Default Re: Trying to install latest OpenFOAM, OpenMPI (and glibc??)

    > Can anybody guide me in the best practice to use in this kind of
    > situation please? (By 'best' I mean most user friendly to achieve a
    > robust result...).


    when you go to the maker's site and download the latest and greatest, it
    is (almost) always gonna be based on the latest and greatest of most
    everything it depends on....lots of rabbit holes for you to step into,
    and break a leg there!

    instead of doing all that hard stuff, why not just:
    -go to http://software.opensuse.org/search
    -type in OpenFOAM (or openfoam, or . . .)
    -just below your version (12.1) click "Show unstable packages"
    -read the WARNING, decide to proceed or not
    -choose 64 bit, source, or 1 Click Install [hint: take the last one]
    -follow your nose (and YaST will [usually] do all the dirty work)

    note: most folks here (and me for sure) will tell you to disable or
    uninstall apper--it is born broken and should be avoided (if you like a
    stable and usable system)...instead of touching apper use YaST Software
    Management and Online Update, or zypper...read around if you don't believe:

    [url]https://www.google.com/search?q=site:forums.opensuse.org+apper+disable+OR+uninstall+OR+ignore[url]

    --
    dd http://tinyurl.com/DD-Caveat

  3. #3

    Default Re: Trying to install latest OpenFOAM, OpenMPI (and glibc??)

    Hi dd,

    Thank you for your help - I'll use that route in future for other software, that's been a useful lesson.

    Unfortunately, I need the Arbitrary Mesh Interface in OpenFOAM 2.1.x so need to install that version with OpenMPI 1.5.

    Are there any other ways?

    Best regards,

    Tom

  4. #4
    dd@home.dk NNTP User

    Default Re: Trying to install latest OpenFOAM, OpenMPI (and glibc??)

    > I need the Arbitrary Mesh Interface in OpenFOAM 2.1.x

    if you _need_ that version, then you have to meet its needs (aka:
    dependencies)...

    _and_ the needs of all the dependencies...

    so, of course, if you don't already have those (like in 12.1) then you
    have to get them..

    as you were already doing: it is just step by step until you have
    discovered all the dependencies (and their dependencies) and satisified
    them all....

    the process is routinely termed "dependency hell"..

    an alternative _might_ be to wait and see what is released with openSUSE
    12.2, (it might just have all you need)...you could download the latest
    testing version of that and see what it has in the way of OpenMPI,
    glibc, etc etc etc...grab it here: http://software.opensuse.org/developer/

    NOTE: 12.2 is TESTING software, don't expose your only copy of data to
    it! and, when you run into trouble [note i didn't write 'if'] post to
    the pre-release/beta forum http://tinyurl.com/2du7r4s or the factory
    mail list..

    _or_ pick a different distro (born with the dependencies), but i do not
    know which distro might be the best for that..

    maybe someone else has an idea!

    --
    dd

  5. #5

    Default Re: Trying to install latest OpenFOAM, OpenMPI (and glibc??)

    t clark wrote:
    > Unfortunately, I need the Arbitrary Mesh Interface in OpenFOAM 2.1.x so
    > need to install that version with OpenMPI 1.5.
    >
    > Are there any other ways?


    I'm a bit confused. Looking at the OpenFOAM install instructions for
    openSUSE <http://www.openfoam.org/download/suse.php>, they seem to
    suggest that even openmpi-1.3.2 is suitable, so I'm not sure why there's
    a problem with 1.4 and you feel the need for 1.5? It seems like you have
    a problem with the OpenFOAM instructions, which you are suggesting are
    broken. So I think you should bug report them as suggested on that page.

    Also, presumably somebody on an openFOAM forum or mailing list is more
    likely to have experience of installing it?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •