Results 1 to 8 of 8

Thread: How do I stop screen from blanking out during a movie ?

  1. #1

    Default How do I stop screen from blanking out during a movie ?

    Hello,

    Just converted over from Mandriva to SUSE - install of 12.1 64-bit KDE was very easy!!

    When I am watching a movie or streaming video, the screen will blank out after about 10 to 15 minutes. I have disabled the screen saver (set a long time to enable screen saver), so it is not that. I am thinking it a power saving feature that needs to be turned off. I am sure that this is a common problem, but was not able to find the solution with a search (probably not using the right terminology). How do I proceed?? I gather in Mandriva I needed to edit the /etc/X11/xorg.conf file, but switched over before trying that.

    Thanks -- Roger

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,054

    Default Re: How do I stop screen from blanking out during a movie ?

    There's probably a setting somewhere, but what I tend to do is just run:

    xset -dpms

    And that turns off the power saving.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    dd@home.dk NNTP User

    Default Re: How do I stop screen from blanking out during a movie ?

    On 07/18/2012 06:16 PM, rogerh113 wrote:
    > I am thinking
    > it a power saving feature that needs to be turned off. I am sure that
    > this is a common problem


    you are correct, it is a power saving feature, and it is common..

    in the KDE desktop (mine is a little older than yours, so the names may
    be off some) go Personal Settings - Configure Desktop > Hardware > Power
    Management

    on the left two selections Global settings, where you decide what
    profile will be in force for each of the power settings there..

    and, on the left Power Profiles where you decide what each profile does...

    so, if you on the global page set Performance profile for when the
    machine is on main power/plugged into the electricity grid....then go to
    the Power Profiles and adjust the Performance Profile which you will see
    came default set to blank the screen at 10 minutes, or so...so you need
    to (for example) set it to dim the display after 109 minutes, and switch
    the screen off at 111, and then suspend the session at 120, when you
    wake up your machine will be snoozing also...UNLESS while watching the
    movie you see the screen dim OR go blank and wiggle the mouse . . .

    lots of opportunities to tune it to do exactly what you want..

    don't overlook the "Help" button in the lower left corner..

    --
    dd


  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How do I stop screen from blanking out during a movie ?

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: How do I stop screen from blanking out during a movie ?

    Thanks for all of the input - sounds pretty straightforward (now that I know where everything is....).

    Regards -- Roger

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,616
    Blog Entries
    3

    Default Re: How do I stop screen from blanking out during a movie ?

    I haven't tried this with 12.1.

    When using opensuse 11.4, I did:

    Personal settings --> Startup and Shutdown --> Service Manager

    and their I unchecked the box for "Power Management" and also click the "Stop" button to stop the running power management applet.

    Once I had finished with the movie, I rechecked the box for Power Management and restarted it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    dd@home.dk NNTP User

    Default Re: How do I stop screen from blanking out during a movie ?

    On 07/19/2012 10:36 PM, nrickert wrote:
    > Personal settings --> Startup and Shutdown --> Service Manager


    OH! that is cool!!
    and totally new to me--THANKS!

    --
    dd

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How do I stop screen from blanking out during a movie ?

    On 2012-07-20 06:29, dd@home.dk wrote:
    > On 07/19/2012 10:36 PM, nrickert wrote:
    >> Personal settings --> Startup and Shutdown --> Service Manager

    >
    > OH! that is cool!!
    > and totally new to me--THANKS!


    Stopping the power manager might be excessive, I think it does other things, like controlling
    cpu power usage :-?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •